Bug 111882 - modinfo does not work with 2.6
modinfo does not work with 2.6
Status: CLOSED DUPLICATE of bug 116305
Product: Red Hat Raw Hide
Classification: Retired
Component: modutils (Show other bugs)
1.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-11 02:32 EST by Behdad Esfahbod
Modified: 2014-03-16 22:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace modinfo radeon &> radeon.log (50.07 KB, application/gzip)
2004-01-19 01:54 EST, Behdad Esfahbod
no flags Details

  None (edit)
Description Behdad Esfahbod 2003-12-11 02:32:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114 Epiphany/1.0.4

Description of problem:
Trying modinfo on any module under 2.6 kernel (from rawhide) gives a
no module by that name found error.  I guess it's not updated
correctly to work with .ko module extension.

Version-Release number of selected component (if applicable):
modutils-2.4.25-13

How reproducible:
Always

Steps to Reproduce:
1. modinfo radeon
2.
3.
    

Actual Results:  modinfo: radeon: no module by that name found


Expected Results:  radeon module information

Additional info:
Comment 1 Bill Nottingham 2003-12-11 10:18:19 EST
I'll have to check, but I could have sworn that this required a kernel
patch to work right anyway (i.e., to see any modinfo.)
Comment 2 Behdad Esfahbod 2004-01-19 01:54:43 EST
Created attachment 97092 [details]
strace modinfo radeon &> radeon.log

I'm attaching the log of 'strace modinfo radeon'.
It shows that modinfo actually finds the module, as it does lstat64 the right
file, but find nothing.

On the other hand, if I do 'modinfo
/lib/modules/2.6.1-1.43/kernel/drivers/char/drm/radeon.ko' I see the real
module info.

So should be a silly problem in modinfo.  I had a look into code, but more
complicated than a 5 minute fix.  So the search is missing the module.
Comment 3 Bill Nottingham 2004-02-23 23:55:32 EST

*** This bug has been marked as a duplicate of 116305 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:00:22 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.