Bug 111883 - scrollwheel does not work with 2.6 kernel
scrollwheel does not work with 2.6 kernel
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
: 112410 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-11 02:37 EST by Behdad Esfahbod
Modified: 2007-04-18 13:00 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.6.1-1.43
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-18 04:09:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Behdad Esfahbod 2003-12-11 02:37:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114 Epiphany/1.0.4

Description of problem:
ScrollWheel on my USB mouse does not work with 2.6 kernels.  Here is
the simple XFree config generated by kudzu for it:

Section "InputDevice"
                                                                     
                                                                     
# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
        Identifier  "DevInputMice"
        Driver      "mouse"
        Option      "Protocol" "IMPS/2"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5"
        Option      "Emulate3Buttons" "no"
EndSection

I have no idea what's the problem, as it's a USB mouse, not PS2 ;-).

Version-Release number of selected component (if applicable):
2.6.0-0.test11.1.12

How reproducible:
Always

Steps to Reproduce:
1. Give it a roll
2.
3.
    

Actual Results:  Nothing interesting

Expected Results:  A cool scroll in your browser..

Additional info:
Comment 1 Tim Waugh 2003-12-23 08:06:31 EST
*** Bug 112410 has been marked as a duplicate of this bug. ***
Comment 2 Behdad Esfahbod 2004-01-18 04:09:55 EST
It's fixed in kernel-2.6.1-1.43 for me.  Closing.  Open up if you feel
like that.

Note You need to log in before you can comment on or make changes to this bug.