Bug 1118844 - lpf notify doesn't work
Summary: lpf notify doesn't work
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: lpf
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Alec Leamas
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-11 16:42 UTC by Paul DeStefano
Modified: 2015-12-02 16:09 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-02 03:15:09 UTC


Attachments (Terms of Use)

Description Paul DeStefano 2014-07-11 16:42:07 UTC
Description of problem:
I don't understand how and when lpf notify is supposed to inform me of updates available to lpf targets, but it doesn't seem to be working.  An important security update for flash-plugin was release many weeks ago, and I still haven't received a notification.

I think, since I am running lpf-notify, that I show get a pop-up message.  But, also, 'lpf notify' should say something when queried; it returns nothing and exits with code 81.

Version-Release number of selected component (if applicable):
lpf-0.1-6.36e5aa0.fc20.noarch

How reproducible:
Has not worked since I started using lpf a few months ago.

Steps to Reproduce:

This is very difficult to test, perhaps you can think of a better one
1. Install lpf and lpf-<tgt pkg>
2. Build & install target package with lpf
3. Wait for an "update" to the target package to be released
4. Run 'lpf notify'

Actual results:
'lpf notify' quiery returns nothing & exit code 81.

Expected results:
'lpf notify' and lpf-notify should inform user that an update is available to the target package.

Additional info:

Comment 1 Alec Leamas 2014-07-13 19:13:28 UTC
on holiday, will look into into this when I'm back (August).

Comment 2 Paul DeStefano 2014-08-24 21:01:39 UTC
Got snagged by this, today.  Skype stopped working and I went all the way through changing my password before I guessed correctly that my version of the software was so out-of-date that it was disabled for login.

Doesn't help that MS kept this a secret, but I was counting on lpf-notify to help prevent this sort of thing.

Comment 3 Alec Leamas 2014-08-30 08:11:51 UTC
Somehow, this is about the target package version. The current lpf-skype seems to be 4.3.0.37-1. Is this what you have installed?

If so, can anyone reproduce a situation where the target is rolled back to previous version 4.2.0.13-4 and check what lpf-notify displays?

Comment 4 Paul DeStefano 2014-10-29 20:50:00 UTC
Hi Alec,

So, there is a new lpf-skype package and thought I could use it as a test case for lpf-notify.

* I haven't received any alerts from lpf-notify (ever).
* I upgraded lpf-skype package and still no notices.
* I then upgraded lpf to lpf-0.1-8.36e5aa0.fc20.noarch.  Then, I killed lpf-notify and inotifywait processes.  Then I restarted lpf-notify using the command: /bin/bash /usr/share/lpf/scripts/lpf-notify notify-watch /usr/share/lpf/scripts/notify .  Still not notices.

If you could just tell me how lpf-notify is supposed to work, I would look for that action.  But, since I've never seen it work, I don't know if I'm just missing it or if it's actually not working.  What am I looking for?

Comment 5 Paul DeStefano 2014-10-29 21:00:44 UTC
Also, when I run lpf-gui, now, it shows Skype needs to be built.  But, when I try to do that, I get a pop up that says Skype needs to be updated, run lpf-update?.  Then I click okay.  But, I get *two* more pop-up errors that say the build failed.  And that leaves *two* "lpf:skype" windows that say "Updating: skype" but are *both* stuck at the "Build" stage and cannot finish.

skype: installing build dependencies
/usr/share/lpf/scripts/lpf-pkgbuild: line 52: /var/lib/lpf/log/skype.log: Permission denied
skype: downloading sources
Getting http://download.skype.com/linux/skype-4.3.0.37.tar.bz2 to ./skype-4.3.0.37.tar.bz2
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 18.4M  100 18.4M    0     0  1513k      0  0:00:12  0:00:12 --:--:-- 1404k
skype: building
error: File /var/lib/lpf/rpmbuild/SOURCES/skype-4.3.0.37.tar.bz2: No such file or directory
Building target platforms: i686
Building for target i686
skype: build failed
skype: build errors
skype: exiting

Comment 6 Paul DeStefano 2014-10-29 21:03:11 UTC
Aha!  I think I get it now.

When I "reset package data", I immediately get the pop-up message from lpf-notify that Skype is ready to update.  That's great!  I assume that, if I keep the package data(base) clean, that message will pop-up as soon as the new lpf-skype is installed.  (That's how it's supposed to work, right?)

Comment 7 Alec Leamas 2014-10-29 21:55:31 UTC
Hi!

Great input, it's not easy to construct test cases here. Will look into this later this week.

Comment 8 Paul DeStefano 2015-03-30 21:39:07 UTC
Hi Alec,

Hey, I have new info to report.  So, I still haven't ever received any lpf notifications for outdated packages.  But, I see that a new lpf-skype package was installed a while ago, presumably with regular system updates which is what I expect.  So, what I said in comment 6 is either incorrect (that's not how it is supposed to work) or it is broken (that is how it's supposed to work, but it doesn't).

Today, I started the lpf-gui to check on skype and I didn't even get a notification at that point.  But, it showed me immediately that lpf-skype had been updated and the Skype pkg needed to be re-built.  I clicked on "build" and *then* it gave me the notification that a new version of skype was ready and needed to be re-built.  This is wrong and causes problems; if you click on "run lpf-update" it starts *another* build process in parallel and then things break.

Comment 9 Fedora End Of Life 2015-11-04 12:51:58 UTC
This message is a reminder that Fedora 21 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 21. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '21'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 21 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 10 Fedora End Of Life 2015-12-02 03:15:11 UTC
Fedora 21 changed to end-of-life (EOL) status on 2015-12-01. Fedora 21 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.