Bug 1118890 - sed: can't read /var/tmp/initramfs.k6HXBZ/etc/lvm/lvm.conf: No such file or directory
Summary: sed: can't read /var/tmp/initramfs.k6HXBZ/etc/lvm/lvm.conf: No such file or d...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: dracut
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: dracut-maint-list
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1121164 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-11 19:44 UTC by Valdis Kletnieks
Modified: 2014-08-01 09:11 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-01 09:11:26 UTC


Attachments (Terms of Use)

Description Valdis Kletnieks 2014-07-11 19:44:39 UTC
Description of problem:
When running dracut, I get an error message:


/usr/bin/dracut -f -H --no-kernel -o 'busybox qemu btrfs resume dmraid multipath' /boot/initramfs-3.16.0-rc4-01911-g351e3da.img 3.16.0-rc4-01911-g351e3da
sed: can't read /var/tmp/initramfs.k6HXBZ/etc/lvm/lvm.conf: No such file or directory
sed: can't read /var/tmp/initramfs.k6HXBZ/etc/lvm/lvm.conf: No such file or directory

The resulting initrd does in fact boot correctly.

I'm guessing that the problem is this code in 90lvm/module-setup.sh:

        if [ -f /etc/lvm/lvm.conf ]; then
            inst_simple -H /etc/lvm/lvm.conf

Looking through the rest of dracut, almost every other instance expects to
be passed one parameter - the only other user of -H is 95zfcp

[/usr/lib/dracut/modules.d/90lvm]1 rpm -ql dracut | xargs grep inst_simple 2> /dev/null | grep -e -H
/usr/lib/dracut/modules.d/90lvm/module-setup.sh:            inst_simple -H /etc/lvm/lvm.conf
/usr/lib/dracut/modules.d/95zfcp/module-setup.sh:        inst_simple -H /etc/zfcp.conf

And lo and behold, deleting the -H causes the error to go away.

Probably needs fixing in 95zfcp as well....


Version-Release number of selected component (if applicable):
dracut-038-1.fc21.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Harald Hoyer 2014-07-18 15:07:22 UTC
*** Bug 1121164 has been marked as a duplicate of this bug. ***

Comment 2 D. Charles Pyle 2014-07-21 05:27:17 UTC
Seeing the same problem on F21 (branched).

$ rpm -qa dracut*
dracut-network-038-2.fc21.x86_64
dracut-038-2.fc21.x86_64
dracut-tools-038-2.fc21.x86_64
dracut-config-rescue-038-2.fc21.x86_64

Comment 3 Harald Hoyer 2014-07-24 13:12:33 UTC
should be fixed with dracut-038-14.git20140724

Comment 4 Andre Robatino 2014-07-29 17:18:36 UTC
Seems to be fixed. Haven't seen this in the last several kernel updates.


Note You need to log in before you can comment on or make changes to this bug.