Bug 1118923 - anaconda gets stuck at "Probing storage..." when booting on a system with a Windows 8.1 install (UEFI)
Summary: anaconda gets stuck at "Probing storage..." when booting on a system with a W...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 21
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-11 23:58 UTC by Adam Williamson
Modified: 2014-08-26 02:14 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-26 02:14:20 UTC


Attachments (Terms of Use)
storage.log from an affected run (16.37 KB, text/plain)
2014-07-12 00:22 UTC, Adam Williamson
no flags Details
anaconda.log from an affected run (6.59 KB, text/plain)
2014-07-12 00:27 UTC, Adam Williamson
no flags Details
journal output from an affected boot (96.39 KB, text/plain)
2014-07-12 00:33 UTC, Adam Williamson
no flags Details
program.log from an affected run (3.94 KB, text/plain)
2014-07-12 00:35 UTC, Adam Williamson
no flags Details
storage.log from a *BUGGY* 2014-07-17 f21 boot.iso run (16.35 KB, text/plain)
2014-07-17 21:47 UTC, Adam Williamson
no flags Details
anaconda.log from a *BUGGY* 2014-07-17 f21 boot.iso run (10.73 KB, text/plain)
2014-07-17 21:48 UTC, Adam Williamson
no flags Details
program.log from a *BUGGY* 2014-07-17 f21 boot.iso run (3.93 KB, text/plain)
2014-07-17 21:48 UTC, Adam Williamson
no flags Details
journal from a *BUGGY* 2014-07-17 f21 boot.iso run (96.46 KB, text/plain)
2014-07-17 21:49 UTC, Adam Williamson
no flags Details
storage.log from a *WORKING* 2014-07-17 f21 boot.iso run (58.57 KB, text/plain)
2014-07-17 22:01 UTC, Adam Williamson
no flags Details
anaconda.log from a *WORKING* 2014-07-17 f21 boot.iso run (13.62 KB, text/plain)
2014-07-17 22:01 UTC, Adam Williamson
no flags Details
program.log from a *WORKING* 2014-07-17 f21 boot.iso run (22.93 KB, text/plain)
2014-07-17 22:02 UTC, Adam Williamson
no flags Details
journal from a *WORKING* 2014-07-17 f21 boot.iso run (96.25 KB, text/plain)
2014-07-17 22:02 UTC, Adam Williamson
no flags Details

Description Adam Williamson 2014-07-11 23:58:23 UTC
I'm trying to test https://bugzilla.redhat.com/show_bug.cgi?id=1010704 , so I did a Windows 8.1 install in my UEFI test VM. Then I booted the 2014-07-10 nightly boot.iso, again via UEFI. However, I can't run the install, because it reaches the hub and then gets stuck with Installation Source and Installation Destination showing "Probing storage..." and Software Selection showing "Downloading package metadata..."

Will attach logs.

Comment 1 Adam Williamson 2014-07-12 00:22:31 UTC
Created attachment 917457 [details]
storage.log from an affected run

Comment 2 Adam Williamson 2014-07-12 00:27:39 UTC
Created attachment 917458 [details]
anaconda.log from an affected run

Comment 3 Adam Williamson 2014-07-12 00:33:32 UTC
Created attachment 917459 [details]
journal output from an affected boot

Comment 4 Adam Williamson 2014-07-12 00:35:09 UTC
Created attachment 917460 [details]
program.log from an affected run

Comment 5 Adam Williamson 2014-07-12 00:47:35 UTC
packaging.log is empty.

Comment 6 Adam Williamson 2014-07-12 00:52:59 UTC
dlehman thought the 'ntfsresize' process from program.log might be stuck, but 'ps' does not show it running, and re-running it manually doesn't get stuck - it very quickly responds "Minsize (in MB): 248"

Comment 7 Adam Williamson 2014-07-12 07:32:25 UTC
dlehman further asked for 'updated logs', but nothing's changed. there's no indication the ntfsresize command failed or stuck, but for some reason, anaconda doesn't seem to have done anything after running it. there is nothing beyond that point in program.log even now, the VM has been running for nearly 8 hours at this point.

Comment 8 Chris Murphy 2014-07-16 20:46:05 UTC
I tried this in a BIOS VM with a Window created NTFS volume, and can't reproduce with Fedora-Live-Workstation-x86_64-rawhide-20140703.iso which uses: anaconda-21.46-1, py-blivet0.60-1, ntfsprogs-2014.2.15-3

After Begin Installation, it resizes the NTFS volume, but crashes when creating ext4 on sda2, abrt filed bug 1120406.

Comment 9 Adam Williamson 2014-07-16 22:30:18 UTC
Just to be clear: cmurf's attempt was not a true reproduction, he tried with BIOS. this may well be linked to UEFI boot somehow.

Comment 10 Chris Murphy 2014-07-17 16:35:38 UTC
Yes, it was intentional to see if it's a UEFI specific thing. I just tried this with a UEFI VM, can't reproduce this bug here either with
Fedora-Live-Workstation-x86_64-rawhide-20140624.iso with a dnf upgrade to anaconda-21.48-1, python-blivet-0.61-1. It resizes the NTFS volume and installation succeeds.

The target drive NTFS volume is empty, however, because VirtualBox doesn't support UEFI installs of Windows; so I just created a faux target disk with three partitions: Microsoft Reserved, EFI System (FAT32), remainder as NTFS.

Comment 11 Adam Williamson 2014-07-17 21:39:39 UTC
I can still reproduce this on the affected VM with a 2014-07-17 F21 boot.iso nightly, though I did get one successful boot (where hub got to its usual state, didn't stick at Probing storage...). I didn't proceed with that install, just rebooted to see if it would always succeed, but on a second boot, the bug happened.

storage.log does not get past "Running ... ntfsresize -m /dev/vda1", but there is definitely no running ntfsresize process according to ps. There's nothing particularly interesting in the journal.

Comment 12 Adam Williamson 2014-07-17 21:47:43 UTC
Created attachment 918843 [details]
storage.log from a *BUGGY* 2014-07-17 f21 boot.iso run

Comment 13 Adam Williamson 2014-07-17 21:48:15 UTC
Created attachment 918844 [details]
anaconda.log from a *BUGGY* 2014-07-17 f21 boot.iso run

Comment 14 Adam Williamson 2014-07-17 21:48:49 UTC
Created attachment 918845 [details]
program.log from a *BUGGY* 2014-07-17 f21 boot.iso run

Comment 15 Adam Williamson 2014-07-17 21:49:13 UTC
Created attachment 918846 [details]
journal from a *BUGGY* 2014-07-17 f21 boot.iso run

Comment 16 Adam Williamson 2014-07-17 22:01:15 UTC
Created attachment 918849 [details]
storage.log from a *WORKING* 2014-07-17 f21 boot.iso run

Comment 17 Adam Williamson 2014-07-17 22:01:37 UTC
Created attachment 918850 [details]
anaconda.log from a *WORKING* 2014-07-17 f21 boot.iso run

Comment 18 Adam Williamson 2014-07-17 22:02:07 UTC
Created attachment 918851 [details]
program.log from a *WORKING* 2014-07-17 f21 boot.iso run

Comment 19 Adam Williamson 2014-07-17 22:02:26 UTC
Created attachment 918852 [details]
journal from a *WORKING* 2014-07-17 f21 boot.iso run

Comment 20 Chris Murphy 2014-07-18 01:52:39 UTC
I tried this with today's boot.iso also and still can't reproduce it in a vbox uefi VM; although it's a Windows 7 created GPT+NTFS disk. 

So I did a BIOS VM install of Win 8.1, and I still don't get a hang when installing on that either.

In a shall try strace ntfsresize -m /dev/vdaX before running the installer, it might reveal something is wrong before the actual program is even running and that's what's causing the hangup and why ntfsresize isn't listed. Some kind of race?

Comment 21 Adam Williamson 2014-07-18 06:15:03 UTC
it runs fine when I run it manually after the bug occurs, and I did get that one successful run. I don't think ntfsresize per se is really the problem.

Comment 22 Adam Williamson 2014-08-26 02:14:20 UTC
This seems to have gone away as of 'TC3' (an unofficial / unannounced / incomplete Alpha TC, generated 2014-08-24). I did three boots in a row and made it to target disk selection each time.


Note You need to log in before you can comment on or make changes to this bug.