Bug 1120406 - FormatCreateError: ('device does not exist', '/dev/sda2')
Summary: FormatCreateError: ('device does not exist', '/dev/sda2')
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-blivet
Version: 21
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Lehman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:c67baa6f44671736fa85b5507c8...
: 1121398 1126684 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-16 20:41 UTC by Chris Murphy
Modified: 2014-12-02 21:06 UTC (History)
10 users (show)

Fixed In Version: python-blivet-0.68-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-12-02 21:06:39 UTC


Attachments (Terms of Use)
File: anaconda-tb (543.32 KB, text/plain)
2014-07-16 20:41 UTC, Chris Murphy
no flags Details
File: anaconda.log (14.30 KB, text/plain)
2014-07-16 20:41 UTC, Chris Murphy
no flags Details
File: environ (548 bytes, text/plain)
2014-07-16 20:41 UTC, Chris Murphy
no flags Details
File: journalctl (274.82 KB, text/plain)
2014-07-16 20:41 UTC, Chris Murphy
no flags Details
File: lsblk_output (2.35 KB, text/plain)
2014-07-16 20:41 UTC, Chris Murphy
no flags Details
File: nmcli_dev_list (1.54 KB, text/plain)
2014-07-16 20:41 UTC, Chris Murphy
no flags Details
File: os_info (381 bytes, text/plain)
2014-07-16 20:41 UTC, Chris Murphy
no flags Details
File: program.log (29.84 KB, text/plain)
2014-07-16 20:41 UTC, Chris Murphy
no flags Details
File: storage.log (170.17 KB, text/plain)
2014-07-16 20:41 UTC, Chris Murphy
no flags Details
File: ifcfg.log (2.73 KB, text/plain)
2014-07-16 20:41 UTC, Chris Murphy
no flags Details

Description Chris Murphy 2014-07-16 20:41:49 UTC
Version-Release number of selected component:
anaconda-core-21.46-2.fc21.x86_64

The following was filed automatically by anaconda:
anaconda 21.46-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/formats/fs.py", line 383, in doFormat
    raise FormatCreateError("device does not exist", self.device)
  File "/usr/lib/python2.7/site-packages/blivet/formats/fs.py", line 815, in create
    return self.doFormat(options=kwargs.get('options'))
  File "/usr/lib/python2.7/site-packages/blivet/deviceaction.py", line 554, in execute
    options=self.device.formatArgs)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 354, in processActions
    action.execute()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 357, in doIt
    self.devicetree.processActions()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 216, in turnOnFilesystems
    storage.doIt()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 179, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall)
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 227, in run
    threading.Thread.run(self, *args, **kwargs)
FormatCreateError: ('device does not exist', '/dev/sda2')

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Workstation-x86_64-r rootfstype=auto ro rd.live.image elevator=deadline enforcing=0 rd.luks=0 rd.md=0 rd.dm=0 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.16.0-0.rc3.git2.1.fc21.x86_64
other involved packages: python-libs-2.7.7-2.fc21.x86_64, python-blivet-0.60-1.fc21.noarch
product:        Fedora
release:        Fedora release 21 (Rawhide)
type:           anaconda
version:        rawhide

Comment 1 Chris Murphy 2014-07-16 20:41:52 UTC
Created attachment 918521 [details]
File: anaconda-tb

Comment 2 Chris Murphy 2014-07-16 20:41:53 UTC
Created attachment 918522 [details]
File: anaconda.log

Comment 3 Chris Murphy 2014-07-16 20:41:53 UTC
Created attachment 918523 [details]
File: environ

Comment 4 Chris Murphy 2014-07-16 20:41:55 UTC
Created attachment 918524 [details]
File: journalctl

Comment 5 Chris Murphy 2014-07-16 20:41:55 UTC
Created attachment 918525 [details]
File: lsblk_output

Comment 6 Chris Murphy 2014-07-16 20:41:56 UTC
Created attachment 918526 [details]
File: nmcli_dev_list

Comment 7 Chris Murphy 2014-07-16 20:41:57 UTC
Created attachment 918527 [details]
File: os_info

Comment 8 Chris Murphy 2014-07-16 20:41:58 UTC
Created attachment 918528 [details]
File: program.log

Comment 9 Chris Murphy 2014-07-16 20:41:59 UTC
Created attachment 918529 [details]
File: storage.log

Comment 10 Chris Murphy 2014-07-16 20:41:59 UTC
Created attachment 918530 [details]
File: ifcfg.log

Comment 11 Chris Murphy 2014-07-16 21:34:30 UTC
Succeeds with anaconda-21.47-1, python-blivet-0.61-1. Uncertain if the update fixes this or if the problem is transient.

Comment 12 David Lehman 2014-07-17 15:05:45 UTC
This is very similar to 1109244. It seems like a race related to commiting new flags to the partition prior to formatting it. There is an updates for testing in https://bugzilla.redhat.com/show_bug.cgi?id=1109244#c21 if you want to test it.

Comment 13 Brian Lane 2014-07-21 21:40:51 UTC
*** Bug 1121398 has been marked as a duplicate of this bug. ***

Comment 14 Orion Poplawski 2014-08-08 15:56:29 UTC
*** Bug 1126684 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.