Bug 1118950 - T440s DP2 port has max resolution available is 1024x768
Summary: T440s DP2 port has max resolution available is 1024x768
Keywords:
Status: CLOSED DUPLICATE of bug 1117008
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-12 08:18 UTC by Jiri Pirko
Modified: 2015-05-05 01:25 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-13 09:00:41 UTC


Attachments (Terms of Use)
Xorg log (79.52 KB, text/x-log)
2014-07-12 08:18 UTC, Jiri Pirko
no flags Details

Description Jiri Pirko 2014-07-12 08:18:57 UTC
Created attachment 917481 [details]
Xorg log

Description of problem:

I installed F20, updated. Connected my monitor (actually I tried 2 different ones) via DP. xrandr shows max resolution 1024x720. Sometimes it helps if I turn the monitor off and on couple of times and then the correct resolution appears.

Version-Release number of selected component (if applicable):
kernel-3.15.3-200.fc20.x86_64
xorg-x11-drv-intel-2.21.15-7.fc20.x86_64
xorg-x11-server-Xorg-1.14.4-11.fc20.x86_64
xorg-x11-drv-modesetting-0.8.0-2.fc20.x86_64

How reproducible:
95%

Steps to Reproduce:
1. Connect monitor with resolution higher than 1024x768 to T440s
2. run xrandr

Actual results:
DP2 connected primary 1024x768+1920+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768      60.00* 
   800x600       60.32    56.25  
   848x480       60.00  
   640x480       59.94

Expected results:
All modes up to native one are listed.

Additional info:
NA

Comment 1 Jiri Pirko 2014-07-12 08:51:08 UTC
Interesting. I need to add this is happening using a docking station. I found out that the same xrandr output I get when I connect turned off monitor using dsub and dvi cable.

When I remove the laptop from the dock and use dsub to connect to monitor, I see all resolutions:

DP2 connected primary 1024x768+1920+0 (normal left inverted right x axis y axis) 509mm x 286mm
   1920x1080     60.00 +
   1280x1024     75.02    60.02  
   1152x864      75.00  
   1024x768      75.08    60.00* 
   800x600       75.00    60.32  
   640x480       75.00    60.00  
   720x400       70.08  

It is weird though that I still see DP2 and not VGA1. It is also weird that 1024x768 is selected by default.

But after I do:
xrandr --output DP2 --off ;  xrandr --output DP2 --auto

I see:
DP2 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 509mm x 286mm
   1920x1080     60.00*+
   1280x1024     75.02    60.02  
   1152x864      75.00  
   1024x768      75.08    60.00  
   800x600       75.00    60.32  
   640x480       75.00    60.00  
   720x400       70.08  

Note that my eDP1 resolution is 1920x1080.

Comment 2 Jiri Pirko 2014-07-12 09:12:27 UTC
Sometimes I also see following:

HDMI2 disconnected (normal left inverted right x axis y axis)
  1920x1080 (0x50) 148.500MHz
        h: width  1920 start 2008 end 2052 total 2200 skew    0 clock  67.50KHz
        v: height 1080 start 1084 end 1089 total 1125           clock  60.00Hz

Note that HDMI2 was never connected to anything.

Comment 3 Richard Körber 2014-07-12 10:25:42 UTC
It works again when downgrading to kernel-3.14.8-200.

Seems to be a duplicate of Bug 1117008.

Comment 4 Jiri Pirko 2014-07-13 09:00:41 UTC

*** This bug has been marked as a duplicate of bug 1117008 ***


Note You need to log in before you can comment on or make changes to this bug.