Bug 1119203 - Live snapshot creation reported as failed by engine but created successfully
Summary: Live snapshot creation reported as failed by engine but created successfully
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.5
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: 3.5.0
Assignee: Daniel Erez
QA Contact: Raz Tamir
URL:
Whiteboard: storage
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-14 09:14 UTC by Raz Tamir
Modified: 2016-02-10 18:58 UTC (History)
9 users (show)

Fixed In Version: ovirt-3.5.0_rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-17 12:29:03 UTC
oVirt Team: Storage
scohen: needinfo+


Attachments (Terms of Use)
vdsm and engine logs (471.58 KB, application/x-gzip)
2014-07-14 09:14 UTC, Raz Tamir
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 32580 master MERGED core: explicit warning on live snapshot failure Never
oVirt gerrit 32751 ovirt-engine-3.5 MERGED core: explicit warning on live snapshot failure Never

Description Raz Tamir 2014-07-14 09:14:48 UTC
Created attachment 917707 [details]
vdsm and engine logs

Description of problem:
The engine reports that "Failed to complete snapshot 'snapshot_343074' creation for VM 'vm_0'." but the snapshot created successfully and the volumes created too.


Version-Release number of selected component (if applicable):
ovirt-engine-3.5.0-0.0.master.20140629172257.git0b16ed7.el6.noarch
vdsm-4.16.0-3.git601f786.el6.x86_64


How reproducible:
100%

Steps to Reproduce:
1. Start a live snapshot operation
2. restart VDSM
3.

Actual results:
The snapshot is created and all the volumes exists and the failure message is shown.

Expected results:
the snapshot should succeeded with no Failure message OR the snapshot creation should fail with failure message

Additional info:

Comment 1 Raz Tamir 2014-07-14 12:06:44 UTC
Update:
This bug is not depend on restarting VDSM or engine (https://bugzilla.redhat.com/show_bug.cgi?id=1119236).

*****************************
Description of problem:
Creation of live snapshot ends with failure message from engine side that:
"Failed to complete snapshot 'snapshot_343074' creation for VM 'vm_0'."

The snapshot is actually created successfully and all relevant volumes are exists.

** Closing bug: https://bugzilla.redhat.com/show_bug.cgi?id=1119236


Version-Release number of selected component (if applicable):
ovirt-engine-3.5.0-0.0.master.20140629172257.git0b16ed7.el6.noarch
vdsm-4.16.0-3.git601f786.el6.x86_64


How reproducible:
100%

Steps to Reproduce:
1. Start a live snapshot operation
2. restart VDSM
3.

Actual results:
The snapshot is created and all the volumes exists and the failure message is shown.

Expected results:
the snapshot should succeeded with no Failure message OR the snapshot creation should fail with failure message

Comment 2 Allon Mureinik 2014-07-15 06:41:12 UTC
I don't understand the difference between this one and bug 1119236.
Raz, can you please clarify?

Comment 3 Raz Tamir 2014-07-15 06:50:07 UTC
This bug is about normal live snapshot creation that ends with the above error message. bug 1119236 is about restarting the engine during a live snapshot.
The reason I opened it is because I thought that the engine restart is the problem but then I performed a live snapshot with no engine restart and figured that the problem is not the engine restart.

Comment 4 Daniel Erez 2014-07-15 07:00:28 UTC
According to the logs, it seems like another duplicate of bug 870928 and bug 1064419. The failure has occurred during the live snapshot operation. In which, according to the design, an event log is displayed [1] (and an error log [2]); but no rollback is done on the snapshot (as it's still usable). See bug 870928 - comment #4.

[1] Message: Failed to create live snapshot 'snapshot_343074' for VM 'vm_0'. VM restart is recommended.

[2] VDSErrorException: Failed to SnapshotVDS, error = Snapshot failed, code = 48 (Failed with error SNAPSHOT_FAILED and code 48). VM will still be configured to the new created snapshot

Comment 5 Daniel Erez 2014-07-15 07:01:02 UTC

*** This bug has been marked as a duplicate of bug 870928 ***

Comment 6 Raz Tamir 2014-07-15 10:05:09 UTC
The snapshot is not usable after this scenario - bug 1119691
Reopening the bug

Comment 7 Daniel Erez 2014-07-15 10:18:01 UTC
(In reply to ratamir from comment #6)
> The snapshot is not usable after this scenario - bug 1119691
> Reopening the bug

Hi Raz,

What do you mean by 'not usable'? Snapshot volumes have been created?
What is the scenario? restart vdsm during live snapshot?

Comment 8 Raz Tamir 2014-07-15 10:34:40 UTC
Hi Daniel,
Sorry for the not so clear bug and changing the reason.
The bug is that when creating a live snapshot, the engine report that:
"Failed to complete snapshot 'snapshot_343074' creation for VM 'vm_0'."
Restarting vdsm is out of the scope of this bug. I thought that the reason is the vdsm restart but Live snapshot "fails" even without the vdsm restart.
You mentioned in comment 4 that "...no rollback is done on the snapshot (as it's still usable).", so I checked this and the snapshot is not usable (as described in bug 1119691).
And the snapshot volume created.

Comment 9 Daniel Erez 2014-07-15 17:41:10 UTC
On failure of live snapshot, using the newly created snapshot might lead to data inconsistency (similar to bug 870928). As roll-back is not applicable in such scenario (the created snapshot could be deleted when the VM is down), we might want to add/replace the warning with an error audit log to explicitly state that using the created snapshot might cause data inconsistency. Thoughts?

Comment 13 Raz Tamir 2014-10-02 05:35:06 UTC
Verified - The live snapshot created successfully

Comment 14 Sandro Bonazzola 2014-10-17 12:29:03 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.