Bug 1119236 - Restart engine during live snapshot creation reported as failed by engine but created successfully
Summary: Restart engine during live snapshot creation reported as failed by engine but...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.5.0
Assignee: Allon Mureinik
QA Contact: Aharon Canan
URL:
Whiteboard: storage
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-14 10:54 UTC by Raz Tamir
Modified: 2016-02-10 19:43 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-14 12:07:48 UTC
oVirt Team: Storage


Attachments (Terms of Use)
vdsm and engine logs (757.10 KB, application/x-gzip)
2014-07-14 10:54 UTC, Raz Tamir
no flags Details

Description Raz Tamir 2014-07-14 10:54:19 UTC
Created attachment 917748 [details]
vdsm and engine logs

Description of problem:
If restarting the engine during a live snapshot creation,
the engine reports that "Failed to complete snapshot 'snapshot_343077' creation for VM 'vm_0'." but the snapshot created successfully and the volumes created too.

Version-Release number of selected component (if applicable):
ovirt-engine-3.5.0-0.0.master.20140629172257.git0b16ed7.el6.noarch
vdsm-4.16.0-3.git601f786.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Start a live snapshot operation
2. restart engine service
3.

Actual results:
The snapshot is created and all the volumes exists and the failure message is shown.

Expected results:
the snapshot should succeeded with no Failure message OR the snapshot creation should fail with failure message

Additional info:

Comment 1 Sven Kieske 2014-07-14 12:19:38 UTC
Why is this considered "not a bug"?
Doesn't this lead to an inconsistent state in ovirt-engine?

Comment 2 Raz Tamir 2014-07-14 12:25:42 UTC
Update:
This bug is not depend on restarting engine.
The relevant bug is: https://bugzilla.redhat.com/show_bug.cgi?id=1119203


Note You need to log in before you can comment on or make changes to this bug.