Bug 1119380 - AttributeError: 'Flags' object has no attribute 'targetarch'
Summary: AttributeError: 'Flags' object has no attribute 'targetarch'
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kexec-tools
Version: 21
Hardware: All
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: WANG Chao
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:48060d2c5b859bbe25170ddd4a7...
: 1120900 (view as bug list)
Depends On:
Blocks: ARMTracker F21AlphaBlocker
TreeView+ depends on / blocked
 
Reported: 2014-07-14 16:07 UTC by Paul Whalen
Modified: 2014-07-24 07:53 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-24 07:53:12 UTC


Attachments (Terms of Use)
File: anaconda-tb (66.33 KB, text/plain)
2014-07-14 16:07 UTC, Paul Whalen
no flags Details
File: anaconda.log (3.47 KB, text/plain)
2014-07-14 16:07 UTC, Paul Whalen
no flags Details
File: environ (448 bytes, text/plain)
2014-07-14 16:07 UTC, Paul Whalen
no flags Details
File: lsblk_output (1.17 KB, text/plain)
2014-07-14 16:07 UTC, Paul Whalen
no flags Details
File: nmcli_dev_list (1.00 KB, text/plain)
2014-07-14 16:07 UTC, Paul Whalen
no flags Details
File: os_info (377 bytes, text/plain)
2014-07-14 16:07 UTC, Paul Whalen
no flags Details
File: program.log (28.91 KB, text/plain)
2014-07-14 16:07 UTC, Paul Whalen
no flags Details
File: storage.log (67.47 KB, text/plain)
2014-07-14 16:07 UTC, Paul Whalen
no flags Details
File: syslog (45.95 KB, text/plain)
2014-07-14 16:07 UTC, Paul Whalen
no flags Details
File: packaging.log (1.56 KB, text/plain)
2014-07-14 16:07 UTC, Paul Whalen
no flags Details
updates.img against anaconda-21.48-1 (14.68 KB, application/x-raw-disk-image)
2014-07-17 22:07 UTC, Brian Lane
no flags Details

Description Paul Whalen 2014-07-14 16:07:17 UTC
Description of problem:


Version-Release number of selected component:
anaconda-21.47-1

The following was filed automatically by anaconda:
anaconda 21.47-1 exception report
Traceback (most recent call first):
  File "/usr/share/anaconda/addons/com_redhat_kdump/common.py", line 65, in getMemoryBounds
    if flags.targetarch == 'ppc64':
  File "/usr/share/anaconda/addons/com_redhat_kdump/tui/spokes/kdump.py", line 50, in <module>
    lower, upper ,step = getMemoryBounds()
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/common.py", line 600, in collect
    __import__(module_pattern % mod_name)
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/__init__.py", line 159, in _collectActionClasses
    standalones.extend(collect(module_pattern, path, lambda obj: issubclass(obj, standalone_class) and \
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/tui/__init__.py", line 153, in setup
    spokes = self._collectActionClasses(self.paths["spokes"], StandaloneSpoke)
  File "/sbin/anaconda", line 1344, in <module>
    anaconda._intf.setup(ksdata)
AttributeError: 'Flags' object has no attribute 'targetarch'

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   console=ttymxc0,115200 ip=eth0:dhcp inst.ks=nfs:192.168.0.80:/var/exports/tftpboot/wandboard-21-minimal.ks rd.shell
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.16.0-0.rc4.git3.1.fc21.armv7hl
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        21

Comment 1 Paul Whalen 2014-07-14 16:07:19 UTC
Created attachment 917908 [details]
File: anaconda-tb

Comment 2 Paul Whalen 2014-07-14 16:07:20 UTC
Created attachment 917909 [details]
File: anaconda.log

Comment 3 Paul Whalen 2014-07-14 16:07:20 UTC
Created attachment 917910 [details]
File: environ

Comment 4 Paul Whalen 2014-07-14 16:07:21 UTC
Created attachment 917911 [details]
File: lsblk_output

Comment 5 Paul Whalen 2014-07-14 16:07:22 UTC
Created attachment 917912 [details]
File: nmcli_dev_list

Comment 6 Paul Whalen 2014-07-14 16:07:23 UTC
Created attachment 917913 [details]
File: os_info

Comment 7 Paul Whalen 2014-07-14 16:07:24 UTC
Created attachment 917914 [details]
File: program.log

Comment 8 Paul Whalen 2014-07-14 16:07:25 UTC
Created attachment 917915 [details]
File: storage.log

Comment 9 Paul Whalen 2014-07-14 16:07:26 UTC
Created attachment 917916 [details]
File: syslog

Comment 10 Paul Whalen 2014-07-14 16:07:27 UTC
Created attachment 917917 [details]
File: packaging.log

Comment 11 Martin Kolman 2014-07-15 11:57:32 UTC
Anaconda recently dropped the targetarch flag, which also really wasn't the right thing to get current architecture anyway. 

So I've opened a pull request on Github for fixing the kdump addon to use the blivet.arch.getArch() call:
https://github.com/daveyoung/kdump-anaconda-addon/pull/2

Merging the pull request & doing a new build should be enough to fix this issues.

Comment 12 Adam Williamson 2014-07-16 16:45:13 UTC
Discussed at the 2014-07-16 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2014-07-16/f21-blocker-review.2014-07-16-15.59.log.txt . This was verified to prevent text installation from working on any arch, and also prevents the Cloud images from being generated. Accepted as a release blocker per criterion https://fedoraproject.org/wiki/Fedora_21_Alpha_Release_Criteria#Installation_interfaces , "When using a dedicated installer image, the installer must be able to complete an installation using the text, graphical and VNC installation interfaces."

Comment 13 Brian Lane 2014-07-17 22:01:54 UTC
I have found a few more issues that need to be merged before this will work:

https://github.com/daveyoung/kdump-anaconda-addon/pull/3

Please update the package ASAP, breakage in it will block other things (eg. text mode is totally useless right now).

I will also attach an updates.img with the changes.

Comment 14 Brian Lane 2014-07-17 22:07:03 UTC
Created attachment 918855 [details]
updates.img against anaconda-21.48-1

Comment 15 David Shea 2014-07-18 13:07:54 UTC
*** Bug 1120900 has been marked as a duplicate of this bug. ***

Comment 16 Orion Poplawski 2014-07-23 16:08:14 UTC
updates.img works for me with F21a-TC1/21.47-1.

Comment 17 Dave Young 2014-07-24 01:21:54 UTC
Hi, all

I have merged the related fixes to github. Chao, could you update Fedora addon package ASAP, thanks a lot!

Dave

Comment 18 WANG Chao 2014-07-24 07:53:12 UTC
Fixed in kexec-tools-2.0.7-4.fc21:
http://kojipkgs.fedoraproject.org/packages/kexec-tools/2.0.7/4.fc21/


Note You need to log in before you can comment on or make changes to this bug.