Bug 1120900 - AttributeError: 'Flags' object has no attribute 'targetarch'
Summary: AttributeError: 'Flags' object has no attribute 'targetarch'
Keywords:
Status: CLOSED DUPLICATE of bug 1119380
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:48060d2c5b859bbe25170ddd4a7...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-18 00:19 UTC by Mike Ruckman
Modified: 2014-07-18 13:07 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-18 13:07:54 UTC


Attachments (Terms of Use)
File: anaconda-tb (97.61 KB, text/plain)
2014-07-18 00:20 UTC, Mike Ruckman
no flags Details
File: anaconda.log (4.02 KB, text/plain)
2014-07-18 00:20 UTC, Mike Ruckman
no flags Details
File: environ (447 bytes, text/plain)
2014-07-18 00:20 UTC, Mike Ruckman
no flags Details
File: lsblk_output (1.35 KB, text/plain)
2014-07-18 00:20 UTC, Mike Ruckman
no flags Details
File: nmcli_dev_list (1.10 KB, text/plain)
2014-07-18 00:20 UTC, Mike Ruckman
no flags Details
File: os_info (381 bytes, text/plain)
2014-07-18 00:20 UTC, Mike Ruckman
no flags Details
File: program.log (15.58 KB, text/plain)
2014-07-18 00:20 UTC, Mike Ruckman
no flags Details
File: storage.log (31.83 KB, text/plain)
2014-07-18 00:20 UTC, Mike Ruckman
no flags Details
File: syslog (65.99 KB, text/plain)
2014-07-18 00:20 UTC, Mike Ruckman
no flags Details
File: ifcfg.log (1.75 KB, text/plain)
2014-07-18 00:20 UTC, Mike Ruckman
no flags Details
File: packaging.log (1.41 KB, text/plain)
2014-07-18 00:20 UTC, Mike Ruckman
no flags Details

Description Mike Ruckman 2014-07-18 00:19:56 UTC
Description of problem:
Downloaded today's boot.iso and attempted install from both GUI and cmdline based. GUI results in a non-responsive anaconda screen and cmdline install resulted in this backtrace.

Version-Release number of selected component:
anaconda-21.48-1

The following was filed automatically by anaconda:
anaconda 21.48-1 exception report
Traceback (most recent call first):
  File "/usr/share/anaconda/addons/com_redhat_kdump/common.py", line 65, in getMemoryBounds
    if flags.targetarch == 'ppc64':
  File "/usr/share/anaconda/addons/com_redhat_kdump/tui/spokes/kdump.py", line 50, in <module>
    lower, upper ,step = getMemoryBounds()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/common.py", line 600, in collect
    __import__(module_pattern % mod_name)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/__init__.py", line 159, in _collectActionClasses
    standalones.extend(collect(module_pattern, path, lambda obj: issubclass(obj, standalone_class) and \
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/tui/__init__.py", line 153, in setup
    spokes = self._collectActionClasses(self.paths["spokes"], StandaloneSpoke)
  File "/sbin/anaconda", line 1346, in <module>
    anaconda._intf.setup(ksdata)
AttributeError: 'Flags' object has no attribute 'targetarch'

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-rawhide-x86_64 cmdline
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.16.0-0.rc5.git1.1.fc22.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        rawhide

Comment 1 Mike Ruckman 2014-07-18 00:20:02 UTC
Created attachment 918873 [details]
File: anaconda-tb

Comment 2 Mike Ruckman 2014-07-18 00:20:04 UTC
Created attachment 918874 [details]
File: anaconda.log

Comment 3 Mike Ruckman 2014-07-18 00:20:05 UTC
Created attachment 918875 [details]
File: environ

Comment 4 Mike Ruckman 2014-07-18 00:20:07 UTC
Created attachment 918876 [details]
File: lsblk_output

Comment 5 Mike Ruckman 2014-07-18 00:20:09 UTC
Created attachment 918877 [details]
File: nmcli_dev_list

Comment 6 Mike Ruckman 2014-07-18 00:20:11 UTC
Created attachment 918878 [details]
File: os_info

Comment 7 Mike Ruckman 2014-07-18 00:20:14 UTC
Created attachment 918879 [details]
File: program.log

Comment 8 Mike Ruckman 2014-07-18 00:20:16 UTC
Created attachment 918880 [details]
File: storage.log

Comment 9 Mike Ruckman 2014-07-18 00:20:20 UTC
Created attachment 918881 [details]
File: syslog

Comment 10 Mike Ruckman 2014-07-18 00:20:22 UTC
Created attachment 918882 [details]
File: ifcfg.log

Comment 11 Mike Ruckman 2014-07-18 00:20:24 UTC
Created attachment 918883 [details]
File: packaging.log

Comment 12 David Shea 2014-07-18 13:07:54 UTC

*** This bug has been marked as a duplicate of bug 1119380 ***


Note You need to log in before you can comment on or make changes to this bug.