Bug 1119450 - Packstack fails to install on "Error: comparison of String with 7" when installing on CentOS7
Summary: Packstack fails to install on "Error: comparison of String with 7" when insta...
Keywords:
Status: CLOSED DUPLICATE of bug 1117871
Alias: None
Product: RDO
Classification: Community
Component: openstack-packstack
Version: unspecified
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
: ---
Assignee: Martin Magr
QA Contact: Ami Jeain
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-14 19:47 UTC by Yaniv Kaul
Modified: 2014-07-16 07:24 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-16 07:24:52 UTC


Attachments (Terms of Use)

Description Yaniv Kaul 2014-07-14 19:47:26 UTC
Description of problem:
Running on CentOS 7, NOVA network, packstack fails with:
cd /usr/share/openstack-puppet/modules
tar --dereference -cpzf - apache ceilometer certmonger cinder concat firewall glance heat horizon inifile keystone memcached mongodb mysql neutron nova nssdb openstack packstack qpid rabbitmq rsync ssh stdlib swift sysctl tempest vcsrepo vlan vswitch xinetd | ssh -o StrictHostKeyChecking=no -o UserKnownHostsFile=/dev/null root@10.102.34.175 tar -C /var/tmp/packstack/f20fcc0979624767bfe5bf160471bc15/modules -xpzf -
2014-07-14 22:40:10::ERROR::run_setup::920::root:: Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 915, in main
    _main(confFile)
  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 605, in _main
    runSequences()
  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 584, in runSequences
    controller.runAllSequences()
  File "/usr/lib/python2.7/site-packages/packstack/installer/setup_controller.py", line 68, in runAllSequences
    sequence.run(config=self.CONF, messages=self.MESSAGES)
  File "/usr/lib/python2.7/site-packages/packstack/installer/core/sequences.py", line 98, in run
    step.run(config=config, messages=messages)
  File "/usr/lib/python2.7/site-packages/packstack/installer/core/sequences.py", line 44, in run
    raise SequenceError(str(ex))
SequenceError: Error appeared during Puppet run: 10.102.34.175_prescript.pp
Error: comparison of String with 7 failed at /var/tmp/packstack/f20fcc0979624767bfe5bf160471bc15/manifests/10.102.34.175_prescript.pp:15 on node lgdrm920.xiodrm.lab.emc.com
You will find full trace in log /var/tmp/packstack/20140714-223919-KCYfJU/manifests/10.102.34.175_prescript.pp.log

2014-07-14 22:40:10::INFO::shell::81::root:: [10.102.34.175] Executing script:
rm -rf /var/tmp/packstack/f20fcc0979624767bfe5bf160471bc15



Log file:
^[[1;31mWarning: Config file /etc/puppet/hiera.yaml not found, using Hiera defaults^[[0m
^[[1;31mError: comparison of String with 7 failed at /var/tmp/packstack/f20fcc0979624767bfe5bf160471bc15/manifests/10.102.34.175_prescript.pp:15 on node lgdrm920.xiodrm.lab.emc.com
Wrapped exception:
comparison of String with 7 failed^[[0m
^[[1;31mError: comparison of String with 7 failed at /var/tmp/packstack/f20fcc0979624767bfe5bf160471bc15/manifests/10.102.34.175_prescript.pp:15 on node lgdrm920.xiodrm.lab.emc.com^[[0m


Version-Release number of selected component (if applicable):
openstack-packstack-2014.1.1-0.25.dev1208.el7.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Copying Puppet modules and manifests                 [ DONE ]
Applying 10.102.34.175_prescript.pp

10.102.34.175_prescript.pp:                       [ ERROR ]
Applying Puppet manifests                         [ ERROR ]

ERROR : Error appeared during Puppet run: 10.102.34.175_prescript.pp
Error: comparison of String with 7 failed at /var/tmp/packstack/f20fcc0979624767bfe5bf160471bc15/manifests/10.102.34.175_prescript.pp:15 on node lgdrm920.xiodrm.lab.emc.com
You will find full trace in log /var/tmp/packstack/20140714-223919-KCYfJU/manifests/10.102.34.175_prescript.pp.log
Please check log file /var/tmp/packstack/20140714-223919-KCYfJU/openstack-setup.log for more information

Comment 1 Yaniv Kaul 2014-07-14 20:14:51 UTC
Possibly documented @ https://ask.openstack.org/en/question/35705/attempt-of-rdo-aio-install-icehouse-on-centos-7/ , didn't try (and can't patch so much to try it out now), returning to CentOS 6.5.

Comment 2 Kashyap Chamarthy 2014-07-16 07:24:52 UTC

*** This bug has been marked as a duplicate of bug 1117871 ***


Note You need to log in before you can comment on or make changes to this bug.