Bug 1117871 - Could not evaluate: Could not find init script for 'messagebus' - RDO Icehouse AIO on CentOS 7
Summary: Could not evaluate: Could not find init script for 'messagebus' - RDO Icehous...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: RDO
Classification: Community
Component: openstack-puppet-modules
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Gaël Chamoulaud
QA Contact: Ami Jeain
URL:
Whiteboard:
: 1119450 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-09 14:44 UTC by Stephen Gordon
Modified: 2014-09-15 18:51 UTC (History)
10 users (show)

Fixed In Version: openstack-puppet-modules-2014.1-23.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-15 18:51:07 UTC


Attachments (Terms of Use)
RDO AIO CentOS 7 Patch (4.18 KB, patch)
2014-07-18 10:59 UTC, Michael J. Kidd
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 105526 None None None Never

Description Stephen Gordon 2014-07-09 14:44:50 UTC
Preparing servers                                    [ DONE ]
    Installing Dependencies                              [ DONE ]
    Copying Puppet modules and manifests                 [ DONE ]
    Applying 192.169.142.57_prescript.pp
    192.169.142.57_prescript.pp:                         [ DONE ]          
    Applying 192.169.142.57_mysql.pp
    Applying 192.169.142.57_amqp.pp
    192.169.142.57_mysql.pp:                             [ DONE ]      
    192.169.142.57_amqp.pp:                              [ DONE ]      
    Applying 192.169.142.57_keystone.pp
    Applying 192.169.142.57_glance.pp
    Applying 192.169.142.57_cinder.pp
    192.169.142.57_keystone.pp:                          [ DONE ]         
    192.169.142.57_cinder.pp:                            [ DONE ]         
    192.169.142.57_glance.pp:                            [ DONE ]         
    Applying 192.169.142.57_api_nova.pp
    192.169.142.57_api_nova.pp:                          [ DONE ]         
    Applying 192.169.142.57_nova.pp
    192.169.142.57_nova.pp:                           [ ERROR ]       
    Applying Puppet manifests                         [ ERROR ]

    ERROR : Error appeared during Puppet run: 192.169.142.57_nova.pp
    Error: /Service[messagebus]: Could not evaluate: Could not find init script for 'messagebus'
    You will find full trace in log /var/tmp/packstack/20140709-114849-pY1VcY/manifests/192.169.142.57_nova.pp.log
    Please check log file /var/tmp/packstack/20140709-114849-pY1VcY/openstack-setup.log for more information

Moreover if I create /etc/init.d/messagebus , I get attempt to start D-bus in old style :-

        192.169.142.57_nova.pp:                           [ ERROR ]       
        Applying Puppet manifests                         [ ERROR ]

        ERROR : Error appeared during Puppet run: 192.169.142.57_nova.pp
        Error: Could not start Service[messagebus]: Execution of '/etc/init.d/messagebus start' returned 127: Starting D-Bus daemon: /etc/init.d/messagebus: line 26: start-stop-daemon: command not found
        You will find full trace in log /var/tmp/packstack/20140709-170356-4RxF1Q/manifests/192.169.142.57_nova.pp.log
        Please check log file /var/tmp/packstack/20140709-170356-4RxF1Q/openstack-setup.log for more information

Comment 1 Alejandro Cortina 2014-07-11 19:37:23 UTC
I had a different error but I fixed with the same solution provided in:

https://ask.openstack.org/en/question/35705/attempt-of-rdo-aio-install-icehouse-on-centos-7/

"..replace content /etc/redhat-release with "Fedora release 20 (Heisenbug)" and rerun packstack --allinone. In meantime I have IceHouse AIO Instance on CentOS 7 completely functional."

Terminal:

ERROR : Error appeared during Puppet run: 192.168.11.19_prescript.pp
Error: comparison of String with 7 failed at /var/tmp/packstack/2761ac128766421ab10ff27c754a6285/manifests/192.168.11.19_prescript.pp:15 on node stack1.local.lan
You will find full trace in log /var/tmp/packstack/20140712-012704-8RBDNB/manifests/192.168.11.19_prescript.pp.log
Please check log file /var/tmp/packstack/20140712-012704-8RBDNB/openstack-setup.log for more information


openstack-setup.log:

...
tar --dereference -cpzf - apache ceilometer certmonger cinder concat firewall glance heat horizon inifile keystone memcached mongodb mysql neutron nova nssdb openstack packstack qp
id rabbitmq rsync ssh stdlib swift sysctl tempest vcsrepo vlan vswitch xinetd | ssh -o StrictHostKeyChecking=no -o UserKnownHostsFile=/dev/null root@192.168.11.19 tar -C /var/tmp/packstack/2761ac128766421ab10ff27c754a6285/modules -xpzf -
2014-07-12 01:28:57::ERROR::run_setup::920::root:: Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 915, in main
    _main(confFile)
  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 605, in _main
    runSequences()
  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 584, in runSequences
    controller.runAllSequences()
  File "/usr/lib/python2.7/site-packages/packstack/installer/setup_controller.py", line 68, in runAllSequences
    sequence.run(config=self.CONF, messages=self.MESSAGES)
  File "/usr/lib/python2.7/site-packages/packstack/installer/core/sequences.py", line 98, in run
    step.run(config=config, messages=messages)
  File "/usr/lib/python2.7/site-packages/packstack/installer/core/sequences.py", line 44, in run
    raise SequenceError(str(ex))
SequenceError: Error appeared during Puppet run: 192.168.11.19_prescript.pp
Error: comparison of String with 7 failed at /var/tmp/packstack/2761ac128766421ab10ff27c754a6285/manifests/192.168.11.19_prescript.pp:15 on node stack1.local.lan
You will find full trace in log /var/tmp/packstack/20140712-012704-8RBDNB/manifests/192.168.11.19_prescript.pp.log

2014-07-12 01:28:57::INFO::shell::81::root:: [192.168.11.19] Executing script:
rm -rf /var/tmp/packstack/2761ac128766421ab10ff27c754a6285
[root@stack1 20140712-012704-8RBDNB]# 


192.168.11.19_prescript.pp.log:

Warning: Config file /etc/puppet/hiera.yaml not found, using Hiera defaults
Error: comparison of String with 7 failed at /var/tmp/packstack/2761ac128766421ab10ff27c754a6285/manifests/192.168.11.19_prescript.pp:15 on node stack1.local.lan
Wrapped exception:
comparison of String with 7 failed
Error: comparison of String with 7 failed at /var/tmp/packstack/2761ac128766421ab10ff27c754a6285/manifests/192.168.11.19_prescript.pp:15 on node stack1.local.lan

Comment 2 John Haller 2014-07-14 13:01:13 UTC
I made the following changes to the Puppet scripts, and it worked, although I'm less sure about the need for the .rb
/usr/share/openstack-puppet/modules/nova/manifests/compute/libvirt.pp line 112
<  if($::osfamily == 'RedHat' and $::operatingsystem != 'Fedora') {
>  if($::osfamily == 'RedHat' and $::operatingsystem != 'Fedora' and $::osoperatingsystemmajrelease < 7) {
/usr/share/openstack-puppet/modules/nova/spec/classes/nova_compute_libvirt_spec.rb line 107
<        :operatingsystemrelease => 6.5 }
>        :operatingsystemmajrelease => 6.5 }
/usr/share/openstack-puppet/modules/nova/spec/classes/nova_compute_libvirt_spec.rb line 136
<          super().merge(:operatingsystemrelease => 7.0)
>          super().merge(:operatingsystemmajrelease => 7.0)
/usr/share/openstack-puppet/modules/nova/manifests/params.pp 112
<        'Fedora', 'RedHat': {
<          $special_service_provider = undef
<        }
<        'RedHat': {
<          if ($::operatingsystemrelease < 7) {
>        'Fedora', 'RedHat', 'CentOS': {
>          $special_service_provider = undef
>        }
>        'RedHat', 'CentOS': {
>          if ($::operatingsystemmajrelease < 7) {


Of course, that wasn't the last of the Puppet errors, after fixing the above, I also ran into an Apache problem, which required the following change:
/usr/share/openstack-puppet/modules/apache/manifests/version.pp line 8
<      if ($::operatingsystem == 'Fedora' and $::operatingsystemrelease >= 18) or ($::operatingsystem != 'Fedora' and $::operatingsystemrelease >= 7) {
>      if ($::operatingsystem == 'Fedora' and $::operatingsystemrelease >= 18) or ($::operatingsystem != 'Fedora' and $::operatingsystemmajrelease >= 7) {

Comment 3 Kashyap Chamarthy 2014-07-16 07:24:52 UTC
*** Bug 1119450 has been marked as a duplicate of this bug. ***

Comment 4 Yaniv Kaul 2014-07-16 08:14:34 UTC
Kashyap - please note the severity here is unspecified. Should be set to something  better.

Comment 5 Michael J. Kidd 2014-07-18 10:59:48 UTC
Created attachment 919050 [details]
RDO AIO CentOS 7 Patch

Apply with:
cd /
patch -p1 < /path/to/packstack.diff

Comment 6 Gaël Chamoulaud 2014-07-18 11:14:15 UTC
The Fix for this has already been merged in the Nova upstream puppet modules [1].

[1] - https://github.com/stackforge/puppet-nova/commit/0ed5b7745b6b200cdda4ae6b7d88af71498361e4

Comment 7 Gaël Chamoulaud 2014-07-23 10:52:55 UTC
This bug is coming from the new CentOS versioning number. You will find a full status report on all the fixes for CentOS 7 in https://bugzilla.redhat.com/show_bug.cgi?id=1117035#c4

Comment 8 Alan Pevec 2014-09-15 18:51:07 UTC
Updated openstack-puppet-modules has been published to the RDO Icehouse repository.


Note You need to log in before you can comment on or make changes to this bug.