Bug 1119473 - ERROR : 'CONFIG_NEUTRON_ML2_MECHANISM_DRIVERS' when installing OSP 5 via Packstack
Summary: ERROR : 'CONFIG_NEUTRON_ML2_MECHANISM_DRIVERS' when installing OSP 5 via Pack...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack
Version: 5.0 (RHEL 7)
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: rc
: 5.0 (RHEL 7)
Assignee: Martin Magr
QA Contact: Jaroslav Henner
URL:
Whiteboard:
: 1120056 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-14 20:56 UTC by jliberma@redhat.com
Modified: 2016-04-26 18:22 UTC (History)
11 users (show)

Fixed In Version: openstack-packstack-2014.1.1-0.35.dev1220.el7ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-24 17:25:13 UTC


Attachments (Terms of Use)
log (2.94 KB, text/plain)
2014-07-15 14:23 UTC, Jaroslav Henner
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0930 normal SHIPPED_LIVE openstack-packstack and openstack-puppet-modules bug-fix advisory 2014-07-24 21:22:40 UTC
OpenStack gerrit 107077 None None None Never
OpenStack gerrit 107158 None None None Never

Description jliberma@redhat.com 2014-07-14 20:56:31 UTC
Description of problem: ERROR : 'CONFIG_NEUTRON_ML2_MECHANISM_DRIVERS' when installing OSP 5 via packstack on RHEL 7

Version-Release number of selected component (if applicable):
2014.1.1-0.34.dev1219.el7ost

How reproducible:
Every time

Steps to Reproduce:
1. yum install openstack-packstack
2. packstack --answer-file=answer.txt

Actual results:
Failed


Expected results:
Retested with GA puddle, same answer file worked.

Additional info:
Failed puddle: 2014-07-14.1

Error from log:
2014-07-14 15:18:19::ERROR::run_setup::920::root:: Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 915, in main
    _main(confFile)
  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 605, in _main
    runSequences()
  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 584, in runSequences
    controller.runAllSequences()
  File "/usr/lib/python2.7/site-packages/packstack/installer/setup_controller.py", line 68, in runAllSequences
    sequence.run(config=self.CONF, messages=self.MESSAGES)
  File "/usr/lib/python2.7/site-packages/packstack/installer/core/sequences.py", line 98, in run
    step.run(config=config, messages=messages)
  File "/usr/lib/python2.7/site-packages/packstack/installer/core/sequences.py", line 44, in run
    raise SequenceError(str(ex))
SequenceError: 'CONFIG_NEUTRON_ML2_MECHANISM_DRIVERS'

Answer file:
[general]
CONFIG_SSH_KEY=/root/.ssh/id_rsa.pub
CONFIG_MYSQL_INSTALL=y
CONFIG_GLANCE_INSTALL=y
CONFIG_CINDER_INSTALL=y
CONFIG_NOVA_INSTALL=y
CONFIG_NEUTRON_INSTALL=y
CONFIG_HORIZON_INSTALL=n
CONFIG_SWIFT_INSTALL=y
CONFIG_CEILOMETER_INSTALL=n
CONFIG_HEAT_INSTALL=n
CONFIG_CLIENT_INSTALL=y
CONFIG_NTP_SERVERS=10.16.255.1,10.16.255.2
CONFIG_NAGIOS_INSTALL=n
EXCLUDE_SERVERS=
CONFIG_DEBUG_MODE=n
CONFIG_CONTROLLER_HOST=10.19.137.100
CONFIG_COMPUTE_HOSTS=10.19.137.101,10.19.137.102,10.19.137.103,10.19.137.104
CONFIG_NETWORK_HOSTS=10.19.137.101
CONFIG_VMWARE_BACKEND=n
CONFIG_VCENTER_HOST=
CONFIG_VCENTER_USER=
CONFIG_VCENTER_PASSWORD=
CONFIG_VCENTER_CLUSTER_NAME=
CONFIG_MYSQL_HOST=10.19.137.100
CONFIG_MYSQL_USER=root
CONFIG_MYSQL_PW=redhat
CONFIG_AMQP_BACKEND=rabbitmq
CONFIG_AMQP_HOST=10.19.137.100
CONFIG_AMQP_ENABLE_SSL=n
CONFIG_AMQP_ENABLE_AUTH=n
CONFIG_AMQP_NSS_CERTDB_PW=redhat
CONFIG_AMQP_SSL_PORT=5671
CONFIG_AMQP_SSL_CERT_FILE=/etc/pki/tls/certs/amqp_selfcert.pem
CONFIG_AMQP_SSL_KEY_FILE=/etc/pki/tls/private/amqp_selfkey.pem
CONFIG_AMQP_SSL_SELF_SIGNED=y
CONFIG_AMQP_AUTH_USER=amqp_user
CONFIG_AMQP_AUTH_PASSWORD=redhat
CONFIG_KEYSTONE_DB_PW=redhat
CONFIG_KEYSTONE_ADMIN_TOKEN=redhat
CONFIG_KEYSTONE_ADMIN_PW=redhat
CONFIG_KEYSTONE_DEMO_PW=redhat
CONFIG_KEYSTONE_TOKEN_FORMAT=PKI
CONFIG_GLANCE_DB_PW=redhat
CONFIG_GLANCE_KS_PW=redhat
CONFIG_CINDER_DB_PW=redhat
CONFIG_CINDER_KS_PW=redhat
CONFIG_CINDER_BACKEND=nfs
CONFIG_CINDER_VOLUMES_CREATE=n
CONFIG_CINDER_VOLUMES_SIZE=10G
CONFIG_CINDER_GLUSTER_MOUNTS=
CONFIG_CINDER_NFS_MOUNTS=10.19.137.120:/srv
CONFIG_NOVA_DB_PW=redhat
CONFIG_NOVA_KS_PW=redhat
CONFIG_NOVA_SCHED_CPU_ALLOC_RATIO=16.0
CONFIG_NOVA_SCHED_RAM_ALLOC_RATIO=1.5
CONFIG_NOVA_COMPUTE_PRIVIF=p3p1
CONFIG_NOVA_NETWORK_MANAGER=nova.network.manager.VlanManager
CONFIG_NOVA_NETWORK_PUBIF=em1
CONFIG_NOVA_NETWORK_PRIVIF=p3p1
CONFIG_NOVA_NETWORK_FIXEDRANGE=172.16.3.0/24
CONFIG_NOVA_NETWORK_FLOATRANGE=10.19.137.112/28
CONFIG_NOVA_NETWORK_DEFAULTFLOATINGPOOL=nova
CONFIG_NOVA_NETWORK_AUTOASSIGNFLOATINGIP=n
CONFIG_NOVA_NETWORK_VLAN_START=1000
CONFIG_NOVA_NETWORK_NUMBER=1
CONFIG_NOVA_NETWORK_SIZE=255
CONFIG_NEUTRON_KS_PW=redhat
CONFIG_NEUTRON_DB_PW=redhat
CONFIG_NEUTRON_L3_EXT_BRIDGE=provider
CONFIG_NEUTRON_L2_PLUGIN=openvswitch
CONFIG_NEUTRON_METADATA_PW=redhat
CONFIG_LBAAS_INSTALL=n
CONFIG_NEUTRON_METERING_AGENT_INSTALL=n
CONFIG_NEUTRON_ML2_TYPE_DRIVERS=vlan,local,flat,gre
CONFIG_NEUTRON_ML2_TENANT_NETWORK_TYPES=flat
CONFIG_NEUTRON_ML2_MECHANISM_DRIVERS=openvswitch
CONFIG_NEUTRON_ML2_FLAT_NETWORKS=*
CONFIG_NEUTRON_ML2_VLAN_RANGES=physnet1:1000:1010
CONFIG_NEUTRON_ML2_TUNNEL_ID_RANGES=
CONFIG_NEUTRON_ML2_VXLAN_GROUP=
CONFIG_NEUTRON_ML2_VNI_RANGES=
CONFIG_NEUTRON_L2_AGENT=openvswitch
CONFIG_NEUTRON_LB_TENANT_NETWORK_TYPE=
CONFIG_NEUTRON_LB_VLAN_RANGES=
CONFIG_NEUTRON_LB_INTERFACE_MAPPINGS=
CONFIG_NEUTRON_OVS_TENANT_NETWORK_TYPE=vlan
CONFIG_NEUTRON_OVS_VLAN_RANGES=physnet1:1000:1010
CONFIG_NEUTRON_OVS_BRIDGE_MAPPINGS=physnet1:br-p3p1
CONFIG_NEUTRON_OVS_BRIDGE_IFACES=br-p3p1:p3p1
CONFIG_NEUTRON_OVS_TUNNEL_RANGES=
CONFIG_NEUTRON_OVS_TUNNEL_IF=
CONFIG_NEUTRON_OVS_VXLAN_UDP_PORT=4789
CONFIG_HORIZON_SSL=n
CONFIG_SSL_CERT=
CONFIG_SSL_KEY=
CONFIG_SWIFT_KS_PW=redhat
CONFIG_SWIFT_STORAGES=
CONFIG_SWIFT_STORAGE_ZONES=1
CONFIG_SWIFT_STORAGE_REPLICAS=1
CONFIG_SWIFT_STORAGE_FSTYPE=ext4
CONFIG_SWIFT_HASH=redhat
CONFIG_SWIFT_STORAGE_SIZE=2G
CONFIG_PROVISION_DEMO=n
CONFIG_PROVISION_TEMPEST=n
CONFIG_PROVISION_DEMO_FLOATRANGE=172.24.4.224/28
CONFIG_PROVISION_TEMPEST_REPO_URI=https://github.com/openstack/tempest.git
CONFIG_PROVISION_TEMPEST_REPO_REVISION=master
CONFIG_PROVISION_ALL_IN_ONE_OVS_BRIDGE=n
CONFIG_HEAT_DB_PW=redhat
CONFIG_HEAT_AUTH_ENC_KEY=redhat
CONFIG_HEAT_KS_PW=redhat
CONFIG_HEAT_CLOUDWATCH_INSTALL=n
CONFIG_HEAT_CFN_INSTALL=n
CONFIG_CEILOMETER_SECRET=redhat
CONFIG_CEILOMETER_KS_PW=redhat
CONFIG_MONGODB_HOST=10.19.137.100
CONFIG_NAGIOS_PW=redhat
CONFIG_USE_EPEL=n
CONFIG_REPO=
CONFIG_RH_USER=
CONFIG_RH_PW=
CONFIG_SATELLITE_URL=
CONFIG_SATELLITE_USER=
CONFIG_SATELLITE_PW=
CONFIG_SATELLITE_AKEY=
CONFIG_SATELLITE_CACERT=
CONFIG_SATELLITE_PROFILE=
CONFIG_SATELLITE_FLAGS=
CONFIG_SATELLITE_PROXY=
CONFIG_SATELLITE_PROXY_USER=
CONFIG_SATELLITE_PROXY_PW=

Comment 3 Martin Magr 2014-07-15 14:01:57 UTC
Can you please attach also openstack-setup.log?

Comment 4 Ivan Chavero 2014-07-15 14:21:02 UTC
Martin, i've reproduced it, we have to check the provided answer file since it was tailored

2014-07-15 10:17:34::DEBUG::sequences::40::root:: Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/packstack-2014.1.1devNone-py2.7.egg/packstack/installer/core/sequences.py", line 38, in run
    self.function(config, messages)
  File "/usr/lib/python2.7/site-packages/packstack-2014.1.1devNone-py2.7.egg/packstack/plugins/neutron_350.py", line 914, in create_l2_agent_manifests
    manifestdata = getManifestTemplate(template_name)
  File "/usr/lib/python2.7/site-packages/packstack-2014.1.1devNone-py2.7.egg/packstack/modules/ospluginutils.py", line 76, in getManifestTemplate
    return fp.read() % controller.CONF
KeyError: 'CONFIG_NEUTRON_ML2_MECHANISM_DRIVERS'

2014-07-15 10:17:34::ERROR::run_setup::920::root:: Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/packstack-2014.1.1devNone-py2.7.egg/packstack/installer/run_setup.py", line 915, in main
    _main(confFile)
  File "/usr/lib/python2.7/site-packages/packstack-2014.1.1devNone-py2.7.egg/packstack/installer/run_setup.py", line 605, in _main
    runSequences()
  File "/usr/lib/python2.7/site-packages/packstack-2014.1.1devNone-py2.7.egg/packstack/installer/run_setup.py", line 584, in runSequences
    controller.runAllSequences()
  File "/usr/lib/python2.7/site-packages/packstack-2014.1.1devNone-py2.7.egg/packstack/installer/setup_controller.py", line 68, in runAllSequences
    sequence.run(config=self.CONF, messages=self.MESSAGES)
  File "/usr/lib/python2.7/site-packages/packstack-2014.1.1devNone-py2.7.egg/packstack/installer/core/sequences.py", line 98, in run
    step.run(config=config, messages=messages)
  File "/usr/lib/python2.7/site-packages/packstack-2014.1.1devNone-py2.7.egg/packstack/installer/core/sequences.py", line 44, in run
    raise SequenceError(str(ex))
SequenceError: 'CONFIG_NEUTRON_ML2_MECHANISM_DRIVERS'

2014-07-15 10:17:34::DEBUG::run_setup::626::root:: Removing /var/tmp/packstack/dfc94fdd58d34dfb9f844bc2674c2ab9 on 192.168.100.144 (if it is a remote host)
2014-07-15 10:17:34::INFO::shell::81::root:: [192.168.100.144] Executing script:
rm -rf /var/tmp/packstack/dfc94fdd58d34dfb9f844bc2674c2ab9
2014-07-15 10:17:35::DEBUG::shell::102::root::

Comment 5 Jaroslav Henner 2014-07-15 14:23:10 UTC
Created attachment 918183 [details]
log

======== END OF STDOUT ========
2014-07-15 08:25:46::DEBUG::sequences::34::root:: Running step Adding Nova Compute manifest entries.
2014-07-15 08:25:46::DEBUG::sequences::34::root:: Running step Adding Nova Scheduler manifest entries.
2014-07-15 08:25:46::DEBUG::sequences::34::root:: Running step Adding Nova VNC Proxy manifest entries.
2014-07-15 08:25:46::DEBUG::sequences::34::root:: Running step Adding Openstack Network-related Nova manifest entries.
2014-07-15 08:25:46::DEBUG::sequences::34::root:: Running step Adding Nova Common manifest entries.
2014-07-15 08:25:46::DEBUG::sequences::93::root:: Running sequence Installing OpenStack Neutron.
2014-07-15 08:25:46::DEBUG::sequences::34::root:: Running step Adding Neutron API manifest entries.
2014-07-15 08:25:46::DEBUG::sequences::34::root:: Running step Adding Neutron Keystone manifest entries.
2014-07-15 08:25:46::DEBUG::sequences::34::root:: Running step Adding Neutron L3 manifest entries.
2014-07-15 08:25:46::DEBUG::sequences::34::root:: Running step Adding Neutron L2 Agent manifest entries.
2014-07-15 08:25:46::DEBUG::sequences::40::root:: Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/packstack/installer/core/sequences.py", line 38, in run
    self.function(config, messages)
  File "/usr/lib/python2.7/site-packages/packstack/plugins/neutron_350.py", line 914, in create_l2_agent_manifests
    manifestdata = getManifestTemplate(template_name)
  File "/usr/lib/python2.7/site-packages/packstack/modules/ospluginutils.py", line 76, in getManifestTemplate
    return fp.read() % controller.CONF
KeyError: 'CONFIG_NEUTRON_ML2_MECHANISM_DRIVERS'

2014-07-15 08:25:46::ERROR::run_setup::920::root:: Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 915, in main
    _main(confFile)
  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 605, in _main
    runSequences()
  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 584, in runSequences
    controller.runAllSequences()
  File "/usr/lib/python2.7/site-packages/packstack/installer/setup_controller.py", line 68, in runAllSequences
    sequence.run(config=self.CONF, messages=self.MESSAGES)
  File "/usr/lib/python2.7/site-packages/packstack/installer/core/sequences.py", line 98, in run
    step.run(config=config, messages=messages)
  File "/usr/lib/python2.7/site-packages/packstack/installer/core/sequences.py", line 44, in run
    raise SequenceError(str(ex))
SequenceError: 'CONFIG_NEUTRON_ML2_MECHANISM_DRIVERS'

2014-07-15 08:25:46::DEBUG::run_setup::626::root:: Removing /var/tmp/packstack/60b2ebc575d1496486fd216095f4f137 on 172.16.32.6 (if it is a remote host)
2014-07-15 08:25:46::INFO::shell::81::root:: [172.16.32.6] Executing script:
rm -rf /var/tmp/packstack/60b2ebc575d1496486fd216095f4f137
2014-07-15 08:25:46::DEBUG::shell::102::root:: 
============= STDOUT ==========

Comment 6 Ivan Chavero 2014-07-15 14:28:05 UTC
flat is not a valid value for CONFIG_NEUTRON_ML2_TYPE_DRIVERS
the provided answer file includes it:
CONFIG_NEUTRON_ML2_TYPE_DRIVERS=vlan,local,flat,gre

i guess we have to improve the error reporting here.

Comment 7 Ivan Chavero 2014-07-15 14:35:24 UTC
sorry the option that does not accept the "flat" value is: CONFIG_NEUTRON_ML2_TENANT_NETWORK_TYPES, it only accepts: "local", "vlan", "gre", "vxlan"

Comment 8 jliberma@redhat.com 2014-07-15 18:11:20 UTC
So is the error related to CONFIG_NEUTRON_ML2_TYPE_DRIVERS or 
CONFIG_NEUTRON_ML2_MECHANISM_DRIVERS as the error indicates?

Just FYI, I tried several different values for CONFIG_NEUTRON_ML2_TYPE_DRIVERS including just vlan, and saw same error as I recall.

I don't have the original log beyond the error I pasted initially. thanks!

Comment 10 Martin Magr 2014-07-16 14:26:59 UTC
*** Bug 1120056 has been marked as a duplicate of this bug. ***

Comment 11 Miguel Angel Ajo 2014-07-16 14:27:54 UTC
I believe this shouldn't be a blocker, as non-ml2 plugins (ovs, linuxbridge) 
will be deprecated in next release,

and I believe we are not recommending any client to install non-ml2.

Comment 12 Miguel Angel Ajo 2014-07-16 14:29:05 UTC
(In reply to Miguel Angel Ajo from comment #11)
> I believe this shouldn't be a blocker, as non-ml2 plugins (ovs, linuxbridge) 
> will be deprecated in next release,
> 
> and I believe we are not recommending any client to install non-ml2.

That comment was meant for bug 1120056 which I think it's not a duplicate.

Comment 15 Jaroslav Henner 2014-07-18 23:39:45 UTC
openstack-packstack        noarch 2014.1.1-0.35.dev1220.el7ost works

Comment 18 errata-xmlrpc 2014-07-24 17:25:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0930.html


Note You need to log in before you can comment on or make changes to this bug.