Bug 111979 - redhat config network segfault
redhat config network segfault
Status: CLOSED DUPLICATE of bug 114071
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2003-12-12 03:20 EST by randy smyth
Modified: 2014-03-16 22:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:00:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description randy smyth 2003-12-12 03:20:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET 
CLR 1.0.3705; .NET CLR 1.1.4322)

Description of problem:
ok thers no problem getting on-line using 1 eathernet card but when i 
plug my second usb network card into my pc and try to configure it 
redhat config network segfaults and crashes. 

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. plug second usb eathernet card in


Actual Results:  segfault in redhat config network

Expected Results:  to work of course

Additional info:
Comment 1 Harald Hoyer 2003-12-17 03:23:06 EST
is there a python traceback you could attach? Or does it segfault
Comment 2 Edward Kuns 2004-01-25 23:57:14 EST
I recently upgraded from RedHat 8 to Fedora Core 1.  I've been running
FC1 on my laptop (upgraded from RH9) for a couple months.  Everything
is fine on the laptop.  However, on my desktop, redhat-config-network
segfaults with no python traceback at all.

All I see is a pop-up window:

Application "redhat-config-network" (process 4287) has crashed
due to a fatal error.
(Segmentation fault)

and a link to the Gnome error reporting page.  I just run
redhat-config-network and the first and only thing I see is that error

I don't know if this is the same issue as above, but it sounds like it.

Since the upgrade, this tool has segfaulted 100% of the time.

If I run (as root) redhat-config-network-tui, it gets as far as
showing the first ethernet device.  (if I click on Ethernet)  As soon
as I *OK* that one, it segfaults.  All I see in the window is
"Segmentation fault" and a command prompt.

The other redhat-config-* programs that I have run all work without a
Comment 3 Harald Hoyer 2004-01-26 04:31:22 EST
this is mostly the kudzu python module... reassigning
Comment 4 Bill Nottingham 2004-02-04 01:11:57 EST

*** This bug has been marked as a duplicate of 114071 ***
Comment 5 Red Hat Bugzilla 2006-02-21 14:00:23 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.