Bug 114071 - kudzu/system-config-network crashes when new ADSL modem and eth device is present
kudzu/system-config-network crashes when new ADSL modem and eth device is pre...
Status: CLOSED DUPLICATE of bug 106332
Product: Red Hat Raw Hide
Classification: Retired
Component: kudzu (Show other bugs)
1.0
i686 Linux
high Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
: 111979 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-22 04:18 EST by Moritz Barsnick
Modified: 2014-03-16 22:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
typical output of "ifconfig -a" (1.14 KB, text/plain)
2004-01-22 04:20 EST, Moritz Barsnick
no flags Details
typical output of "lsmod" (2.03 KB, text/plain)
2004-01-22 04:22 EST, Moritz Barsnick
no flags Details
typical output of "lsusb" (325 bytes, text/plain)
2004-01-22 04:23 EST, Moritz Barsnick
no flags Details
typical content of /proc/bus/usb/devices (4.19 KB, text/plain)
2004-01-22 04:24 EST, Moritz Barsnick
no flags Details
patch against kudzu-1.1.40 to fix segfault (426 bytes, patch)
2004-01-23 03:25 EST, Moritz Barsnick
no flags Details | Diff

  None (edit)
Description Moritz Barsnick 2004-01-22 04:18:37 EST
Description of problem:
I have a new USB ADSL modem, with a non-kernel driver. The driver 
works, and so does the modem. When modem and driver are active (eth1 
is present), system-config-network crashes (segfaults) immediately.

Version-Release number of selected component (if applicable):
1.3.13-2

How reproducible:
always

Steps to Reproduce:
1. Install driver (module + hotplug userdata).
2. Activate modem (hotplug or boot)
3. Call system-config-network (from cmdline, menu, or from
   system-control-network)
  
Actual results:
Segmentation fault (gnome_segv pops up)

Expected results:
Program runs.

Additional info:
This is hindering me from properly configuring my ADSL modem, because 
I'm too stupid to use "route"/"ip". ;-)

It is an Allied Telesyn AT-AR215 USB modem (an "ADImodem", i.e. an 
Analog Devices modem). I use the German driver from http://eagle-usb.
eisfront.de/, which I built as an RPM (myself). The driver works 
fine: hotplug recognizes the device (lsmod shows eagle-usb), 
initializes it with firmware, the device syncs with the DSL network, 
and the driver presents the system with an eth1 (eth0 is present as 
well, my Eth card). If I use rp-pppoe and pppd manually (and some 
guessing with "route add ..."), it operates fine. Yet starting 
system-config-network in any possible way gives a segmentation fault 
very quickly. I think system-config-network is still parsing 
files/output at this point. GPlease give me instructions for an 
"strace [-f -ff]" call, and I will deliver any info required.

If I remove the driver, or reboot without the modem connected, 
system-config-network can start fine. Yet I can't configure the 
connection without the device. ;-) And I need this nice little config 
app, because I'm too stupid for all the mechanisms behind it, right 
now.

BTW, kudzu also crashes when this device is present. ;-)

I will attach some files to show what the system looks like when the 
driver is loaded. I'm open for any other requests.

Thanks a bunch,
Moritz
Comment 1 Moritz Barsnick 2004-01-22 04:20:54 EST
Created attachment 97156 [details]
typical output of "ifconfig -a"

This is typical output of "ifconfig -a" when the eagle-usb driver is loaded.
The new interface eth1 is not activated yet though.
Comment 2 Moritz Barsnick 2004-01-22 04:22:24 EST
Created attachment 97157 [details]
typical output of "lsmod"

This is typical output of "lsmod" when the eagle-usb driver is loaded.
Comment 3 Moritz Barsnick 2004-01-22 04:23:16 EST
Created attachment 97158 [details]
typical output of "lsusb"

This is typical output of "lsusb" when the eagle-usb driver is loaded.
Comment 4 Moritz Barsnick 2004-01-22 04:24:30 EST
Created attachment 97159 [details]
typical content of /proc/bus/usb/devices

This is typical content of /proc/bus/usb/devices when the eagle-usb driver is
loaded.
Comment 5 Harald Hoyer 2004-01-22 04:47:54 EST
system-config-network uses kudzu, which segfaults.
reassigning
Comment 6 Moritz Barsnick 2004-01-22 08:38:53 EST
Thanks to this pointer to kudzu (I thought it was a separate problem) 
and the Fedora-list archive, specifically
http://www.redhat.com/archives/fedora-list/2004-January/msg04701.html
, I think this bug may be a duplicate of bugzilla Bug #106332. 
Especially the contents of attachment 94965 [details] and attachment 94966 [details] very 
much resemble what I saw when stracing and gdb'ing either 
system-config-network or kudzu (can't remember which ;->); i.e. the 
functions which the backtrace lists, and the 
/etc/sysconfig/network-scripts/ifcfg-lo at the and of the strace!

Nevertheless, I hope my info (especially tracing it down to a certain 
device/interface) helps track this down.

Has attachment 96307 [details] been integrated into kudzu yet?

Thanks
Comment 7 Moritz Barsnick 2004-01-23 03:20:57 EST
Indeed, the patch in attachment 96307 [details] does the job for me. I rebuilt 
the kudzu RPM with an updated patch applied, and kudzu no longer 
segfaults when the new device is present. system-config-network also 
starts up fine now. I still can't configure the connection with scn, 
but that's a different, separate bug report.

I'm attaching an updated patch which applies properly against 
kudzu-1.1.40 and post a reference in the report for Bug #106332.
Comment 8 Moritz Barsnick 2004-01-23 03:25:08 EST
Created attachment 97205 [details]
patch against kudzu-1.1.40 to fix segfault

This patch is to fix the described segfault of kudzu. It is an update of the
one included in attachment 96307 [details]. Thanks to Norm Brake for the latter!
Comment 9 Bill Nottingham 2004-02-04 01:11:59 EST
*** Bug 111979 has been marked as a duplicate of this bug. ***
Comment 10 Bill Nottingham 2004-02-04 01:13:15 EST
*** This bug has been marked as a duplicate of 106332 ***

*** This bug has been marked as a duplicate of 106332 ***
Comment 11 Red Hat Bugzilla 2006-02-21 14:00:53 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.