Bug 1119827 - Brick goes offline unexpectedly
Summary: Brick goes offline unexpectedly
Keywords:
Status: CLOSED DUPLICATE of bug 1144315
Alias: None
Product: GlusterFS
Classification: Community
Component: quota
Version: 3.5.1
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
Assignee: GlusterFS Bugs list
QA Contact:
URL:
Whiteboard:
Depends On: 1118591
Blocks: glusterfs-3.5.3
TreeView+ depends on / blocked
 
Reported: 2014-07-15 15:25 UTC by NOVELTIS IT
Modified: 2014-09-27 09:15 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-27 09:15:50 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description NOVELTIS IT 2014-07-15 15:25:40 UTC
Description of problem: I have a volume divided into 3 bricks (one per server). Sometimes, a brick goes down.

The only error I found is in the /var/log/glusterfs/brick/glusterfs-projets-brick2-projets.log log file :
http://fpaste.org/118116/14054353/

I have a talk with ndevos on IRC and he asked me the result of :
gdb /usr/lib/x86_64-linux-gnu/glusterfs/3.5.1/xlator/features/marker.so
l *mq_loc_fill_from_name+0x86

which is :
0x14896 is in mq_loc_fill_from_name (marker-quota.c:178).
173     marker-quota.c: No such file or directory.

I'm using glusterfs 3.5.1 on a Debian Wheezy server and I use NFS, Quota and ACL.

# gluster volume info projets
 
Volume Name: projets
Type: Distribute
Volume ID: ee585e7a-1b89-40b5-bd37-1c977920e87f
Status: Started
Number of Bricks: 3
Transport-type: tcp
Bricks:
Brick1: projet1:/glusterfs/projets-brick1/projets
Brick2: projet2:/glusterfs/projets-brick2/projets
Brick3: projet3:/glusterfs/projets-brick3/projets
Options Reconfigured:
performance.cache-size: 256MB
features.quota-timeout: 0
features.quota: on

Comment 1 Niels de Vos 2014-07-15 15:45:34 UTC
Bug 1118591 looks very much the same.

This bug will handle the issue in glusterfs-3.5.x, where bug 1118591 is used to include a fix in the master branch.

Comment 2 Niels de Vos 2014-07-15 15:52:19 UTC
(In reply to Thilam from comment #0)
> The only error I found is in the
> /var/log/glusterfs/brick/glusterfs-projets-brick2-projets.log log file :
> http://fpaste.org/118116/14054353/

/usr/lib/x86_64-linux-gnu/glusterfs/3.5.1/xlator/features/marker.so(mq_loc_fill_from_name+0x86)[0x7f654cb48896]
/usr/lib/x86_64-linux-gnu/glusterfs/3.5.1/xlator/features/marker.so(mq_readdir_cbk+0x227)[0x7f654cb49367]
/usr/lib/x86_64-linux-gnu/libglusterfs.so.0(default_readdir_cbk+0xc0)[0x7f6552a22460]

> I have a talk with ndevos on IRC and he asked me the result of :
> gdb /usr/lib/x86_64-linux-gnu/glusterfs/3.5.1/xlator/features/marker.so
> l *mq_loc_fill_from_name+0x86
> 
> which is :
> 0x14896 is in mq_loc_fill_from_name (marker-quota.c:178).
> 173     marker-quota.c: No such file or directory.

$ git show v3.5.1:xlators/features/marker/src/marker-quota.c
 ...
 176         len = strlen (oldloc->path);
 177 
 178         if (oldloc->path [len - 1] == '/')
 ...

Line marker-quota.c:178 caused the segfault.

Comment 3 Vijay Bellur 2014-07-15 16:34:33 UTC
(In reply to Niels de Vos from comment #2)
> (In reply to Thilam from comment #0)
> > The only error I found is in the
> > /var/log/glusterfs/brick/glusterfs-projets-brick2-projets.log log file :
> > http://fpaste.org/118116/14054353/
> 
> /usr/lib/x86_64-linux-gnu/glusterfs/3.5.1/xlator/features/marker.
> so(mq_loc_fill_from_name+0x86)[0x7f654cb48896]
> /usr/lib/x86_64-linux-gnu/glusterfs/3.5.1/xlator/features/marker.
> so(mq_readdir_cbk+0x227)[0x7f654cb49367]
> /usr/lib/x86_64-linux-gnu/libglusterfs.so.
> 0(default_readdir_cbk+0xc0)[0x7f6552a22460]
> 

Seems similar to bz 1118591

Comment 4 Niels de Vos 2014-08-26 17:24:52 UTC
Backporting http://review.gluster.org/8296 should probably fix it.

Comment 5 Niels de Vos 2014-09-27 09:15:50 UTC
The patch has been backported already for bug 1144315.

*** This bug has been marked as a duplicate of bug 1144315 ***


Note You need to log in before you can comment on or make changes to this bug.