Bug 1119864 - screen resolution max 1024x768 after yum update
Summary: screen resolution max 1024x768 after yum update
Keywords:
Status: CLOSED DUPLICATE of bug 1117008
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-15 17:05 UTC by Rich Megginson
Modified: 2014-07-15 22:33 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-15 22:33:29 UTC


Attachments (Terms of Use)
output of xrandr --verbose (5.83 KB, text/plain)
2014-07-15 17:05 UTC, Rich Megginson
no flags Details

Description Rich Megginson 2014-07-15 17:05:24 UTC
Created attachment 918202 [details]
output of xrandr --verbose

Description of problem:
System: Fedora 20 x86_64 - Lenovo ThinkPad 530 in a Lenovo docking station - DVI output into Planar 27" monitor

Screen normally uses 1920x1080 resolution.  After a yum update on July 14, 2014 late at night, rebooting in the morning, the system will not go over 1024x768.  Trying to use the Settings->Display tool shows max of 1024x768.

Someone on #fedora irc suggested setting selinux to permissive and rebooting - that did not help.

The laptop built-in display shows 1920x1080

Version-Release number of selected component (if applicable):
F20

How reproducible:


Steps to Reproduce:
1. Run Fedora 20 before July 14, 2014 with screen resolution 1920x1080
2. yum update ; reboot
3. max screen resolution is 1024x768

Actual results:


Expected results:


Additional info:
see attachments

Comment 1 Rich Megginson 2014-07-15 18:07:52 UTC
Rebooted to the older kernel Fedora (3.14.9-200.fc20.x86_64) 20 (Heisenbug) - now screen resolution is working as expected.

The problem appears to be with Fedora (3.15.4-200.fc20.x86_64) 20 (Heisenbug)

/me wonders if "Heisenbug" is intentional . . .

Comment 2 Rich Megginson 2014-07-15 18:09:16 UTC
additional - This is a ThinkPad T540p

Comment 3 Ted Ross 2014-07-15 19:39:44 UTC
I had the same thing happen on my T540p.  I was able to work around it by disconnecting my external screen from the docking station and plugging it directly into the laptop.

The presence of the docking station between the laptop and the screen seems to cause the problem.

I'm running kernel 3.15.4-200.fc20.x86_64.

Comment 4 Dave Airlie 2014-07-15 22:33:29 UTC

*** This bug has been marked as a duplicate of bug 1117008 ***


Note You need to log in before you can comment on or make changes to this bug.