Bug 1119965 - SystemError: error return without exception set
Summary: SystemError: error return without exception set
Keywords:
Status: CLOSED DUPLICATE of bug 1046482
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 20
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:46ea36be55561e8be330b8bba6c...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-16 02:23 UTC by Amadeus W.M.
Modified: 2014-07-16 13:20 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-16 13:20:53 UTC


Attachments (Terms of Use)
File: anaconda-tb (315.56 KB, text/plain)
2014-07-16 02:23 UTC, Amadeus W.M.
no flags Details
File: anaconda.log (6.90 KB, text/plain)
2014-07-16 02:23 UTC, Amadeus W.M.
no flags Details
File: environ (404 bytes, text/plain)
2014-07-16 02:23 UTC, Amadeus W.M.
no flags Details
File: lsblk_output (2.67 KB, text/plain)
2014-07-16 02:23 UTC, Amadeus W.M.
no flags Details
File: nmcli_dev_list (5.15 KB, text/plain)
2014-07-16 02:23 UTC, Amadeus W.M.
no flags Details
File: os_info (375 bytes, text/plain)
2014-07-16 02:23 UTC, Amadeus W.M.
no flags Details
File: program.log (49.80 KB, text/plain)
2014-07-16 02:23 UTC, Amadeus W.M.
no flags Details
File: storage.log (114.39 KB, text/plain)
2014-07-16 02:23 UTC, Amadeus W.M.
no flags Details
File: syslog (87.24 KB, text/plain)
2014-07-16 02:23 UTC, Amadeus W.M.
no flags Details
File: ifcfg.log (4.00 KB, text/plain)
2014-07-16 02:23 UTC, Amadeus W.M.
no flags Details
File: packaging.log (1.34 KB, text/plain)
2014-07-16 02:23 UTC, Amadeus W.M.
no flags Details

Description Amadeus W.M. 2014-07-16 02:23:17 UTC
Description of problem:
trying to install Fedora 20 i686 on an intel-based pc (D865GBF chipset).

Version-Release number of selected component:
anaconda-20.25.15-1

The following was filed automatically by anaconda:
anaconda 20.25.15-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1766, in _checkMD
    l_csum = self._checksum(r_ctype, file, datasize=size)
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 280, in _check_uncompressed_db_gen
    check_can_fail=True):
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 231, in populate
    db_un_fn = self._check_uncompressed_db_gen(repo, mydbtype)
  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 383, in populateSack
    sack.populate(repo, mdtype, callback, cacheonly)
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 770, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1050, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 904, in _getGroups
    self.pkgSack
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1073, in <lambda>
    comps = property(fget=lambda self: self._getGroups(),
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 3760, in selectGroup
    if not self.comps.has_group(grpid):
  File "/usr/lib/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1091, in _selectYumGroup
    self._yum.selectGroup(groupid, group_package_types=pkg_types)
  File "/usr/lib/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1199, in _applyYumSelections
    self._selectYumGroup("core")
  File "/usr/lib/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1273, in checkSoftwareSelection
    self._applyYumSelections()
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/spokes/software.py", line 124, in checkSoftwareSelection
    self.payload.checkSoftwareSelection()
  File "/usr/lib/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib/python2.7/site-packages/pyanaconda/threads.py", line 192, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib/python2.7/site-packages/pyanaconda/threads.py", line 89, in get
    self.raise_if_error(name)
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/spokes/software.py", line 138, in completed
    processingDone = not threadMgr.get(constants.THREAD_CHECK_SOFTWARE) and \
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 260, in _updateCompleteness
    spoke.selector.set_incomplete(not spoke.completed and spoke.mandatory)
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 336, in _update_spokes
    self._updateCompleteness(spoke)
  File "/usr/lib/python2.7/site-packages/gi/overrides/GLib.py", line 633, in <lambda>
    return (lambda data: callback(*data), user_data)
SystemError: error return without exception set

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020\x20i386 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.10-301.fc20.i686
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        20

Comment 1 Amadeus W.M. 2014-07-16 02:23:20 UTC
Created attachment 918286 [details]
File: anaconda-tb

Comment 2 Amadeus W.M. 2014-07-16 02:23:24 UTC
Created attachment 918287 [details]
File: anaconda.log

Comment 3 Amadeus W.M. 2014-07-16 02:23:27 UTC
Created attachment 918288 [details]
File: environ

Comment 4 Amadeus W.M. 2014-07-16 02:23:31 UTC
Created attachment 918289 [details]
File: lsblk_output

Comment 5 Amadeus W.M. 2014-07-16 02:23:32 UTC
Created attachment 918290 [details]
File: nmcli_dev_list

Comment 6 Amadeus W.M. 2014-07-16 02:23:33 UTC
Created attachment 918291 [details]
File: os_info

Comment 7 Amadeus W.M. 2014-07-16 02:23:34 UTC
Created attachment 918292 [details]
File: program.log

Comment 8 Amadeus W.M. 2014-07-16 02:23:35 UTC
Created attachment 918293 [details]
File: storage.log

Comment 9 Amadeus W.M. 2014-07-16 02:23:37 UTC
Created attachment 918294 [details]
File: syslog

Comment 10 Amadeus W.M. 2014-07-16 02:23:39 UTC
Created attachment 918295 [details]
File: ifcfg.log

Comment 11 Amadeus W.M. 2014-07-16 02:23:40 UTC
Created attachment 918296 [details]
File: packaging.log

Comment 12 David Shea 2014-07-16 13:20:53 UTC

*** This bug has been marked as a duplicate of bug 1046482 ***


Note You need to log in before you can comment on or make changes to this bug.