Bug 1120157 - virtual machine console and details - inconsistent icon size
Summary: virtual machine console and details - inconsistent icon size
Keywords:
Status: CLOSED DUPLICATE of bug 1117763
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager
Version: 21
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-16 10:41 UTC by poma
Modified: 2014-07-16 15:33 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-16 15:33:10 UTC


Attachments (Terms of Use)

Description poma 2014-07-16 10:41:43 UTC
$ grep -R vm_clone_wizard virt-manager-1.0.1/
virt-manager-1.0.1/ui/clone.ui:                    <property name="icon_name">vm_clone_wizard</property>
virt-manager-1.0.1/ui/details.ui:                    <property name="icon_name">vm_clone_wizard</property>
virt-manager-1.0.1/ui/migrate.ui:                    <property name="icon_name">vm_clone_wizard</property>

$ rpm -ql virt-manager | grep vm_clone_wizard
/usr/share/virt-manager/icons/hicolor/48x48/actions/vm_clone_wizard.png

$ rpm -ql virt-manager | grep actions
/usr/share/virt-manager/icons/hicolor/16x16/actions
/usr/share/virt-manager/icons/hicolor/16x16/actions/icon_console.png
/usr/share/virt-manager/icons/hicolor/16x16/actions/vm_new.png
/usr/share/virt-manager/icons/hicolor/22x22/actions
/usr/share/virt-manager/icons/hicolor/22x22/actions/icon_console.png
/usr/share/virt-manager/icons/hicolor/22x22/actions/icon_details.png
/usr/share/virt-manager/icons/hicolor/22x22/actions/vm_new.png
/usr/share/virt-manager/icons/hicolor/24x24/actions
/usr/share/virt-manager/icons/hicolor/24x24/actions/icon_console.png
/usr/share/virt-manager/icons/hicolor/24x24/actions/vm_new.png
/usr/share/virt-manager/icons/hicolor/32x32/actions
/usr/share/virt-manager/icons/hicolor/32x32/actions/icon_console.png
/usr/share/virt-manager/icons/hicolor/32x32/actions/vm_new.png
/usr/share/virt-manager/icons/hicolor/48x48/actions
/usr/share/virt-manager/icons/hicolor/48x48/actions/vm_clone_wizard.png  <- 
/usr/share/virt-manager/icons/hicolor/48x48/actions/vm_delete_wizard.png
/usr/share/virt-manager/icons/hicolor/48x48/actions/vm_import_wizard.png
/usr/share/virt-manager/icons/hicolor/48x48/actions/vm_new_wizard.png


'virt-manager' comes with only one dimension of 'vm_clone_wizard.png' - 48x48, used for the "Snapshots" button, and as such is shown to scale, but not in scale with the other related buttons, in this case.

This "scaling" has worked with <= gtk3-3.13.2-5, but not more, i.e. >= gtk3-3.13.3-1.
The question is whether is this a problem related to 'gtk3', or is 'virt-manager' deficient in 32x32, 24x24, 22x22 and 16.x16 of 'vm_clone_wizard.png', or this comes from something else?

Comment 1 poma 2014-07-16 11:24:55 UTC
As shown, 
http://goo.gl/5acs6u

Comment 2 Cole Robinson 2014-07-16 15:33:10 UTC

*** This bug has been marked as a duplicate of bug 1117763 ***


Note You need to log in before you can comment on or make changes to this bug.