Bug 1120226 - VM's disk copied from template as thin provisioning is imported as preallocated (raw not sparse)
Summary: VM's disk copied from template as thin provisioning is imported as preallocat...
Keywords:
Status: CLOSED DUPLICATE of bug 1116486
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.5.0
Assignee: Tal Nisan
QA Contact: Aharon Canan
URL:
Whiteboard: storage
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-16 13:25 UTC by Carlos Mestre González
Modified: 2016-02-10 17:32 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-30 16:37:57 UTC
oVirt Team: Storage


Attachments (Terms of Use)

Description Carlos Mestre González 2014-07-16 13:25:48 UTC
Description of problem:
VM's disk imported doesn't preseve the disk image format type.

Version-Release number of selected component (if applicable):
av10.1

How reproducible:
100%

Steps to Reproduce:
1. Create a vm from a template as thin provisioning
2. Export the the template and vm.
3. Remove the vm and template from the setup
4. Import the vm (the UI will force you to use collapse snapshot)

Actual results:
VM's disk is exported as preallocated.


Expected results:
VM's disk keep the format that the original vm was, thin provisioning (COW sparse).


Additional info:
Maybe related or the same bug: https://bugzilla.redhat.com/show_bug.cgi?id=1120087

Comment 1 Carlos Mestre González 2014-07-17 08:29:15 UTC
Run was in iSCSI master domain exported to a NFS extorage domain.

Comment 2 Allon Mureinik 2014-07-17 09:25:24 UTC
(In reply to Carlos Mestre González from comment #1)
> Run was in iSCSI master domain exported to a NFS extorage domain.
And imported back to the same domain?

Comment 3 Carlos Mestre González 2014-07-17 09:33:14 UTC
Yes, imported back to the same domain.

Comment 4 Carlos Mestre González 2014-07-17 18:34:48 UTC
From the description, the Actual result should be:
VM's disk is *imported* as preallocated.

I've run this with the same but instead but instead of importing the vm with collapse snapshots with clone (that includes collapse snapshot) and the same happens, Vm's disk is imported as preallocated to the original nfs master domain even if was created with a thin disk.

Comment 5 Sean Cohen 2014-07-30 16:37:57 UTC

*** This bug has been marked as a duplicate of bug 1116486 ***


Note You need to log in before you can comment on or make changes to this bug.