Bug 1120271 - creating compute resource with name more than 245 chars fails
Summary: creating compute resource with name more than 245 chars fails
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: orabin
QA Contact: sthirugn@redhat.com
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks: 913449 1120095 1120181 1120998 1121521 1121936 1122901 1123818 1126496 1129202
TreeView+ depends on / blocked
 
Reported: 2014-07-16 15:21 UTC by Kedar Bidarkar
Modified: 2016-04-22 16:53 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-11 12:23:41 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 6694 None None None 2016-04-22 16:53:22 UTC

Description Kedar Bidarkar 2014-07-16 15:21:57 UTC
Description of problem:

Creating a compute resource name with 245 chars fails with the below error.

PGError: ERROR: value too long for type character varying(255) : INSERT INTO "compute_resources" ("attrs", "created_at", "description", "name", "password", "type", "updated_at", "url", "user", "uuid") VALUES ($1, $2, $3, $4, $5, $6, $7, $8, $9, $10) RETURNING "id"


I believe the actual limit is 255 chars and anything from 256 chars should fail.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
compute resource name with 245 chars fails

Expected results:

compute resource name with upto 255 chars should be possible.
Additional info:

Comment 1 RHEL Product and Program Management 2014-07-16 15:43:55 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 orabin 2014-07-17 06:56:06 UTC
Created redmine issue http://projects.theforeman.org/issues/6658 from this bug

Comment 4 Kedar Bidarkar 2014-07-17 09:39:27 UTC
also when more than 255 chars are entered, we should get a message saying "more than 255 chars is not allowed".

Comment 5 Kedar Bidarkar 2014-07-17 09:41:08 UTC
the same also applies for name and desc fields.

Comment 6 Bryan Kearney 2014-07-31 10:03:52 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/6694 has been closed
-------------
Ori Rabin
Applied in changeset commit:3034e8e28302eab858fa43b71136212350396808.

Comment 9 sthirugn@redhat.com 2014-08-08 19:56:15 UTC
Verified. I am able to create compute resource with name of 255 characters.  Attempting to create compute resource with name of 256 characters shows an error: is too long (maximum is 255 characters)

Version Tested:
GA Snap 4 - Satellite-6.0.4-RHEL-6-20140806.0

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.19-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.19-1.el6_5.noarch
* candlepin-tomcat6-0.9.19-1.el6_5.noarch
* elasticsearch-0.90.10-4.el6sat.noarch
* foreman-1.6.0.38-1.el6sat.noarch
* foreman-compute-1.6.0.38-1.el6sat.noarch
* foreman-gce-1.6.0.38-1.el6sat.noarch
* foreman-libvirt-1.6.0.38-1.el6sat.noarch
* foreman-ovirt-1.6.0.38-1.el6sat.noarch
* foreman-postgresql-1.6.0.38-1.el6sat.noarch
* foreman-proxy-1.6.0.23-1.el6sat.noarch
* foreman-selinux-1.6.0.4-1.el6sat.noarch
* foreman-vmware-1.6.0.38-1.el6sat.noarch
* katello-1.5.0-28.el6sat.noarch
* katello-ca-1.0-1.noarch
* katello-certs-tools-1.5.6-1.el6sat.noarch
* katello-installer-0.0.57-1.el6sat.noarch
* openldap-2.4.23-34.el6_5.1.x86_64
* pulp-katello-0.3-3.el6sat.noarch
* pulp-nodes-common-2.4.0-0.30.beta.el6sat.noarch
* pulp-nodes-parent-2.4.0-0.30.beta.el6sat.noarch
* pulp-puppet-plugins-2.4.0-0.30.beta.el6sat.noarch
* pulp-puppet-tools-2.4.0-0.30.beta.el6sat.noarch
* pulp-rpm-plugins-2.4.0-0.30.beta.el6sat.noarch
* pulp-selinux-2.4.0-0.30.beta.el6sat.noarch
* pulp-server-2.4.0-0.30.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.1.0-2.el6sat.noarch
* sssd-ldap-1.11.5.1-3.el6.x86_64

Comment 11 Bryan Kearney 2014-09-11 12:23:41 UTC
This was delivered with Satellite 6.0 which was released on 10 September 2014.


Note You need to log in before you can comment on or make changes to this bug.