Bug 1122901 - PGError when architecture name exceeds 255 characters
Summary: PGError when architecture name exceeds 255 characters
Keywords:
Status: CLOSED DUPLICATE of bug 1120095
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: Unspecified
Assignee: orabin
QA Contact: Katello QA List
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On: 1120271
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-24 10:56 UTC by Sachin Ghai
Modified: 2016-04-22 14:57 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-29 16:47:35 UTC


Attachments (Terms of Use)
PgError when arch name exceeds 255 characters (24.02 KB, image/png)
2014-07-24 10:56 UTC, Sachin Ghai
no flags Details


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 6658 None None None 2016-04-22 14:57:05 UTC

Description Sachin Ghai 2014-07-24 10:56:47 UTC
Created attachment 920501 [details]
PgError when arch name exceeds 255 characters

Description of problem:
I was trying to perform boundary test are created a new architecture with more than 255 characters in name and UI raises following error:

Error
PGError: ERROR: value too long for type character varying(255) : INSERT INTO "architectures" ("created_at", "hostgroups_count", "hosts_count", "name", "updated_at") VALUES ($1, $2, $3, $4, $5) RETURNING "id"


Version-Release number of selected component (if applicable):
sat6 GA snap1

How reproducible:
always

Steps to Reproduce:
1. create arch with name more 255 char
2.
3.

Actual results:
Error
PGError: ERROR: value too long for type character varying(255) : INSERT INTO "architectures" ("created_at", "hostgroups_count", "hosts_count", "name", "updated_at") VALUES ($1, $2, $3, $4, $5) RETURNING "id"

Expected results:
A proper validation error should be raised.


Additional info:
Processing by ArchitecturesController#create as */*
  Parameters: {"utf8"=>"✓", "search"=>"", "authenticity_token"=>"XLkNroe/1GYA+eEExa2V5ge+6IRgFtgTIMEwhb4GycY=", "architecture"=>{"name"=>"ojJELjrEfavaKHSkSDTncoiqjwik12345yyteyNSBmqcshsFlNcAsGExwayeTXjFOQmXTuVNWCotNUBMbiJmDKtsPtLnXqYJSjTUyNIlSNAAucqVkKXGFrViwyGLTRnqqBaLuGskexxWkYHTLHdLFMEXTmRLiGZgvkTGGmqGEKpGwzEOerEAbVJWBLaKytzydTwJcIQOUdBxowqKqIUSJKZkYHwUzkPWGjQMkpdpadzBctjvjBMDmpfPYurKybz1", "operatingsystem_ids"=>[""]}}
Operation FAILED: PGError: ERROR:  value too long for type character varying(255)
: INSERT INTO "architectures" ("created_at", "hostgroups_count", "hosts_count", "name", "updated_at") VALUES ($1, $2, $3, $4, $5) RETURNING "id"
  Rendered common/500.html.erb (7.1ms)
Completed 500 Internal Server Error in 166ms (Views: 9.7ms | ActiveRecord: 2.6ms)

Comment 1 Dominic Cleal 2014-07-24 11:02:39 UTC
Thanks, we're collecting lots of near-identical BZs, please just add them to bug #1120271 in future.

Comment 3 Sachin Ghai 2014-07-24 11:24:45 UTC
@Dominic: Sure. I'll update  bug #1120271, if found similar bz with any other entity. Thank you for quickly ack'ing all such bugs.

Comment 4 Bryan Kearney 2014-07-29 16:47:35 UTC
The same fix for 1120095 fixes this as well. Please treat these as duplicates.

*** This bug has been marked as a duplicate of bug 1120095 ***


Note You need to log in before you can comment on or make changes to this bug.