Bug 112037 - Custom kernel from 2.6.0-0.test11.1.100 kernel panic
Custom kernel from 2.6.0-0.test11.1.100 kernel panic
Status: CLOSED DUPLICATE of bug 112623
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-13 05:37 EST by raxet
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
ksyms.0 of working 2.6.0 test11 (12.40 KB, text/plain)
2003-12-13 05:41 EST, raxet
no flags Details

  None (edit)
Description raxet 2003-12-13 05:37:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031016

Description of problem:
I immediately received a kernel panic on (0,0) for
kernel-2.6.0-0.test11.1.100.i686.

My sata drive (0000:02:04.0 RAID bus controller: Promise Technology,
Inc. PDC20376 (rev 02)) works well with the .i686 rpm kernel from
people.redhat.com/arjanv/2.5 though.

Also of note, the make modules_install for the custom kernel leaves
the permissions for the .ko's incorrectly permissioned. I had to do
chmod 744 -R * from the lib/modules/2.6.0-0.test11.1.100custom to get
the drivers properly permissioned. Is that required?



Version-Release number of selected component (if applicable):
2.6.0-0.test11.1.100

How reproducible:
Always

Steps to Reproduce:
1. do a custom kernel make xconfig, make clean, make bzImage, make
modules, make modules_install, make install
2. reboot
3. kernel panick on (0,0)
    

Actual Results:  Kernel panick

Expected Results:  boot normally to gnome

Additional info:

0000:02:04.0 RAID bus controller: Promise Technology, Inc. PDC20376
(rev 02)

Also see attached message log of the error.
Comment 1 raxet 2003-12-13 05:41:43 EST
Created attachment 96510 [details]
ksyms.0 of working 2.6.0 test11
Comment 2 raxet 2003-12-13 05:45:18 EST
Comment on attachment 96510 [details]
ksyms.0 of working 2.6.0 test11

Fri Dec 12 18:19:22 MST 2003
Linux maxer.dsl.xmission.com 2.6.0-0.test11.1.100 #1 Mon Dec 8 11:17:41 EST
2003 i686 i686 i386 GNU/Linux
processor	: 0
vendor_id	: GenuineIntel
cpu family	: 15
model		: 2
model name	: Intel(R) Pentium(R) 4 CPU 1.80GHz
stepping	: 4
cpu MHz 	: 1804.188
cache size	: 512 KB
fdiv_bug	: no
hlt_bug 	: no
f00f_bug	: no
coma_bug	: no
fpu		: yes
fpu_exception	: yes
cpuid level	: 2
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat
pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm
bogomips	: 3591.37

ohci_hcd 16000 0 - Live 0x328f2000
floppy 53972 0 - Live 0x32a2d000
usblp 11520 0 - Live 0x328b7000
dm_mod 35872 0 - Live 0x3290a000
hid 56000 0 - Live 0x3295d000
ehci_hcd 20612 0 - Live 0x32903000
uhci_hcd 27152 0 - Live 0x328fb000
usbcore 94684 7 ohci_hcd,usblp,hid,ehci_hcd,uhci_hcd, Live 0x32931000
thermal 12816 0 - Live 0x328b2000
processor 13860 1 thermal, Live 0x328ad000
fan 3980 0 - Live 0x3283e000
button 6168 0 - Live 0x3284b000
battery 9484 0 - Live 0x32898000
asus_acpi 10136 0 - Live 0x32894000
ac 4876 0 - Live 0x3284e000
ext3 112552 2 - Live 0x32914000
jbd 50200 1 ext3, Live 0x3289f000
sbp2 22408 0 - Live 0x3287b000
ohci1394 30600 0 - Live 0x32885000
ieee1394 212780 2 sbp2,ohci1394, Live 0x328bd000
sata_promise 11012 3 - Live 0x32847000
libata 35456 1 sata_promise,[permanent], Live 0x32853000
sd_mod 15136 4 - Live 0x32842000
scsi_mod 108472 3 sbp2,libata,sd_mod, Live 0x3285f000
Comment 3 raxet 2003-12-13 05:46:17 EST
ignore attachment - bogus
Comment 4 raxet 2003-12-26 12:47:19 EST
was running fine with 2.6.0-1.14 until this kernel 2.6.0-1.21:

Not custom built either just ftp'd from
:/pub/fedora/linux/core/development/i386/Fedora/RPMS

VFS: Commit open root device "LABEL=/" or unknow-block Please append
... (0,0)

Kernel Panic VFS: Unable to mount root FS on unknown-block (0,0)
Comment 5 Kaj J. Niemi 2003-12-26 14:37:32 EST
Regarding your post 2003-12-26 12:47, you're most likely hitting bug
#112623, e.g. your mkinitrd is 3.5.16.1 and somehow the root device
gets figured wrong.

Downgrade your mkinitrd to 3.5.15.1 (or similar) and either re-install
the kernel-2.6.0-1.21 rpm or run the postinstall part from --scripts
manually. Both methods result in the creation of a new initrd image.
Comment 6 raxet 2003-12-26 16:04:04 EST
Using mkinitrd-3.5.14-1 resolves the issue completely

*** This bug has been marked as a duplicate of 112623 ***
Comment 7 Red Hat Bugzilla 2006-02-21 14:00:24 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.