Bug 112623 - fails attempting to find the root device
Summary: fails attempting to find the root device
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: mkinitrd (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 112037 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-12-24 19:43 UTC by Kaj J. Niemi
Modified: 2007-04-18 17:00 UTC (History)
8 users (show)

Fixed In Version: 3.5.17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-04 21:32:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kaj J. Niemi 2003-12-24 19:43:55 UTC
Description of problem:
kernel-2.6.0-1.21 is not able to find the root device "LABEL=/".
mkinitrd is at version 3.5.16.1-1. Both kernel's initrd.img files look
the same upon unpacking them, the same modules, etc.

How reproducible:
Always.

Steps to Reproduce:
1. rpm -ivh kernel-2.6.0-1.21.i686.rpm
2. reboot
3.
  
Actual results:
Prints out the following (copied to paper from the screen):

VFS: Mounted root (ext2 file system)
Red Hat nash version 3.5.16.1 starting
Loading jd.ko module
Loading ext3.ko module
Mounting /proc
Mounting sysfs
Creating block devices
VFS: Cannot open root device "LABEL=/" or unknown-block(0,0)
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on unknown-block(0,0)

Expected results:
Should work as 2.6.0-0.1.14 and earlier ones did.

Additional info:
My /etc/grub.conf looks the following and the entry for 2.6.0-0.1.14
works fine:

title Fedora Core (2.6.0-1.21)
        root (hd0,0)
        kernel /boot/vmlinuz-2.6.0-1.21 ro root=LABEL=/ acpi=on
        initrd /boot/initrd-2.6.0-1.21.img
title Fedora Core (2.6.0-0.1.14)
        root (hd0,0)
        kernel /boot/vmlinuz-2.6.0-0.1.14 ro root=LABEL=/ acpi=on
        initrd /boot/initrd-2.6.0-0.1.14.img

Comment 1 Kaj J. Niemi 2003-12-24 19:52:49 UTC
Ok, downgraded mkinitrd to 3.5.15.1-2 and the kernel is able to boot
normally.

Seems like the problem would be the patch from Al Viro? (3.5.16 and up?)

Changing component to mkinitrd.

Comment 2 raxet 2003-12-26 21:04:09 UTC
*** Bug 112037 has been marked as a duplicate of this bug. ***

Comment 3 Ralf Ertzinger 2003-12-31 12:45:46 UTC
I am seeing this with 2.6.0-1.107, mkinitrd-3.5.16.1-1.

Seems to me that the cause is that the linuxrc script no longer mounts
/proc (but mounts /sys instead), so the nash "mkdevices" fails (which
needs /proc/partitions), so it all falls down.

Maybe all this can be done via /sys, too, but nash does not know about it.

Comment 4 sangu 2004-01-03 07:07:04 UTC
The same problem happens in kernel-2.6.0-1.23, mkinitrd-3.5.16.1-1.

but The problem didn't happen in kernel-2.6.0-1.21, mkinitrd-23.5.16.1-1.

Comment 5 Mike Chambers 2004-01-03 15:23:39 UTC
I don't have that problem with kernel-2.6.0-1.23 but my mkinitrd
package is already downgraded to FC1's initial version.

Comment 6 Kaj J. Niemi 2004-01-03 15:55:50 UTC
sangu: verify install order with rpm -qa --last, I bet your
kernel-2.6.0-1.21 was installed before mkinitrd-3.5.16.1-1.

ralf: /proc is mounted as usual within linuxrc, you can verify it
yourself by ungzipping the inird image and mounting it as -o loop
somewhere.

Yes, it looks like the problem would be within mkdevicesCommand() in
nash.c.



Comment 7 sangu 2004-01-04 05:09:32 UTC
Kaj J. Niemi : You're right. Thank your comments.

Comment 8 Jeremy Katz 2004-01-04 21:32:40 UTC
This will be fixed in 3.5.17 built against a newer dietlibc
(dietlibc-0.24-1 had a slightly broken snprintf)


Note You need to log in before you can comment on or make changes to this bug.