Bug 1120394 - Installer fails because mongodb has not initialized yet
Summary: Installer fails because mongodb has not initialized yet
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Eric Helms
QA Contact: Og Maciel
URL:
Whiteboard:
: 1122197 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-16 20:01 UTC by Og Maciel
Modified: 2014-08-08 17:39 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-08 17:39:12 UTC


Attachments (Terms of Use)

Description Og Maciel 2014-07-16 20:01:02 UTC
Description of problem:

Our automation has show that both Beta released code and today's compose (July 16th, 2014) are failing to install due to mongodb not being initialized:

/Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]: Failed to call refresh: /usr/sbin/foreman-rake db:seed returned 1 instead of one of [0]

Subsequent manual execution of the installer works as mongodb is already running.


Version-Release number of selected component (if applicable):


How reproducible:

Hard

Steps to Reproduce:
1. Run the installer
2.
3.

Actual results:

Installer fails

Expected results:


Additional info:

 grep 'WAIT_MAX=' /usr/share/katello/script/service-wait
WAIT_MAX=${WAIT_MAX:-120}

Comment 2 Eric Helms 2014-08-07 15:23:38 UTC
*** Bug 1122197 has been marked as a duplicate of this bug. ***

Comment 3 Og Maciel 2014-08-08 17:39:12 UTC
Looks like we can no longer reproduce it so I'm closing it.


Note You need to log in before you can comment on or make changes to this bug.