Bug 1122197 - service-wait timeout is too short for mongodb initialization on slow systems
Summary: service-wait timeout is too short for mongodb initialization on slow systems
Keywords:
Status: CLOSED DUPLICATE of bug 1120394
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
high
high vote
Target Milestone: Unspecified
Assignee: Elyézer Rezende
QA Contact: Katello QA List
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-22 18:23 UTC by Jason Montleon
Modified: 2016-04-22 16:15 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-07 15:23:38 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 6730 None None None 2016-04-22 16:15:31 UTC

Description Jason Montleon 2014-07-22 18:23:26 UTC
service-wait has a timeout of 30 seconds, which is too short for mongodb initialization on slow systems. I have used a timeout of 120 to circumvent the issue in the past, but not sure if this is enough for all cases.

This can be modified easily in /etc/sysconfig/service-wait, but unfortunately it breaks the installation if it isn't known and done before the install and could leave the host in a bad state.

Comment 1 RHEL Product and Program Management 2014-07-22 18:23:56 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Elyézer Rezende 2014-07-22 18:29:48 UTC
I'm facing this issue every time I try to install Satellite. The timeout occurs every time due to mongodb service.

Comment 5 Elyézer Rezende 2014-07-22 19:26:35 UTC
https://github.com/Katello/katello/pull/4472 fixes the problem.

Comment 6 Elyézer Rezende 2014-07-23 17:16:25 UTC
This https://github.com/Katello/katello-installer/pull/89 is more specific to the problem. The previous comment's PR fix is not necessary if the fix comes to the katello-installer.

Comment 8 Eric Helms 2014-08-07 15:23:38 UTC

*** This bug has been marked as a duplicate of bug 1120394 ***


Note You need to log in before you can comment on or make changes to this bug.