Bug 1120442 - PastDataAggregator - InvalidTypeException: Column type is of type int
Summary: PastDataAggregator - InvalidTypeException: Column type is of type int
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: RHQ Project
Classification: Other
Component: Core Server
Version: 4.12
Hardware: Unspecified
OS: Unspecified
unspecified
urgent vote
Target Milestone: ---
: RHQ 4.13
Assignee: John Sanda
QA Contact: Mike Foley
URL:
Whiteboard:
Depends On: 1120775
Blocks: 1133605
TreeView+ depends on / blocked
 
Reported: 2014-07-17 00:13 UTC by Elias Ross
Modified: 2014-09-11 16:03 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-11 16:03:43 UTC


Attachments (Terms of Use)

Description Elias Ross 2014-07-17 00:13:08 UTC
Description of problem:

This was seen post upgrade

00:09:07,342 WARN  [org.rhq.server.metrics.aggregation.PastDataAggregator] (StorageClientThreadPool-3) There was an error aggregating data: com.datastax.drive
r.core.exceptions.InvalidTypeException: Column type is of type int
        at com.datastax.driver.core.ColumnDefinitions.checkType(ColumnDefinitions.java:282) [cassandra-driver-core-1.0.5.jar:]
        at com.datastax.driver.core.Row.getDouble(Row.java:273) [cassandra-driver-core-1.0.5.jar:]
        at org.rhq.server.metrics.domain.RawNumericMetricMapper$2.map(RawNumericMetricMapper.java:116) [rhq-server-metrics-4.12.0.jar:4.12.0]
        at org.rhq.server.metrics.domain.RawNumericMetricMapper$2.mapAll(RawNumericMetricMapper.java:90) [rhq-server-metrics-4.12.0.jar:4.12.0]
        at org.rhq.server.metrics.domain.RawNumericMetricMapper.mapAll(RawNumericMetricMapper.java:124) [rhq-server-metrics-4.12.0.jar:4.12.0]
        at org.rhq.server.metrics.aggregation.BaseAggregator$1$1$1.next(BaseAggregator.java:262) [rhq-server-metrics-4.12.0.jar:4.12.0]
        at org.rhq.server.metrics.aggregation.BaseAggregator$1$1$1.next(BaseAggregator.java:254) [rhq-server-metrics-4.12.0.jar:4.12.0]
        at org.rhq.server.metrics.aggregation.BaseAggregator$2.apply(BaseAggregator.java:283) [rhq-server-metrics-4.12.0.jar:4.12.0]
        at org.rhq.server.metrics.aggregation.BaseAggregator$2.apply(BaseAggregator.java:279) [rhq-server-metrics-4.12.0.jar:4.12.0]
        at com.google.common.util.concurrent.Futures$1.apply(Futures.java:720) [guava-14.0.1.jar:]
        at com.google.common.util.concurrent.Futures$ChainingListenableFuture.run(Futures.java:859) [guava-14.0.1.jar:]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_40]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_40]
        at java.lang.Thread.run(Thread.java:724) [rt.jar:1.7.0_40]


It seems similar to the Bug 1120441 although I'm not sure the cause.

Version-Release number of selected component (if applicable): 4.12, upgrade from 4.9




How reproducible: Unclear

Comment 2 Mike Foley 2014-07-18 12:48:42 UTC
related JON 3.3 QE ticket ...

https://engineering.redhat.com/trac/jon/ticket/1256

QE Deliverable:
1) upgrade testing
2) review logs ...looking for this error, or other errors
3) mark this BZ as verified ...or if it repros ...add a JON 3.3 BZ and make it URGENT/BLOCKING
4) attach upgrade logs to document that this testing was performed.

requested dev deliverable:
1) comment on this BZ and add info
2) fix in RHQ/master if needed.

Comment 4 John Sanda 2014-09-11 16:03:43 UTC
I am closing this since the code involved has been removed as part of the work for bug 1114202.


Note You need to log in before you can comment on or make changes to this bug.