Bug 1120573 - No release was listed for the RHEL6.6
Summary: No release was listed for the RHEL6.6
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.6
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Bryan Kearney
QA Contact: John Sefler
URL:
Whiteboard:
: 1122155 (view as bug list)
Depends On:
Blocks: 1083985 rhsm-rhel67
TreeView+ depends on / blocked
 
Reported: 2014-07-17 08:02 UTC by xingge
Modified: 2016-09-20 02:28 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1123267 (view as bug list)
Environment:
Last Closed: 2015-04-02 21:41:40 UTC


Attachments (Terms of Use)

Description xingge 2014-07-17 08:02:58 UTC
Description of problem:
Run cmd subscription-manager release --list and will get nothing.

Version-Release number of selected component (if applicable):
RHEL6.6-server64-20140716.0
subscription-manager-gui-1.12.4-1.el6.x86_64
subscription-manager-firstboot-1.12.4-1.el6.x86_64
subscription-manager-1.12.4-1.el6.x86_64
python-rhsm-1.12.4-1.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1.Register the system and attach some subscriptions
2.run subscription-manager release --list to list the available release.

Actual results:
[root@localhost ~]# subscription-manager release --list
No release versions available, please check subscriptions.

Expected results:
[root@localhost ~]# subscription-manager release --list
6.1
6.2
6.3
6.4
6.5
6Server

Additional info:
The url http://cdn.qa.redhat.com/content/dist/rhel/server/6/listing contain the release list.

Comment 2 Petr Janda 2014-07-24 13:25:32 UTC
*** Bug 1122155 has been marked as a duplicate of this bug. ***

Comment 3 Adrian Likins 2014-08-14 17:59:50 UTC
Need /var/log/rhsm/rhsm.log from system showing this.

Comment 8 Bryan Kearney 2014-11-03 19:48:08 UTC
Moving bugs to 6.7

Comment 9 Bryan Kearney 2014-11-03 19:49:08 UTC
Moving bugs to 6.7

Comment 10 Bryan Kearney 2014-11-03 19:53:50 UTC
Moving bugs to 6.7

Comment 12 John Sefler 2015-04-02 21:41:40 UTC
The content listing file appears to have been fixed by release engineering...

[root@jsefler-os6 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.9.26.8-1
subscription management rules: 5.12
subscription-manager: 1.14.1-1.el6
python-rhsm: 1.14.1-1.el6
[root@jsefler-os6 ~]# subscription-manager list --installed 

+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+
Product Name:   Red Hat Enterprise Linux Server
Product ID:     69
Version:        6.6
Arch:           x86_64
Status:         Subscribed
Status Details: 
Starts:         12/31/2014
Ends:           12/30/2015

You have mail in /var/spool/mail/root
[root@jsefler-os6 ~]# subscription-manager release --list
+-------------------------------------------+
          Available Releases
+-------------------------------------------+
6.1
6.2
6.3
6.4
6.5
6.6                      <============ VERIFIED
6Server
[root@jsefler-os6 ~]#


Note You need to log in before you can comment on or make changes to this bug.