Bug 1123267 - No release was listed for the RHEL5.11
Summary: No release was listed for the RHEL5.11
Keywords:
Status: CLOSED DUPLICATE of bug 1119809
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager
Version: 5.11
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: candlepin-bugs
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: 1090039 rhsm-rhel511
TreeView+ depends on / blocked
 
Reported: 2014-07-25 08:02 UTC by xingge
Modified: 2016-09-20 02:28 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1120573
Environment:
Last Closed: 2014-08-07 13:16:56 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description xingge 2014-07-25 08:02:21 UTC
+++ This bug was initially created as a clone of Bug #1120573 +++

Description of problem:
Run cmd subscription-manager release --list and will get nothing.

Version-Release number of selected component (if applicable):
RHEL5.11-server64-20140724.1
subscription-manager-gui-1.11.3-10.el5
subscription-manager-1.11.3-10.el5
subscription-manager-firstboot-1.11.3-10.el5
python-rhsm-1.11.3-5.el5

How reproducible:
always

Steps to Reproduce:
1.Register the system and attach some subscriptions
2.run subscription-manager release --list to list the available release.

Actual results:
[root@localhost ~]# subscription-manager release --list
No release versions available, please check subscriptions.

Expected results:
[root@localhost ~]# subscription-manager release --list
5.10
5.7
5.8
5.9
5Server

Additional info:
The url http://cdn.qa.redhat.com/content/dist/rhel/server/5/listing contain the release list.

--- Additional comment from John Sefler on 2014-07-17 09:58:15 EDT ---

This is likely a duplicate of bug 1119809 and is caused by the CDN qa server.

Seth may be able to give an update when this will be fixed.

--- Additional comment from Petr Janda on 2014-07-24 09:25:32 EDT ---

Comment 1 John Sefler 2014-08-07 13:16:56 UTC
Retesting...
[root@jsefler-5 ~]# rpm -q subscription-manager
subscription-manager-1.11.3-10.el5

[root@jsefler-5 ~]# subscription-manager register --serverurl=subscription.rhn.stage.redhat.com:443/subscription --username=stage_test_12 --password=redhat --autosubscribe --baseurl=https://cdn.redhat.com
The system has been registered with ID: 5b1a60ef-e32f-4095-9330-40583b11d17b 
Installed Product Current Status:
Product Name: Red Hat Enterprise Linux Server
Status:       Subscribed

[root@jsefler-5 ~]# subscription-manager release --list
+-------------------------------------------+
          Available Releases
+-------------------------------------------+
5.10
5.7
5.8
5.9
5Server
[root@jsefler-5 ~]# 


VERIFIED:  This is working.



The reason this failed in comment 0 is likely a duplicate of bug 1119809

[root@jsefler-5 ~]# subscription-manager config --rhsm.baseurl=https://cdn.qa.redhat.com
[root@jsefler-5 ~]# subscription-manager release --list
No release versions available, please check subscriptions.
[root@jsefler-5 ~]# 


Closing as a dup.

*** This bug has been marked as a duplicate of bug 1119809 ***


Note You need to log in before you can comment on or make changes to this bug.