Bug 1120703 - PGError searching for content with many content-views
Summary: PGError searching for content with many content-views
Keywords:
Status: CLOSED DUPLICATE of bug 1115308
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Brad Buckingham
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-17 13:57 UTC by Alex Krzos
Modified: 2014-08-11 18:51 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-11 18:51:14 UTC


Attachments (Terms of Use)
foreman production.log with debug logging (33.54 KB, text/plain)
2014-07-17 13:59 UTC, Alex Krzos
no flags Details
Screenshot of error in UI. (253.65 KB, image/png)
2014-07-17 13:59 UTC, Alex Krzos
no flags Details

Description Alex Krzos 2014-07-17 13:57:02 UTC
Description of problem:
Attempted to search for specific package in product content in Sat 6 Content search and PGError ambiguous reference to id is displayed.  See attached screenshot and foreman production.log snippet.

Version-Release number of selected component (if applicable):
Sat 6.0.3 Beta
Build: Snap11-Compose3
RHEL 6.5 2.6.32-431.20.3
katello-1.5.0-26.el6sat.noarch
foreman-1.6.0.21-1.el6sat.noarch
candlepin-0.9.19-1.el6_5.noarch
pulp-server-2.4.0-0.23.beta.el6sat.noarch
puppet-3.6.2-1.el6sat.noarch

How reproducible:
Always

Steps to Reproduce:
1. Assuming pre-built Sat 6.0.3 with manifest uploaded, content syned, custom content synced, content views published/promoted
2. Navigate to content search, select Products under content, and attempt to search for a package under products.

Actual results:
PG Error is displayed on browser and error is dumped to foreman/production.log 

Expected results:
Content is searched and no error is displayed.

Additional info:
I have published/promoted a minimum of 99 content views.

Comment 1 Alex Krzos 2014-07-17 13:59:33 UTC
Created attachment 918728 [details]
foreman production.log with debug logging

Comment 2 Alex Krzos 2014-07-17 13:59:58 UTC
Created attachment 918729 [details]
Screenshot of error in UI.

Comment 3 RHEL Product and Program Management 2014-07-17 14:04:11 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 5 Josep 'Pep' Turro Mauri 2014-08-01 15:30:15 UTC
(In reply to Alex Krzos from comment #0)
> Additional info:
> I have published/promoted a minimum of 99 content views.

In case it helps: I just hit this having published/promoted no content views yet, just sync'd a RHEL repo into the Library, went to search for a package, selected the auto-complete for repos and the error appeared as soon as I started typing:

PGError: ERROR: column reference "id" is ambiguous LINE 1: SELECT id FROM "katello_repositories" INNER JOIN "katello_pr... ^ : SELECT id FROM "katello_repositories" INNER JOIN "katello_products" ON "katello_products"."id" = "katello_repositories"."product_id" INNER JOIN "katello_content_view_versions" ON "katello_content_view_versions"."id" = "katello_repositories"."content_view_version_id" WHERE "katello_content_view_versions"."content_view_id" IN (1, 2) AND "katello_repositories"."product_id" IN (1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18) ORDER BY katello_repositories.name ASC (ActiveRecord::StatementInvalid)

Comment 6 Brad Buckingham 2014-08-11 18:51:14 UTC

*** This bug has been marked as a duplicate of bug 1115308 ***


Note You need to log in before you can comment on or make changes to this bug.