Bug 1120707 - Autocompletion for product on content search produces sql error
Summary: Autocompletion for product on content search produces sql error
Keywords:
Status: CLOSED DUPLICATE of bug 1115308
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Brad Buckingham
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-17 14:06 UTC by Ivan Necas
Modified: 2014-08-11 18:51 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-11 18:51:11 UTC


Attachments (Terms of Use)
Product autocomplete error (105.60 KB, image/png)
2014-07-29 19:26 UTC, sthirugn@redhat.com
no flags Details

Description Ivan Necas 2014-07-17 14:06:43 UTC
Steps to Reproduce:
1. UI -> Content Search
2. Search by Product
3. Type anything in the search part (autocomplete)


Actual results:
The exception:

PGError: ERROR: column reference "id" is ambiguous LINE 1: SELECT id FROM "katello_products" INNER JOIN "katello_reposi... ^ : SELECT id FROM "katello_products" INNER JOIN "katello_repositories" ON "katello_repositories"."product_id" = "katello_products"."id" INNER JOIN "katello_content_view_versions" ON "katello_content_view_versions"."id" = "katello_repositories"."content_view_version_id" WHERE "katello_content_view_versions"."content_view_id" IN (1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11) (ActiveRecord::StatementInvalid)

is shown

Expected results:
no exceptions

Additional info:

Comment 2 sthirugn@redhat.com 2014-07-29 19:25:36 UTC
This also gives me an UI error (see attachment)

Comment 3 sthirugn@redhat.com 2014-07-29 19:26:07 UTC
Created attachment 922297 [details]
Product autocomplete error

Comment 4 Brad Buckingham 2014-08-11 18:51:11 UTC

*** This bug has been marked as a duplicate of bug 1115308 ***


Note You need to log in before you can comment on or make changes to this bug.