Bug 1120721 - Fail to get template/disk via REST
Summary: Fail to get template/disk via REST
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: vdsm
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.5.0
Assignee: Saggi Mizrahi
QA Contact: Antonin Pagac
URL:
Whiteboard: infra
: 1135987 (view as bug list)
Depends On:
Blocks: 966103 1073943
TreeView+ depends on / blocked
 
Reported: 2014-07-17 14:49 UTC by Gal Amado
Modified: 2016-02-10 19:30 UTC (History)
13 users (show)

Fixed In Version: ioprocess-0.10.0-1.el6_5.noarch
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-17 12:43:22 UTC
oVirt Team: Infra


Attachments (Terms of Use)
vdsm.log (8.70 MB, text/x-log)
2014-07-17 14:49 UTC, Gal Amado
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 29634 master MERGED oop: add missing utils.forceLink Never
oVirt gerrit 30545 None None None Never

Description Gal Amado 2014-07-17 14:49:20 UTC
Created attachment 918737 [details]
vdsm.log

Description of problem:
When trying to get api/templates/{ID}/disks , getting 
"500 Internal Server Error"


Version-Release number of selected component (if applicable):
oVirt Engine Version: 3.5.0-0.0.master.20140629172257.git0b16ed7.el6


How reproducible:
via rest API , try to get  api/templates/{ID}/disks

Steps to Reproduce:
1.up and running setup with shutdown VM + disks
2.create a template from that vm 
3.via rest API , try to get  api/templates/{ID}/disks

Actual results:
"500 Internal Server Error"
<fault>
<reason>Operation Failed</reason>
<detail>java.lang.reflect.InvocationTargetException</detail>
</fault>

Expected results:
get a response with the disks 


Additional info:
in the vdsm.log , we can see :
AttributeError: '_IOProcWrapper' object has no attribute 'utils'

Comment 1 Allon Mureinik 2014-07-18 08:28:08 UTC
The beef here is indeed the following error:
> AttributeError: '_IOProcWrapper' object has no attribute 'utils'

Yeela - AFAIK this was already solved?

Comment 2 Allon Mureinik 2014-07-18 08:29:06 UTC
Gal, can you attach the engine log too please?

Comment 3 Barak 2014-07-20 11:47:32 UTC
Saggi, wasn't that fixed already ?

Comment 4 Gal Amado 2014-08-05 07:34:29 UTC
Won't reproduce in 
oVirt Engine Version: 3.5.0-0.0.master.20140722232058.git8e1babc.el6 
vdsm Version : vdsm-4.16.1-0.gita4d9abf.el6.x86_64

probably fixed .

Comment 5 Maor 2014-09-01 13:47:59 UTC
*** Bug 1135987 has been marked as a duplicate of this bug. ***

Comment 6 Antonin Pagac 2014-09-03 08:23:52 UTC
Verified in: oVirt Engine Version: 3.5.0-0.0.master.20140821064931.gitb794d66.el6

Comment 7 Sandro Bonazzola 2014-10-17 12:43:22 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.