Bug 1120864 - [abrt] WARNING: CPU: 1 PID: 749 at drivers/gpu/drm/i915/intel_display.c:931 assert_pll+0x68/0x70 [i915]()
Summary: [abrt] WARNING: CPU: 1 PID: 749 at drivers/gpu/drm/i915/intel_display.c:931 a...
Keywords:
Status: CLOSED DUPLICATE of bug 1101633
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:02378d013acbf140dbcb614858d...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-17 21:37 UTC by Pete
Modified: 2014-11-19 15:50 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-19 15:50:57 UTC


Attachments (Terms of Use)
File: dmesg (93.34 KB, text/plain)
2014-07-17 21:37 UTC, Pete
no flags Details
gzipped output from /sys/class/drm/card0/error (94.49 KB, application/x-tar)
2014-07-18 22:21 UTC, Michael Young
no flags Details

Description Pete 2014-07-17 21:37:26 UTC
Description of problem:
Once 3.15.4 was installed my laptop cannot boot into X; it crashes with a black screen and no keyboard activity is accepted either (like ctl-alt-f2 or such to get a text screen).

Also the 3.15.5 kernel shows as tainted (flags GW) where the previous kernel didn't.  Don't know why a distributed kernel shows that (and the ABRT system refuses to report it...)

If the report includes dmesg anyhow then that will show.  If not, I can recover it from messages and the Xorg.log and attach them afterwards.

Additional info:
reporter:       libreport-2.2.2
WARNING: CPU: 1 PID: 749 at drivers/gpu/drm/i915/intel_display.c:931 assert_pll+0x68/0x70 [i915]()
PLL state assertion failure (expected on, current off)
Modules linked in: ccm fcoe libfcoe 8021q garp libfc scsi_transport_fc stp llc scsi_tgt mrp vfat fat fuse arc4 iwl4965 iwlegacy coretemp mac80211 kvm_intel kvm sdhci_pci iTCO_wdt joydev sdhci iTCO_vendor_support mmc_core acer_wmi cfg80211 sparse_keymap microcode tifm_7xx1 snd_hda_codec_realtek snd_hda_codec_generic lpc_ich tifm_core snd_hda_intel snd_hda_controller i2c_i801 serio_raw mfd_core snd_hda_codec snd_hwdep wmi snd_seq snd_seq_device rfkill nsc_ircc irda crc_ccitt snd_pcm snd_timer snd soundcore shpchp acpi_cpufreq nfsd auth_rpcgss nfs_acl lockd sunrpc binfmt_misc tg3 firewire_ohci i915 ata_generic pata_acpi firewire_core crc_itu_t yenta_socket ptp i2c_algo_bit drm_kms_helper pps_core drm i2c_core video
CPU: 1 PID: 749 Comm: X Not tainted 3.15.4-200.fc20.x86_64 #1
Hardware name: Acer            TravelMate 5720                /Columbia                       , BIOS V1.25           11/29/2007
 0000000000000000 00000000ce665fe4 ffff8800bae5b7a8 ffffffff816ef2b1
 ffff8800bae5b7f0 ffff8800bae5b7e0 ffffffff8108934d 0000000000000001
 000000000000a800 ffff880139bd6000 ffff8800b8fdc800 0000000000000001
Call Trace:
 [<ffffffff816ef2b1>] dump_stack+0x45/0x56
 [<ffffffff8108934d>] warn_slowpath_common+0x7d/0xa0
 [<ffffffff810893cc>] warn_slowpath_fmt+0x5c/0x80
 [<ffffffffa00f234b>] ? gen4_read32+0x4b/0xc0 [i915]
 [<ffffffffa00ffde8>] assert_pll+0x68/0x70 [i915]
 [<ffffffffa0105711>] intel_crtc_load_lut+0x1c1/0x1e0 [i915]
 [<ffffffffa0105946>] i9xx_crtc_enable+0x216/0x420 [i915]
 [<ffffffffa0108727>] __intel_set_mode+0x827/0x1640 [i915]
 [<ffffffffa010bbf6>] intel_set_mode+0x16/0x30 [i915]
 [<ffffffffa010cacd>] intel_crtc_set_config+0x8ed/0xdc0 [i915]
 [<ffffffffa0032541>] drm_mode_set_config_internal+0x61/0xf0 [drm]
 [<ffffffffa006e6d3>] drm_fb_helper_restore_fbdev_mode+0xb3/0xe0 [drm_kms_helper]
 [<ffffffffa00702f1>] drm_fb_helper_set_par+0x31/0x80 [drm_kms_helper]
 [<ffffffff813bb287>] fb_set_var+0x197/0x440
 [<ffffffff813b58b7>] ? bit_putcs+0x317/0x590
 [<ffffffff810c5aa7>] ? update_curr+0x67/0x160
 [<ffffffff813b1b31>] fbcon_blank+0x1f1/0x2f0
 [<ffffffff81431bb8>] do_unblank_screen+0xb8/0x1f0
 [<ffffffff814279fa>] complete_change_console+0x5a/0xe0
 [<ffffffff81428a55>] vt_ioctl+0xfd5/0x1190
 [<ffffffff8141c559>] tty_ioctl+0x289/0xb70
 [<ffffffff81227ba8>] ? fsnotify+0x238/0x310
 [<ffffffff811f94a0>] do_vfs_ioctl+0x2e0/0x4a0
 [<ffffffff811e86d1>] ? __sb_end_write+0x31/0x60
 [<ffffffff811f96e1>] SyS_ioctl+0x81/0xa0
 [<ffffffff816ff2e9>] system_call_fastpath+0x16/0x1b

Comment 1 Pete 2014-07-17 21:37:29 UTC
Created attachment 918834 [details]
File: dmesg

Comment 2 Michael Young 2014-07-18 22:21:23 UTC
Created attachment 919194 [details]
gzipped output from /sys/class/drm/card0/error

I am seeing a similar crash. I noticed in the dmesg output a request for the contents of /sys/class/drm/card0/error and I have successfully managed to get it (not easy when you don't have a working screen and the contents don't survive a reboot). I have gzipped the file to save space. The unzipped file is 776860 bytes.

Comment 3 Michael Young 2014-07-20 14:18:35 UTC
With 3.15.6-200.fc20.x86_64 I still get backtraces in /var/log/messages but the screen no longer blanks, so my computer is usable again.

Comment 4 Adam Jackson 2014-11-19 15:50:57 UTC

*** This bug has been marked as a duplicate of bug 1101633 ***


Note You need to log in before you can comment on or make changes to this bug.