Bug 1121073 - [ja_JP][Admin portal] : 'Guide Me' needs to be localized.
Summary: [ja_JP][Admin portal] : 'Guide Me' needs to be localized.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal
Version: 3.5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: 3.5.0
Assignee: Yuko Katabami
QA Contact: Pavel Stehlik
URL:
Whiteboard: i18n
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-18 10:21 UTC by Bhushan Barve
Modified: 2016-02-10 18:59 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-28 21:53:40 UTC
oVirt Team: i18n


Attachments (Terms of Use)
ja_JP 'Guide Me' (78.68 KB, image/png)
2014-07-18 10:21 UTC, Bhushan Barve
no flags Details
ja_JP_red_Hat_support (133.95 KB, image/png)
2014-07-18 10:23 UTC, Bhushan Barve
no flags Details
zanata: "Guide Me" [Japanese] (43.61 KB, image/png)
2014-07-28 20:03 UTC, Einav Cohen
no flags Details

Description Bhushan Barve 2014-07-18 10:21:41 UTC
Created attachment 919033 [details]
ja_JP 'Guide Me'

Description of problem:

In RHEVM admin portal, for ja_JP locale following strings are not localized-
Guide Me - at datacenter and cluster tabs.
Red Hat Access:support - the string and the pane at all occurrences


Version-Release number of selected component (if applicable):
Red Hat Enterprise Virtualization Manager: 3.5.0-0.4.master.el6_5

How reproducible:
always

Steps to Reproduce:
1.Login to RHEVM admin portal with ja_JP locale.
2.check datacenter and cluster tabs
3.also check all occurrences of Red Hat access:support

Actual results:
'Guide Me' string is not localized.
'red Hat access:support' string and the pane is not localized.

Expected results:
both should be localized.

Additional info:

Comment 1 Bhushan Barve 2014-07-18 10:23:32 UTC
Created attachment 919036 [details]
ja_JP_red_Hat_support

Comment 2 Einav Cohen 2014-07-28 20:03:01 UTC
Created attachment 921912 [details]
zanata: "Guide Me" [Japanese]

Comment 3 Einav Cohen 2014-07-28 20:39:46 UTC
- please don't document several issues in a single BZ. 

- all Red Hat Support content is not built-in the application - it is added via the UI plugin infrastructure, therefore localizing it is not trivial.
localization issues for UI plugins in general as well as for the RHS plugin in particular will be taken care of in the context of bug 1009731 and bug 1009722 -> removing the "Red Hat access:support" from the BZ subject.

** this BZ tracks only the "Guide Me" buttons-text issue **. 

- see attachment 921912 [details]: it seems that the Japanese translation for "Guide Me" for Clusters and Data-Centers (and VMs as well) in Zanata is in English. 
@Yuko: there is a chance that you left this in English on purpose, however I am not sure. 
If the Japanese translation was left in English on purpose - please close this BZ on NOT-A-BUG.
If the Japanese translation is in English by mistake and needs to be corrected - please grant "devel_ack+" to this BZ, correct the Japanese translation in Zanata ('ovirt' project, 'master' and 'ovirt-3.5' versions) and move this BZ to POST once done. 

Thanks.

Comment 4 Yuko Katabami 2014-07-28 21:53:40 UTC
Hi Einav,

I have already answered the same question last year.
It is not a bug as it was intentionally left in English.
Please check Comment 8 in https://bugzilla.redhat.com/show_bug.cgi?id=1010121

Moving the status to CLOSED.


Note You need to log in before you can comment on or make changes to this bug.