Bug 1121240 - python26-jinja2 is missing a Requires for python26-distribute
Summary: python26-jinja2 is missing a Requires for python26-distribute
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: python26-jinja2
Version: el5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Thomas Moschny
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-18 17:53 UTC by Erik Johnson
Modified: 2014-08-19 16:24 UTC (History)
3 users (show)

Fixed In Version: python26-jinja2-2.5.5-6.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-19 16:24:51 UTC


Attachments (Terms of Use)

Description Erik Johnson 2014-07-18 17:53:49 UTC
Description of problem:

Missing build dep results in jinja2.__version__ to evaluate to "unknown"

How reproducible:

100% of the time on a box without python26-distribute

Steps to Reproduce:
1. Install python26-jinja2
2. Run the command: python26 -c 'import jinja2; print(jinja2.__version__)'

Actual results:

The command returns "unknown"

Expected results:

The command should return the version of Jinja2, "2.5.5"

Comment 1 Erik Johnson 2014-07-18 17:59:38 UTC
Actually, to clarify, it's not a missing build dep. python26-distribute is there as a BuildRequires, it just needs to also be there as a Requires.

Comment 2 Erik Johnson 2014-07-18 18:05:02 UTC
I've opened a bug report for RHEL6 since this issue affects RHEL6 and jinja2 is not in EPEL6. https://bugzilla.redhat.com/show_bug.cgi?id=1121241

Comment 3 Fedora Update System 2014-08-01 19:58:20 UTC
python26-jinja2-2.5.5-6.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/python26-jinja2-2.5.5-6.el5

Comment 4 Fedora Update System 2014-08-02 16:21:48 UTC
Package python26-jinja2-2.5.5-6.el5:
* should fix your issue,
* was pushed to the Fedora EPEL 5 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing python26-jinja2-2.5.5-6.el5'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-2101/python26-jinja2-2.5.5-6.el5
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2014-08-19 16:24:51 UTC
python26-jinja2-2.5.5-6.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.