Bug 1121241 - python-jinja2 missing a Requires for python-setuptools
Summary: python-jinja2 missing a Requires for python-setuptools
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: python-jinja2
Version: 6.7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Miro Hrončok
QA Contact: Branislav Náter
URL:
Whiteboard:
Depends On:
Blocks: 1356061 1373251
TreeView+ depends on / blocked
 
Reported: 2014-07-18 18:04 UTC by Erik Johnson
Modified: 2017-03-21 09:59 UTC (History)
7 users (show)

Fixed In Version: python-jinja2-2.2.1-3.el6
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-21 09:59:23 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0635 normal SHIPPED_LIVE python-jinja2 bug fix update 2017-03-21 12:30:37 UTC

Description Erik Johnson 2014-07-18 18:04:06 UTC
This is the same issue as https://bugzilla.redhat.com/show_bug.cgi?id=1121240, but jinja2 is in base/updates on RHEL6, hence the separate issue. Please close and link to the original issue if I have done this in error.


Description of problem:

Missing dep results in jinja2.__version__ to evaluate to "unknown"

How reproducible:

100% of the time on a box without python-setuptools

Steps to Reproduce:
1. Install python-jinja2
2. Run the command: python -c 'import jinja2; print(jinja2.__version__)'

Actual results:

The command returns "unknown"

Expected results:

The command should return the version of Jinja2, "2.2.1"


I'm guessing this bug exists on RHEL7 too (though I haven't had a chance to test), should I file a separate bug for that?

Comment 2 Bohuslav "Slavek" Kabrda 2014-07-29 14:35:56 UTC
This indeed is a bug and the suggested solution is correct - we should add python-setuptools as a runtime requirement to python-jinja2.
Note, that this is *not* a problem on RHEL 7, since in version 2.7.2, jinja doesn't specify version using setuptools anymore, but rather uses simple

__version__ = '2.7.2'

Comment 11 errata-xmlrpc 2017-03-21 09:59:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0635.html


Note You need to log in before you can comment on or make changes to this bug.