Bug 1121263 - augeas aug lens bug for /etc/services currently doesn't handle colon in service_name
Summary: augeas aug lens bug for /etc/services currently doesn't handle colon in servi...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: augeas
Version: 6.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Dominic Cleal
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 1075802 1121527
TreeView+ depends on / blocked
 
Reported: 2014-07-18 19:40 UTC by Dave Sullivan
Modified: 2019-07-11 08:04 UTC (History)
6 users (show)

Fixed In Version: augeas-1.0.0-8.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1121527 (view as bug list)
Environment:
Last Closed: 2015-07-22 05:40:49 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1256 normal SHIPPED_LIVE augeas bug fix and enhancement update 2015-07-20 17:50:00 UTC

Description Dave Sullivan 2014-07-18 19:40:30 UTC
Description of problem:

we have this swift application, which needs to put some entry like this in /etc/services: SWRPC.ACCESS.BSS:BS_rmq                         48102/tcp               # SWIFTAlliance_SWRPC ACCESS --. This means the 'service_name' field in services.aug file needs to be able to support colon character. Right now I just directly hacked this file to include colon character by changing this line: let word_re     = /[:a-zA-Z0-9_.+*\/-]+/

file hacked /usr/share/augeas/lenses/dist/systemd.aug

Version-Release number of selected component (if applicable):

[root@seaking ~]# rpm -qa augeas-libs
augeas-libs-1.0.0-5.el6_5.1.x86_64


How reproducible:

see above

Comment 2 Lingfei Kong 2014-07-21 02:43:19 UTC
Can reproduce with augeas-1.0.0-7.el6
Steps to reproduce:
1. Add the following line to /etc/services(the new line number is 10775)
SWRPC.ACCESS.BSS:BS_rmq                         48102/tcp               # SWIFTAlliance_SWRPC ACCESS

2. # augtool print /augeas//error
/augeas/files/etc/services/error = "parse_failed"
/augeas/files/etc/services/error/pos = "641020"
/augeas/files/etc/services/error/line = "10775"
/augeas/files/etc/services/error/char = "0"
/augeas/files/etc/services/error/lens = "/usr/share/augeas/lenses/dist/services.aug:81.10-.39:"
/augeas/files/etc/services/error/message = "Iterated lens matched less than it should"

Comment 3 Dominic Cleal 2014-07-21 07:19:49 UTC
Fixed in a32a5a395bc63094ba59857fd5dc329c28ddee32

Comment 10 Hu Zhang 2015-03-03 08:59:07 UTC
Reproduced with augeas-1.0.0-7.el6.x86_64.

Verified with the package:
augeas-1.0.0-8.el6.x86_64

Steps to verify:
1. Add the following line to /etc/services(the new line number is 10775)
SWRPC.ACCESS.BSS:BS_rmq                         48102/tcp               # SWIFTAlliance_SWRPC ACCESS

2. # augtool print /augeas/files/etc/services/error
Nothing returned.


No parse error returned.
So verified.

Comment 12 errata-xmlrpc 2015-07-22 05:40:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1256.html


Note You need to log in before you can comment on or make changes to this bug.