Bug 1121527 - augeas aug lens bug for /etc/services currently doesn't handle colon in service_name
Summary: augeas aug lens bug for /etc/services currently doesn't handle colon in servi...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: augeas
Version: 7.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Dominic Cleal
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 1121263
Blocks: 1064025
TreeView+ depends on / blocked
 
Reported: 2014-07-21 07:20 UTC by Dominic Cleal
Modified: 2019-07-11 08:04 UTC (History)
5 users (show)

Fixed In Version: augeas-1.1.0-13.el7
Doc Type: Bug Fix
Doc Text:
Clone Of: 1121263
Environment:
Last Closed: 2015-03-05 09:25:36 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0399 normal SHIPPED_LIVE augeas bug fix and enhancement update 2015-03-05 14:17:57 UTC

Description Dominic Cleal 2014-07-21 07:20:43 UTC
+++ This bug was initially created as a clone of Bug #1121263 +++

Description of problem:

we have this swift application, which needs to put some entry like this in /etc/services: SWRPC.ACCESS.BSS:BS_rmq                         48102/tcp               # SWIFTAlliance_SWRPC ACCESS --. This means the 'service_name' field in services.aug file needs to be able to support colon character. Right now I just directly hacked this file to include colon character by changing this line: let word_re     = /[:a-zA-Z0-9_.+*\/-]+/

file hacked /usr/share/augeas/lenses/dist/systemd.aug

Version-Release number of selected component (if applicable):

[root@seaking ~]# rpm -qa augeas-libs
augeas-libs-1.0.0-5.el6_5.1.x86_64


How reproducible:

see above

--- Additional comment from Lingfei Kong on 2014-07-21 03:43:19 BST ---

Can reproduce with augeas-1.0.0-7.el6
Steps to reproduce:
1. Add the following line to /etc/services(the new line number is 10775)
SWRPC.ACCESS.BSS:BS_rmq                         48102/tcp               # SWIFTAlliance_SWRPC ACCESS

2. # augtool print /augeas//error
/augeas/files/etc/services/error = "parse_failed"
/augeas/files/etc/services/error/pos = "641020"
/augeas/files/etc/services/error/line = "10775"
/augeas/files/etc/services/error/char = "0"
/augeas/files/etc/services/error/lens = "/usr/share/augeas/lenses/dist/services.aug:81.10-.39:"
/augeas/files/etc/services/error/message = "Iterated lens matched less than it should"

--- Additional comment from Dominic Cleal on 2014-07-21 08:19:49 BST ---

Fixed in a32a5a395bc63094ba59857fd5dc329c28ddee32

Comment 2 Lingfei Kong 2014-09-05 03:31:11 UTC
Can reproduce with augeas-1.1.0-12.el7:
Steps to reproduce:
1. Add the following line to  /etc/services
 SWRPC.ACCESS.BSS:BS_rmq                         48102/tcp               # SWIFTAlliance_SWRPC ACCESS
(the new line is11177 )

2. # augtool print /augeas//error
/augeas/files/etc/services/error = "parse_failed"
/augeas/files/etc/services/error/pos = "670293"
/augeas/files/etc/services/error/line = "11177"
/augeas/files/etc/services/error/char = "0"
/augeas/files/etc/services/error/lens = "/usr/share/augeas/lenses/dist/services.aug:87.10-.39:"
/augeas/files/etc/services/error/message = "Iterated lens matched less than it should"


Verify with augeas-1.1.0-13.el7
Steps to verify:
1. Add the following line to  /etc/services
 SWRPC.ACCESS.BSS:BS_rmq                         48102/tcp               # SWIFTAlliance_SWRPC ACCESS

2. # augtool print /augeas//error
no errors like: /augeas/files/etc/services/error = "parse_failed"

Comment 4 errata-xmlrpc 2015-03-05 09:25:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0399.html


Note You need to log in before you can comment on or make changes to this bug.