Bug 1121269 - product page continues to spin when using a SSL web proxy between sat6 and CDN
Summary: product page continues to spin when using a SSL web proxy between sat6 and CDN
Keywords:
Status: CLOSED DUPLICATE of bug 1123483
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: Unspecified
Assignee: Katello Bug Bin
QA Contact: Katello QA List
URL:
Whiteboard:
: 1121887 (view as bug list)
Depends On:
Blocks: GSS_Sat6Beta_Tracker, GSS_Sat6_Tracker
TreeView+ depends on / blocked
 
Reported: 2014-07-18 20:08 UTC by Shannon Hughes
Modified: 2018-12-09 18:12 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-06 12:33:37 UTC


Attachments (Terms of Use)

Description Shannon Hughes 2014-07-18 20:08:04 UTC
Description of problem:

During installation process using the following directions:

https://access.redhat.com/documentation/en-US/Red_Hat_Satellite/6.0/pdf/Installation_Guide/Red_Hat_Satellite-6.0-Installation_Guide-en-US.pdf

At 4 .1.1.3. Enabling Red Hat Repositories, the product names appear but the checkboxes stay as spinning icons. 

I believe this might have something to do with the web proxy that is being used between satellite6 and the CDN. We can see in the foreman log there are issues: 

SSL_connect returned=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (OpenSSL::SSL::SSLError)
/opt/rh/ruby193/root/usr/share/ruby/net/http.rb:800:in `connect'
/opt/rh/ruby193/root/usr/share/ruby/net/http.rb:800:in `block in connect'
/opt/rh/ruby193/root/usr/share/ruby/timeout.rb:55:in `timeout'
/opt/rh/ruby193/root/usr/share/ruby/timeout.rb:100:in `timeout'
/opt/rh/ruby193/root/usr/share/ruby/net/http.rb:800:in `connect'
/opt/rh/ruby193/root/usr/share/ruby/net/http.rb:756:in `do_start'
/opt/rh/ruby193/root/usr/share/ruby/net/http.rb:745:in `start'
/opt/rh/ruby193/root/usr/share/gems/gems/katello-1.5.0/app/lib/katello/resources/cdn.rb:80:in `get'
/opt/rh/ruby193/root/usr/share/gems/gems/katello-1.5.0/app/lib/katello/util/cdn_var_substitutor.rb:154:in `get_substitutions_from'
/opt/rh/ruby193/root/usr/share/gems/gems/katello-1.5.0/app/lib/katello/util/cdn_var_substitutor.rb:143:in `for_each_substitute_of_next_var'
/opt/rh/ruby193/root/usr/share/gems/gems/katello-1.5.0/app/lib/katello/util/cdn_var_substitutor.rb:85:in `substitute_vars_in_prefix'
/opt/rh/ruby193/root/usr/share/gems/gems/katello-1.5.0/app/lib/katello/util/cdn_var_substitutor.rb:61:in `substitute_vars'
/opt/rh/ruby193/root/usr/share/gems/gems/katello-1.5.0/app/lib/actions/katello/repository_set/scan_cdn.rb:39:in `run'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.1/lib/dynflow/action.rb:439:in `block (3 levels) in execute_run'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.1/lib/dynflow/middleware/stack.rb:26:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.1/lib/dynflow/middleware/stack.rb:26:in `pass'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.1/lib/dynflow/middleware.rb:16:in `pass'
/opt/rh/ruby193/root/usr/share/gems/gems/katello-1.5.0/app/lib/actions/middleware/remote_action.rb:25:in `block in run'
/opt/rh/ruby193/root/usr/share/gems/gems/katello-1.5.0/app/lib/actions/middleware/remote_action.rb:51:in `block (2 levels) in as_remote_user'
/opt/rh/ruby193/root/usr/share/gems/gems/katello-1.5.0/app/lib/katello/util/thread_session.rb:85:in `set_pulp_config'
/opt/rh/ruby193/root/usr/share/gems/gems/katello-1.5.0/app/lib/actions/middleware/remote_action.rb:41:in `as_pulp_user'
/opt/rh/ruby193/root/usr/share/gems/gems/katello-1.5.0/app/lib/actions/middleware/remote_action.rb:50:in `block in as_remote_user'
/opt/rh/ruby193/root/usr/share/gems/gems/katello-1.5.0/app/lib/katello/util/thread_session.rb:92:in `set_cp_config'
/opt/rh/ruby193/root/usr/share/gems/gems/katello-1.5.0/app/lib/actions/middleware/remote_action.rb:36:in `as_cp_user'
/opt/rh/ruby193/root/usr/share/gems/gems/katello-1.5.0/app/lib/actions/middleware/remote_action.rb:49:in `as_remote_user'
/opt/rh/ruby193/root/usr/share/gems/gems/katello-1.5.0/app/lib/actions/middleware/remote_action.rb:25:in `run'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.1/lib/dynflow/middleware/stack.rb:22:in `call'

the web proxy is setup as a ssl only web proxy with authentication. currently trying to setup environment to reproduce. 

complete production.log is available

Comment 1 RHEL Product and Program Management 2014-07-18 20:14:01 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 4 Brad Buckingham 2014-08-11 19:05:08 UTC
*** Bug 1121887 has been marked as a duplicate of this bug. ***

Comment 8 Brad Buckingham 2014-11-06 12:33:37 UTC
The solution for this bug should be included as part of bug 1123483; therefore, going to close it as a duplicate.  The solution for that bug updates the behavior so that when a user is on the Red Hat Repositories page, if an error occurs interacting with the CDN, they will see the error instead of having a spinner that spins forever.

*** This bug has been marked as a duplicate of bug 1123483 ***


Note You need to log in before you can comment on or make changes to this bug.