Bug 1123483 - ISE when selecting Repositories to enable (likely CDN issue); need better messaging / error reporting
Summary: ISE when selecting Repositories to enable (likely CDN issue); need better mes...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: Unspecified
Assignee: Justin Sherrill
QA Contact: jcallaha
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1121269 1149670 (view as bug list)
Depends On:
Blocks: GSS_Sat6Beta_Tracker, GSS_Sat6_Tracker
TreeView+ depends on / blocked
 
Reported: 2014-07-25 19:31 UTC by Shannon Hughes
Modified: 2016-04-22 16:05 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, the Satellite Server did not inform the user of any errors that occured when enabling repositories. Better error reporting messages have been added into the web UI. If an issue crops up when enabling repositories, the UI should now inform the user about these errors.
Clone Of:
Environment:
Last Closed: 2014-11-13 22:28:52 UTC


Attachments (Terms of Use)
debug log (23.33 KB, text/plain)
2014-07-25 19:31 UTC, Shannon Hughes
no flags Details
repo expansion (19.20 KB, image/jpeg)
2014-07-25 19:32 UTC, Shannon Hughes
no flags Details
manifest (58.39 KB, application/zip)
2014-07-29 17:31 UTC, Shannon Hughes
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1857 normal SHIPPED_LIVE Red Hat Satellite 6 server bug fix update 2014-11-14 03:28:23 UTC
Foreman Issue Tracker 7979 None None None 2016-04-22 16:04:59 UTC
Red Hat Bugzilla 1124923 None CLOSED Sync Mgmt and Content->Product sync hides CDN errors; needs better messaging/error reporting 2019-05-08 20:16:24 UTC

Internal Links: 1124923

Description Shannon Hughes 2014-07-25 19:31:38 UTC
Created attachment 921042 [details]
debug log

Description of problem:

Uploaded manifest which was successful. Then went to enable rhel 6 repo and kickstart repo. The spinner next to Red Hat Enterprise Linux 6 Server (Kickstart)  spins for a while and then expands with no options underneath. (see attached screenshot). 

Looked in production.log and noticed the ISE. The CDN today seems to be slow so that might be part of the issue but we should handle errors gracefully and have some type of indication of failure to user. 

attaching production.log for debugging.

Comment 1 Shannon Hughes 2014-07-25 19:32:15 UTC
Created attachment 921043 [details]
repo expansion

Comment 2 RHEL Product and Program Management 2014-07-25 19:33:35 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 4 Shannon Hughes 2014-07-29 17:31:39 UTC
Created attachment 922242 [details]
manifest

Comment 14 Justin Sherrill 2014-10-17 00:15:36 UTC
Created redmine issue http://projects.theforeman.org/issues/7979 from this bug

Comment 15 Bryan Kearney 2014-10-20 04:03:01 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/7979 has been closed
-------------
Justin Sherrill
Applied in changeset commit:katello|b0a8b01cd1863997f786ccfb9c7b73c592abfded.

Comment 19 jcallaha 2014-10-31 13:39:19 UTC
** Verified against Z-Stream **

Error message received when verifying:

There was an error attempting to enable or disable this repository:
getaddrinfo: Name or service not known


Satellite-6.0.4-RHEL-7-20141029.5

foreman-1.6.0.47-1.el7sat.noarch
foreman-compute-1.6.0.47-1.el7sat.noarch
ruby193-rubygem-foreman_hooks-0.3.5-2.el7sat.noarch
foreman-gce-1.6.0.47-1.el7sat.noarch
ruby193-rubygem-foreman_discovery-1.3.0-2.el7sat.noarch
foreman-libvirt-1.6.0.47-1.el7sat.noarch
foreman-proxy-1.6.0.30-1.el7sat.noarch
ruby193-rubygem-foreman-redhat_access-0.0.4-2.el7sat.noarch
foreman-vmware-1.6.0.47-1.el7sat.noarch
rubygem-hammer_cli_foreman_tasks-0.0.3-3.el7sat.noarch
foreman-selinux-1.6.0.15-1.el7sat.noarch
ruby193-rubygem-foreman-tasks-0.6.9-1.1.el7sat.noarch
foreman-ovirt-1.6.0.47-1.el7sat.noarch
foreman-postgresql-1.6.0.47-1.el7sat.noarch
qe-sat6-rhel7.usersys.redhat.com-foreman-proxy-1.0-1.noarch
qe-sat6-rhel7.usersys.redhat.com-foreman-client-1.0-1.noarch
rubygem-hammer_cli_foreman-0.1.1-16.el7sat.noarch
ruby193-rubygem-foreman_bootdisk-2.0.6-1.1.el7sat.noarch

Comment 20 Brad Buckingham 2014-11-06 12:33:37 UTC
*** Bug 1121269 has been marked as a duplicate of this bug. ***

Comment 22 errata-xmlrpc 2014-11-13 22:28:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2014:1857

Comment 23 Brad Buckingham 2015-09-09 18:32:14 UTC
*** Bug 1149670 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.