Bug 1121383 - ValueError: specified lv is not part of this vg
Summary: ValueError: specified lv is not part of this vg
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-blivet
Version: 21
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Lehman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:bf2368d8f5bcd4949e53a139952...
: 1098458 1128605 1141788 1142780 1146186 (view as bug list)
Depends On:
Blocks: F21BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2014-07-20 09:30 UTC by Oded Arbel
Modified: 2014-10-25 14:29 UTC (History)
24 users (show)

Fixed In Version: python-blivet-0.61.3-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-15 21:15:04 UTC


Attachments (Terms of Use)
File: anaconda-tb (732.56 KB, text/plain)
2014-07-20 09:30 UTC, Oded Arbel
no flags Details
File: anaconda.log (23.76 KB, text/plain)
2014-07-20 09:30 UTC, Oded Arbel
no flags Details
File: environ (459 bytes, text/plain)
2014-07-20 09:30 UTC, Oded Arbel
no flags Details
File: lsblk_output (1.90 KB, text/plain)
2014-07-20 09:30 UTC, Oded Arbel
no flags Details
File: nmcli_dev_list (1.49 KB, text/plain)
2014-07-20 09:30 UTC, Oded Arbel
no flags Details
File: os_info (377 bytes, text/plain)
2014-07-20 09:30 UTC, Oded Arbel
no flags Details
File: program.log (35.92 KB, text/plain)
2014-07-20 09:30 UTC, Oded Arbel
no flags Details
File: storage.log (202.87 KB, text/plain)
2014-07-20 09:30 UTC, Oded Arbel
no flags Details
File: syslog (105.33 KB, text/plain)
2014-07-20 09:30 UTC, Oded Arbel
no flags Details
File: ifcfg.log (1.93 KB, text/plain)
2014-07-20 09:30 UTC, Oded Arbel
no flags Details
File: packaging.log (270.73 KB, text/plain)
2014-07-20 09:30 UTC, Oded Arbel
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1143864 None None None Never

Internal Links: 1143864

Description Oded Arbel 2014-07-20 09:30:35 UTC
Description of problem:
1. Boot Fedora installer
2. Select default paritioning scheme
  - Installer will create an LVM setup
3. After installation, reboot back to installer
4. Open disk configuration, make sure automatic partitioning is enabled, check "I would like to make additional space available".
5. In the "reclaim space" dialog delete all partitions (including LVM partitions) and approve.
6. reopen disk configuration, and select "I will configure partitions". 
7. click "Done"
8. Crash

Version-Release number of selected component:
anaconda-21.48-1

The following was filed automatically by anaconda:
anaconda 21.48-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 2585, in _removeLogVol
    raise ValueError("specified lv is not part of this vg")
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 450, in _removeDevice
    dev.vg._removeLogVol(dev)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 521, in cancelAction
    self._removeDevice(action.device)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 1967, in hide
    self.cancelAction(action)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 352, in _hide_unusable_disks
    self._storage_playground.devicetree.hide(disk)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 120, in decorated
    return func(*args, **kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 360, in _reset_storage
    self._hide_unusable_disks()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 375, in refresh
    self._reset_storage()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 355, in _on_spoke_clicked
    spoke.refresh()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 387, in spoke_done
    self._on_spoke_clicked(self._spokes[dest].selector, None, self._spokes[dest])
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/__init__.py", line 51, in on_back_clicked
    self.main_window.current_action.spoke_done(self)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 870, in on_back_clicked
    NormalSpoke.on_back_clicked(self, button)
ValueError: specified lv is not part of this vg

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-21-x86_64 quiet
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.16.0-0.rc5.git1.1.fc21.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        21

Comment 1 Oded Arbel 2014-07-20 09:30:41 UTC
Created attachment 919334 [details]
File: anaconda-tb

Comment 2 Oded Arbel 2014-07-20 09:30:43 UTC
Created attachment 919335 [details]
File: anaconda.log

Comment 3 Oded Arbel 2014-07-20 09:30:44 UTC
Created attachment 919336 [details]
File: environ

Comment 4 Oded Arbel 2014-07-20 09:30:46 UTC
Created attachment 919337 [details]
File: lsblk_output

Comment 5 Oded Arbel 2014-07-20 09:30:47 UTC
Created attachment 919338 [details]
File: nmcli_dev_list

Comment 6 Oded Arbel 2014-07-20 09:30:48 UTC
Created attachment 919339 [details]
File: os_info

Comment 7 Oded Arbel 2014-07-20 09:30:50 UTC
Created attachment 919340 [details]
File: program.log

Comment 8 Oded Arbel 2014-07-20 09:30:53 UTC
Created attachment 919341 [details]
File: storage.log

Comment 9 Oded Arbel 2014-07-20 09:30:55 UTC
Created attachment 919342 [details]
File: syslog

Comment 10 Oded Arbel 2014-07-20 09:30:56 UTC
Created attachment 919343 [details]
File: ifcfg.log

Comment 11 Oded Arbel 2014-07-20 09:30:59 UTC
Created attachment 919344 [details]
File: packaging.log

Comment 12 Oded Arbel 2014-07-20 09:36:50 UTC
The "reclaim space" process appears to be at fault here, if I skip step 5 above, everything works fine.

Comment 13 Brian Lane 2014-07-21 22:35:41 UTC
Does this happen every time for you? I can't seem to reproduce it here.

Comment 14 Oded Arbel 2014-07-27 12:57:37 UTC
When I repeat the same steps using the latest F21 network install ISO (update time 26-07-2014), it still crashes but now I get a different error: 

AttributeError: 'module' object has no attribute 'EARLY_SWAP_RAM'.

Do you prefer to close this issue and for me to reopen a new one (with the updated stack trace)?

Comment 15 Brian Lane 2014-07-28 21:34:20 UTC
That error is unrelated, vpodzime is already working on it.

Comment 16 Oded Arbel 2014-07-30 08:45:55 UTC
ok, thanks. closing for now.

Comment 17 Stephen Gallagher 2014-08-29 14:28:27 UTC
I'm seeing this whenever I try to do a manual partition setup on the Fedora 21 Server Alpha TC4 DVD ISO.

Comment 18 Leslie Satenstein 2014-09-13 20:29:16 UTC
Another user experienced a similar problem:

Selected Automatic partitioning, then said to myself  whoops, I want standard. 
I reentered the Device Selection, clicked on I will configure partitioning, and 
error presented itself.

That is what I did. 



Please note
is " will configure partitioning"  different  from 
I will establish filesystem protocol (lvm, standard btrfs, etc )?

I understand Configuring partition as meaning I set each partition size 

 

addons:         com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-WS-21_A_T7-x86_64 quiet
hashmarkername: anaconda
kernel:         3.16.1-301.fc21.x86_64
package:        anaconda-21.48.6-1
product:        Fedora-Workstation
reason:         ValueError: specified lv is not part of this vg
release:        Cannot get release name.
version:        21_Alpha_TC7

Comment 19 David Lehman 2014-09-15 15:48:31 UTC
*** Bug 1141788 has been marked as a duplicate of this bug. ***

Comment 20 David Shea 2014-09-17 13:42:33 UTC
*** Bug 1142780 has been marked as a duplicate of this bug. ***

Comment 21 Lukas Brabec 2014-09-18 08:21:04 UTC
Another user experienced a similar problem:

Tried to reproduce bug 1143849, steps:

1. custom partitioning selected
2. "encrypt my data" checked
3. clicked done

addons:         com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   inst.repo=nfs:nfs.englab.brq.redhat.com:/pub/fedora/fedora-alt/stage/21_Alpha_RC1/Server/x86_64/iso/Fedora-Server-DVD-x86_64-21_Alpha.iso initrd=F21/Alpha_RC1/x86_64/initrd.img BOOT_IMAGE=F21/Alpha_RC1/x86_64/vmlinuz 
hashmarkername: anaconda
kernel:         3.16.1-301.fc21.x86_64
package:        anaconda-21.48.6-1
product:        Fedora-Server
reason:         ValueError: specified lv is not part of this vg
release:        Cannot get release name.
version:        21_Alpha

Comment 22 David Lehman 2014-09-18 20:32:11 UTC
*** Bug 1098458 has been marked as a duplicate of this bug. ***

Comment 23 David Lehman 2014-09-22 14:23:44 UTC
Proposing as a beta blocker. This is already fixed on master.

Comment 24 herr.ernst 2014-09-23 19:10:10 UTC
Another user experienced a similar problem:

some clicking around in partitioning

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Workstation-x86_64-2 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         3.16.1-301.fc21.x86_64
other involved packages: python-blivet-0.62-1.fc21.noarch, anaconda-gui-21.48.6-1.fc21.x86_64
package:        anaconda-core-21.48.6-1.fc21.x86_64
packaging.log:  
product:        Fedora
reason:         ValueError: specified lv is not part of this vg
release:        Fedora release 21 (Twenty One)
version:        21

Comment 25 David Lehman 2014-09-24 16:55:14 UTC
*** Bug 1128605 has been marked as a duplicate of this bug. ***

Comment 26 Kamil Páral 2014-09-24 17:02:47 UTC
Discussed in 2014-09-24 Blocker Review meeting [1]. Accepted as a blocker. This bug is really easy to hit and violates Beta custom partitioning criteria.

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2014-09-24/

Comment 27 Adam Williamson 2014-09-24 17:46:55 UTC
*** Bug 1146186 has been marked as a duplicate of this bug. ***

Comment 28 Nix\ 2014-09-26 06:14:44 UTC
Another user experienced a similar problem:

Trying to make a manual partitioning Fedora 21 i386 netinstall

addons:         com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-S-21_A-i386 
hashmarkername: anaconda
kernel:         3.16.1-301.fc21.i686
package:        anaconda-21.48.6-1
product:        Fedora-Server
reason:         ValueError: specified lv is not part of this vg
release:        Cannot get release name.
version:        21_Alpha

Comment 29 Adam Williamson 2014-10-08 17:20:51 UTC
Discussed at 2014-10-08 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2014-10-08/f21-blocker-review.2014-10-08-15.58.log.txt . David, we can't spot the fix for this in the anaconda commit log, so we'll have to ask - is it on f21-branch yet? Should it be fixed in one of the recent anaconda updates? Thanks!

Comment 30 Mairi Dulaney 2014-10-09 02:28:35 UTC
Another user experienced a similar problem:

Changing from auto to manual partitioning, clicked done.

addons:         com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-WS-21_A-x86_64 quiet
hashmarkername: anaconda
kernel:         3.16.1-301.fc21.x86_64
package:        anaconda-21.48.6-1
product:        Fedora-Workstation
reason:         ValueError: specified lv is not part of this vg
release:        Cannot get release name.
version:        21_Alpha

Comment 31 Adam Williamson 2014-10-15 21:15:04 UTC
blivet 0.61.3 was pushed stable and we haven't had a report of this bug with TC2 or TC3, so let's call it fixed. If another dupe comes in, we can reopen it.

Comment 32 Jan Vlug 2014-10-23 15:16:49 UTC
I was directed to this bug today after downloading a fresh Fedora 21 Alpha and trying to install it in a new Box on Boxes.

Comment 33 Adam Williamson 2014-10-25 14:29:14 UTC
Jan: try with Beta RC1 instead - it should be better than Alpha for all practical purposes: https://dl.fedoraproject.org/pub/alt/stage/21_Beta_RC1/

and it definitely should fix this bug.


Note You need to log in before you can comment on or make changes to this bug.