Bug 1128605 - anconda crash when trying to custom partitioning after do an automatically partitioning
Summary: anconda crash when trying to custom partitioning after do an automatically p...
Keywords:
Status: CLOSED DUPLICATE of bug 1121383
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1132322 (view as bug list)
Depends On:
Blocks: F21BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2014-08-11 08:02 UTC by lnie
Modified: 2014-09-24 16:55 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-24 16:55:14 UTC


Attachments (Terms of Use)
anaconda.log (23.39 KB, text/x-log)
2014-08-11 08:06 UTC, lnie
no flags Details
anaconda-tb-MtJzuJ (272.40 KB, text/plain)
2014-08-11 08:07 UTC, lnie
no flags Details
packaging.log (69.43 KB, text/x-log)
2014-08-11 08:07 UTC, lnie
no flags Details
program.log (14.67 KB, text/x-log)
2014-08-11 08:08 UTC, lnie
no flags Details
syslog (61.04 KB, text/plain)
2014-08-11 08:08 UTC, lnie
no flags Details

Description lnie 2014-08-11 08:02:39 UTC
Description of problem:
 

Version-Release number of selected component (if applicable):
f21(20140810)

How reproducible:

always
Steps to Reproduce:
1. choose"automatically partitioning" at Installation Destination page
2. click "Done"
3. try to do custom partitioning by click "I will configure partitioning"
4. the crash happens after Click"Done"

Actual results:


Expected results:


Additional info:

Comment 1 lnie 2014-08-11 08:06:21 UTC
Created attachment 925638 [details]
anaconda.log

Comment 2 lnie 2014-08-11 08:07:16 UTC
Created attachment 925639 [details]
anaconda-tb-MtJzuJ

Comment 3 lnie 2014-08-11 08:07:50 UTC
Created attachment 925640 [details]
packaging.log

Comment 4 lnie 2014-08-11 08:08:17 UTC
Created attachment 925641 [details]
program.log

Comment 5 lnie 2014-08-11 08:08:40 UTC
Created attachment 925642 [details]
syslog

Comment 6 Petr Schindler 2014-08-12 09:15:05 UTC
I reproduced this bug with boot.iso from 2014-08-11.

I propose this as a beta blocker as it violates criterion: "

When using the custom partitioning flow, the installer must be able to:

    Correctly interpret, and modify as described below, any disk with a valid ms-dos or gpt disk label and partition table containing ext4 partitions, LVM and/or btrfs volumes, and/or software RAID arrays at RAID levels 0, 1 and 5 containing ext4 partitions"

anaconda 21.48.2-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 2585, in _removeLogVol
    raise ValueError("specified lv is not part of this vg")
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 450, in _removeDevice
    dev.vg._removeLogVol(dev)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 521, in cancelAction
    self._removeDevice(action.device)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 1967, in hide
    self.cancelAction(action)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 353, in _hide_unusable_disks
    self._storage_playground.devicetree.hide(disk)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 121, in decorated
    return func(*args, **kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 361, in _reset_storage
    self._hide_unusable_disks()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 376, in refresh
    self._reset_storage()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 355, in _on_spoke_clicked
    spoke.refresh()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 387, in spoke_done
    self._on_spoke_clicked(self._spokes[dest].selector, None, self._spokes[dest])
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/__init__.py", line 51, in on_back_clicked
    self.main_window.current_action.spoke_done(self)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 871, in on_back_clicked
    NormalSpoke.on_back_clicked(self, button)
ValueError: specified lv is not part of this vg

Comment 7 David Shea 2014-09-04 17:54:51 UTC
*** Bug 1132322 has been marked as a duplicate of this bug. ***

Comment 8 David Lehman 2014-09-24 16:55:14 UTC

*** This bug has been marked as a duplicate of bug 1121383 ***


Note You need to log in before you can comment on or make changes to this bug.