Bug 1121398 - FormatCreateError: ('device does not exist', '/dev/sda1')
Summary: FormatCreateError: ('device does not exist', '/dev/sda1')
Keywords:
Status: CLOSED DUPLICATE of bug 1120406
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:c67baa6f44671736fa85b5507c8...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-20 12:25 UTC by abyss.7
Modified: 2014-07-21 21:40 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-21 21:40:51 UTC


Attachments (Terms of Use)
File: anaconda-tb (319.70 KB, text/plain)
2014-07-20 12:25 UTC, abyss.7
no flags Details
File: anaconda.log (19.59 KB, text/plain)
2014-07-20 12:25 UTC, abyss.7
no flags Details
File: environ (459 bytes, text/plain)
2014-07-20 12:25 UTC, abyss.7
no flags Details
File: lsblk_output (1.28 KB, text/plain)
2014-07-20 12:25 UTC, abyss.7
no flags Details
File: nmcli_dev_list (1.08 KB, text/plain)
2014-07-20 12:25 UTC, abyss.7
no flags Details
File: os_info (381 bytes, text/plain)
2014-07-20 12:25 UTC, abyss.7
no flags Details
File: program.log (18.17 KB, text/plain)
2014-07-20 12:25 UTC, abyss.7
no flags Details
File: storage.log (87.88 KB, text/plain)
2014-07-20 12:25 UTC, abyss.7
no flags Details
File: syslog (68.77 KB, text/plain)
2014-07-20 12:25 UTC, abyss.7
no flags Details
File: ifcfg.log (1.91 KB, text/plain)
2014-07-20 12:25 UTC, abyss.7
no flags Details
File: packaging.log (70.72 KB, text/plain)
2014-07-20 12:25 UTC, abyss.7
no flags Details

Description abyss.7 2014-07-20 12:25:21 UTC
Description of problem:
Trying to install Fedora Rawhide inside Gnome Boxes

Version-Release number of selected component:
anaconda-21.48-1

The following was filed automatically by anaconda:
anaconda 21.48-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/formats/fs.py", line 388, in doFormat
    raise FormatCreateError("device does not exist", self.device)
  File "/usr/lib/python2.7/site-packages/blivet/formats/fs.py", line 820, in create
    return self.doFormat(options=kwargs.get('options'))
  File "/usr/lib/python2.7/site-packages/blivet/deviceaction.py", line 554, in execute
    options=self.device.formatArgs)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 354, in processActions
    action.execute()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 356, in doIt
    self.devicetree.processActions()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 216, in turnOnFilesystems
    storage.doIt()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 178, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall)
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 227, in run
    threading.Thread.run(self, *args, **kwargs)
FormatCreateError: ('device does not exist', '/dev/sda1')

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-rawhide-x86_64 quiet
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.16.0-0.rc5.git1.1.fc22.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        rawhide

Comment 1 abyss.7 2014-07-20 12:25:25 UTC
Created attachment 919376 [details]
File: anaconda-tb

Comment 2 abyss.7 2014-07-20 12:25:26 UTC
Created attachment 919377 [details]
File: anaconda.log

Comment 3 abyss.7 2014-07-20 12:25:28 UTC
Created attachment 919378 [details]
File: environ

Comment 4 abyss.7 2014-07-20 12:25:29 UTC
Created attachment 919379 [details]
File: lsblk_output

Comment 5 abyss.7 2014-07-20 12:25:30 UTC
Created attachment 919380 [details]
File: nmcli_dev_list

Comment 6 abyss.7 2014-07-20 12:25:32 UTC
Created attachment 919381 [details]
File: os_info

Comment 7 abyss.7 2014-07-20 12:25:33 UTC
Created attachment 919382 [details]
File: program.log

Comment 8 abyss.7 2014-07-20 12:25:35 UTC
Created attachment 919383 [details]
File: storage.log

Comment 9 abyss.7 2014-07-20 12:25:37 UTC
Created attachment 919384 [details]
File: syslog

Comment 10 abyss.7 2014-07-20 12:25:39 UTC
Created attachment 919385 [details]
File: ifcfg.log

Comment 11 abyss.7 2014-07-20 12:25:41 UTC
Created attachment 919386 [details]
File: packaging.log

Comment 12 Brian Lane 2014-07-21 21:40:51 UTC

*** This bug has been marked as a duplicate of bug 1120406 ***


Note You need to log in before you can comment on or make changes to this bug.