Bug 1121400 - VdcBLLException after Live Storage Migration
Summary: VdcBLLException after Live Storage Migration
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.5.0
Assignee: Daniel Erez
QA Contact: Raz Tamir
URL:
Whiteboard: infra
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-20 12:49 UTC by Raz Tamir
Modified: 2016-02-10 19:30 UTC (History)
9 users (show)

Fixed In Version: ovirt-3.5.0-beta1.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-17 12:20:14 UTC
oVirt Team: Infra


Attachments (Terms of Use)
engine log (11.49 MB, text/plain)
2014-07-20 12:49 UTC, Raz Tamir
no flags Details
new engine log (1.52 MB, application/x-gzip)
2014-08-17 12:45 UTC, Raz Tamir
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 29507 None None None Never

Description Raz Tamir 2014-07-20 12:49:44 UTC
Created attachment 919389 [details]
engine log

Description of problem:
During LSM a VdcBLLException raised error message VdcBLLException: Auto-generated live snapshot for VM c7894ab6-c4f0-425f-9f6b-27fa310a4467 failed (Failed with error imageErr and code 13)


Version-Release number of selected component (if applicable):
ovirt-engine-3.5.0-0.0.master.20140715172116.git4687dc1.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. Live migrate vm's disks
2.
3.

Actual results:
In engine logs, VdcBLLException raised

Expected results:
No exception should raise

Additional info:

Comment 1 Daniel Erez 2014-07-21 08:09:42 UTC
Caused by exception [1], already fixed on Change-Id: I55ac1cc3b234a56a5d269ab4ebaeac528a3190de. Moving to MODIFIED.

[1] 
2014-07-16 08:51:23,773 ERROR [org.ovirt.engine.core.bll.CommandsFactory] (ajp--127.0.0.1-8702-9) [78eac9c0] Cant find constructor for type org.ovirt.engine.core.bll.lsm.LiveMigrateVmDisksCommand with parameter types: [class org.ovirt.engine.core.common.action.LiveMigrateVmDisksParameters]
2014-07-16 08:51:23,774 ERROR [org.ovirt.engine.core.bll.CommandsFactory] (ajp--127.0.0.1-8702-9) [78eac9c0] An exception has occured while trying to create a command object for command LiveMigrateVmDisks: java.lang.RuntimeException: could not find matching constructor for Command class class org.ovirt.engine.core.bll.lsm.LiveMigrateVmDisksCommand

Comment 2 Allon Mureinik 2014-07-21 08:14:48 UTC
(In reply to Daniel Erez from comment #1)
> Caused by exception [1], already fixed on Change-Id:
> I55ac1cc3b234a56a5d269ab4ebaeac528a3190de. Moving to MODIFIED.
This is another aspect of the command context issue.
Moving to infra for better tracking, and to ON_QA as this patch is available in beta1.

Comment 3 Jiri Belka 2014-08-07 13:15:41 UTC
ok, ovirt-engine-backend-3.5.0-0.0.master.20140804172041.git23b558e.el6.noarch

no exception while live-migrating vm's disk

Comment 4 Raz Tamir 2014-08-17 12:45:46 UTC
Created attachment 927467 [details]
new engine log

Still happens

Comment 5 Raz Tamir 2014-08-17 12:46:12 UTC
logs attached

Comment 6 Daniel Erez 2014-08-17 12:54:57 UTC
(In reply to ratamir from comment #5)
> logs attached

Seems to be a different issue.
According to the log [1], looks like a duplicate of bug 1124321.
@Vered - is it exactly the same issue?

[1]
2014-08-17 14:07:19,859 ERROR [org.ovirt.engine.core.bll.lsm.LiveMigrateVmDisksCommand] (ajp--127.0.0.1-8702-11) [disks_syncAction_6142ff29-58cc-4054] Error during CanDoActionFailure.: java.lang.NullPointerException
	at org.ovirt.engine.core.bll.validator.StorageDomainValidator.hasSpaceForNewDisks(StorageDomainValidator.java:183) [bll.jar:]
	at org.ovirt.engine.core.bll.lsm.LiveMigrateVmDisksCommand.validateSourceDomainsSpaceRequirements(LiveMigrateVmDisksCommand.java:445) [bll.jar:]

Comment 7 Vered Volansky 2014-08-18 13:36:42 UTC
Looks like the same issue from bz114321. Raz, was this using REST API?
If so, we should move to close/modified.

Comment 8 Vered Volansky 2014-08-18 13:37:37 UTC
That's bz1124321

Comment 9 Raz Tamir 2014-08-18 14:38:40 UTC
Hi Vered,
No, it was via the web admin

Comment 10 Daniel Erez 2014-08-18 15:54:58 UTC
(In reply to ratamir from comment #9)
> Hi Vered,
> No, it was via the web admin

Hi Raz,

So what is the reproducing scenario here? (when do you get this exception mentioned in comment #6 when using the webadmin?)

Comment 11 Raz Tamir 2014-08-18 21:15:24 UTC
Hi Daniel,
To reproduce this, just live migrate a vm's disk and ~2 minutes after the migration finish the mentioned exception raised

Comment 12 Raz Tamir 2014-08-25 09:07:28 UTC
Verified on - ovirt-engine-3.5.0-0.0.master.20140821064931.gitb794d66.el6.noarch

Comment 13 Sandro Bonazzola 2014-10-17 12:20:14 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.