Bug 1121518 - xml output needed for geo-rep CLI commands
Summary: xml output needed for geo-rep CLI commands
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: cli
Version: mainline
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: Darshan
QA Contact:
URL:
Whiteboard:
: 1121517 (view as bug list)
Depends On: 1090910
Blocks: 1133464
TreeView+ depends on / blocked
 
Reported: 2014-07-21 06:46 UTC by Darshan
Modified: 2015-05-14 17:42 UTC (History)
9 users (show)

Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Clone Of: 1090910
: 1133464 (view as bug list)
Environment:
Last Closed: 2015-05-14 17:26:23 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Darshan 2014-07-21 06:46:22 UTC
+++ This bug was initially created as a clone of Bug #1090910 +++

Description of problem:

Currently we are parsing the CLI output for gluster volume geo-replication status - to know if geo-replication sessions are faulty or not.

Need an XML output for the same so that we can parse this output reliably.

--- Additional comment from RHEL Product and Program Management on 2014-04-24 07:54:45 EDT ---

Since this issue was entered in bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 1 Darshan 2014-07-21 06:48:14 UTC
*** Bug 1121517 has been marked as a duplicate of this bug. ***

Comment 2 Anand Avati 2014-07-21 08:34:54 UTC
REVIEW: http://review.gluster.org/8270 (cli: Xml output for geo-replication config command.) posted (#3) for review on master by darshan n (dnarayan@redhat.com)

Comment 3 Anand Avati 2014-07-21 08:42:09 UTC
REVIEW: http://review.gluster.org/8270 (cli: Xml output for geo-replication config command.) posted (#4) for review on master by darshan n (dnarayan@redhat.com)

Comment 4 Anand Avati 2014-07-21 08:54:22 UTC
REVIEW: http://review.gluster.org/8270 (cli: Xml output for geo-replication config command) posted (#5) for review on master by darshan n (dnarayan@redhat.com)

Comment 5 Anand Avati 2014-07-21 11:54:36 UTC
REVIEW: http://review.gluster.org/8089 (cli: Xml output for geo-replication status command.) posted (#8) for review on master by darshan n (dnarayan@redhat.com)

Comment 6 Anand Avati 2014-07-21 12:05:20 UTC
REVIEW: http://review.gluster.org/8089 (cli: Xml output for geo-replication status command.) posted (#9) for review on master by darshan n (dnarayan@redhat.com)

Comment 7 Anand Avati 2014-07-22 07:24:56 UTC
COMMIT: http://review.gluster.org/8270 committed in master by Kaushal M (kaushal@redhat.com) 
------
commit 5e1872c464f34295df136d4120110c3c53c5f599
Author: ndarshan <dnarayan@redhat.com>
Date:   Mon Jul 21 13:55:33 2014 +0530

    cli: Xml output for geo-replication config command
    
    This patch adds xml output for geo-replication config
    command.
    sample:
    ---------------------------------------------------------------------
    <cliOutput>
      <opRet>0</opRet>
      <opErrno>0</opErrno>
      <opErrstr/>
      <geoRep>
        <config>
          <parameter1_name>value</parameter1_name>
          <parameter2_name>value</parameter2_name>
          ...
          ...
          ...
        </config>
      </geoRep>
    </cliOutput>
    ---------------------------------------------------------------------
    
    Change-Id: Iac0451983ae5d0e65b95604eb1c29b968e1ee22f
    BUG: 1121518
    Signed-off-by: ndarshan <dnarayan@redhat.com>
    Reviewed-on: http://review.gluster.org/8270
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaushal M <kaushal@redhat.com>

Comment 8 Anand Avati 2014-07-22 08:53:30 UTC
REVIEW: http://review.gluster.org/8089 (cli: Xml output for geo-replication status command.) posted (#10) for review on master by darshan n (dnarayan@redhat.com)

Comment 9 Anand Avati 2014-07-22 09:01:05 UTC
REVIEW: http://review.gluster.org/8089 (cli: Xml output for geo-replication status command.) posted (#11) for review on master by darshan n (dnarayan@redhat.com)

Comment 10 Anand Avati 2014-07-22 10:46:12 UTC
REVIEW: http://review.gluster.org/8089 (cli: Xml output for geo-replication status command.) posted (#12) for review on master by darshan n (dnarayan@redhat.com)

Comment 11 Anand Avati 2014-07-23 06:18:12 UTC
REVIEW: http://review.gluster.org/8089 (cli: Xml output for geo-replication status command.) posted (#13) for review on master by darshan n (dnarayan@redhat.com)

Comment 12 Anand Avati 2014-07-24 12:05:59 UTC
COMMIT: http://review.gluster.org/8089 committed in master by Kaushal M (kaushal@redhat.com) 
------
commit 54cfb7dab45105e5f9a123503c4f524b99c633ce
Author: ndarshan <dnarayan@redhat.com>
Date:   Tue Jul 22 14:19:19 2014 +0530

    cli: Xml output for geo-replication status command.
    
    This patch adds xml output for geo-replication status
    and status detail command.
    sample:
    --------------------------------------------------------------
      <geoRep>
        <volume>
          <name>master</name>
          <sessions>
            <session>
            <session_slave>:2a301d66-b9d2-44b4-b827-d680d67123eb:ssh://XXXXXXXXXX::slave</session_slave>
              <pair>
                <master_node>localhost.localdomain</master_node>
                <master_node_uuid>2a301d66-b9d2-44b4-b827-d680d67123eb</master_node_uuid>
                <master_brick>/root/master_b1</master_brick>
                <slave>ssh://XXXXXXXXXXX::slave</slave>
                <status>faulty</status>
                <checkpoint_status>N/A</checkpoint_status>
                <crawl_status>N/A</crawl_status>
              </pair>
            </session>
          </sessions>
        </volume>
      </geoRep>
    -------------------------------------------------------------
    
    Change-Id: Ia19dbe751c3ab1ec7cb8923cdd6c8b99c374072f
    BUG: 1121518
    Signed-off-by: ndarshan <dnarayan@redhat.com>
    Reviewed-on: http://review.gluster.org/8089
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaushal M <kaushal@redhat.com>

Comment 13 Niels de Vos 2015-05-14 17:26:23 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 14 Niels de Vos 2015-05-14 17:35:29 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 15 Niels de Vos 2015-05-14 17:37:51 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 16 Niels de Vos 2015-05-14 17:42:42 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.