Bug 1121571 - annoying false error when starting vdsmd
Summary: annoying false error when starting vdsmd
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: vdsm
Classification: oVirt
Component: General
Version: ---
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: ---
: ---
Assignee: Petr Horáček
QA Contact: Lukas Svaty
URL:
Whiteboard:
: 1241464 (view as bug list)
Depends On:
Blocks: 1288163
TreeView+ depends on / blocked
 
Reported: 2014-07-21 09:07 UTC by Dan Kenigsberg
Modified: 2019-04-28 10:09 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1288163 (view as bug list)
Environment:
Last Closed: 2016-12-05 09:09:18 UTC
oVirt Team: Network
danken: ovirt-4.1?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

Description Dan Kenigsberg 2014-07-21 09:07:40 UTC
Description of problem:

vdsm: Running restore_nets
libvir: Network Driver error : Network not found: no network with matching name 'vdsm-ovirtmgmt'

Comment 1 Dan Kenigsberg 2014-09-18 10:14:28 UTC
a snippet from supervdsm.log

vdsm-4.16.4-0.el6.x86_64
libvirt-0.10.2-29.el6_5.7.x86_64


MainThread::DEBUG::2014-09-18 13:06:58,711::api::680::setupNetworks::(setupNetworks) Adding network 'vlan104'
MainThread::DEBUG::2014-09-18 13:06:58,711::api::278::root::(addNetwork) validating network...
MainThread::INFO::2014-09-18 13:06:58,711::api::300::root::(addNetwork) Adding network vlan104 with vlan=104, bonding=None, nics=[u'eth1'], bondingOptions=None, mtu=1500, bridged=False, defaultRoute=False,options={'implicitBonding': True}
MainThread::DEBUG::2014-09-18 13:06:58,712::ifcfg::541::root::(writeConfFile) Writing to file /etc/sysconfig/network-scripts/ifcfg-eth1.104 configuration:
# Generated by VDSM version 4.16.4-0.el6
DEVICE=eth1.104
VLAN=yes
ONBOOT=no
MTU=1500
DEFROUTE=no
NM_CONTROLLED=no
HOTPLUG=no

MainThread::DEBUG::2014-09-18 13:06:58,714::__init__::122::root::(_addSourceRoute) Adding source route eth1.104, None, None, None
MainThread::ERROR::2014-09-18 13:06:58,714::sourceroute::68::root::(configure) ipaddr, mask or gateway not received
MainThread::DEBUG::2014-09-18 13:06:58,714::utils::738::root::(execCmd) /sbin/ifup eth1.104 (cwd None)
MainThread::DEBUG::2014-09-18 13:06:58,798::utils::758::root::(execCmd) SUCCESS: <err> = ''; <rc> = 0
MainThread::DEBUG::2014-09-18 13:06:58,800::libvirtconnection::143::root::(wrapper) Unknown libvirterror: ecode: 43 edom: 19 level: 2 message: Network not found: no network with matching name 'vdsm-vlan104'
MainThread::DEBUG::2014-09-18 13:06:58,800::ifcfg::327::root::(_atomicNetworkBackup) Backed up vlan104
MainThread::INFO::2014-09-18 13:06:58,877::netconfpersistence::68::root::(setNetwork) Adding network vlan104({'nic': u'eth1', u'vlan': u'104', u'bridged': u'false', u'mtu': u'1500'})
MainThread::DEBUG::2014-09-18 13:06:58,877::utils::738::root::(execCmd) /sbin/ip route show to 0.0.0.0/0 table all (cwd None)
MainThread::DEBUG::2014-09-18 13:06:58,880::utils::758::root::(execCmd) SUCCESS: <err> = ''; <rc> = 0

Comment 4 Yaniv Kaul 2016-03-21 10:15:25 UTC
it's confusing for support and community. I'd be happy if it can be fixed for 4.0.
If easy, I'd consider to backport to 3.6.x.

Comment 5 Sandro Bonazzola 2016-05-02 09:50:01 UTC
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.

Comment 6 Dan Kenigsberg 2016-05-18 10:51:19 UTC
*** Bug 1241464 has been marked as a duplicate of this bug. ***

Comment 7 Yaniv Lavi 2016-05-23 13:14:09 UTC
oVirt 4.0 beta has been released, moving to RC milestone.


Note You need to log in before you can comment on or make changes to this bug.