Bug 1241464 - configure nwfilter on vdsm-tool configure, instead of vdsmd startup
Summary: configure nwfilter on vdsm-tool configure, instead of vdsmd startup
Keywords:
Status: CLOSED DUPLICATE of bug 1121571
Alias: None
Product: vdsm
Classification: oVirt
Component: General
Version: ---
Hardware: Unspecified
OS: Unspecified
medium
low vote
Target Milestone: ovirt-4.0.0-beta
: ---
Assignee: Ondřej Svoboda
QA Contact: Meni Yakove
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-09 09:37 UTC by Ying Cui
Modified: 2016-05-18 10:51 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-18 10:51:19 UTC
oVirt Team: Network
ylavi: ovirt-4.0.0?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)
sosreport (6.77 MB, application/x-xz)
2015-07-09 09:45 UTC, Ying Cui
no flags Details

Description Ying Cui 2015-07-09 09:37:27 UTC
Description of problem:
After RHEV-H 6.7 installation, then start vdsmd manually for the _first_ time. then there will display libvirt error.

Version-Release number of selected component (if applicable):
# rpm -q ovirt-node vdsm libvirt qemu-kvm-rhev
ovirt-node-3.2.3-11.el6.noarch
vdsm-4.16.21-1.el6ev.x86_64
libvirt-0.10.2-54.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.479.el6.x86_64
# cat /etc/redhat-release 
Red Hat Enterprise Virtualization Hypervisor release 6.7 (20150707.0.el6ev)


How reproducible:
100%

Steps to Reproduce:
1. Installed RHEVH 6.7 successful.
2. Setup RHEV-H network via RHEV-H TUI.
3. F2 in shell
4. # service vdsmd start
vdsm: Running mkdirs
vdsm: Running configure_coredump
vdsm: Running configure_vdsm_logs
vdsm: Running wait_for_network
vdsm: Running run_init_hooks
vdsm: Running upgraded_version_check
vdsm: Running check_is_configured
libvirt is already configured for vdsm
vdsm: Running validate_configuration
SUCCESS: ssl configured to true. No conflicts
vdsm: Running prepare_transient_repository
vdsm: Running syslog_available
vdsm: Running nwfilter
libvirt: Network Filter Driver error : Network filter not found: no nwfilter with matching name 'vdsm-no-mac-spoofing'
vdsm: Running dummybr
vdsm: Running load_needed_modules
vdsm: Running tune_system
vdsm: Running test_space
vdsm: Running test_lo
Upgrading to unified persistence if needed
Upgrading to v3.x networking if needed
Starting up vdsm daemon: 
[  OK  ]
vdsm start[  OK  ]


Actual results:
libvirt: Network Filter Driver error : Network filter not found: no nwfilter with matching name 'vdsm-no-mac-spoofing'

Expected results:
Without such libvirt error

Additional info:
Not sure how impact on real functionality.

Comment 1 Ying Cui 2015-07-09 09:45:48 UTC
Created attachment 1050203 [details]
sosreport

Comment 2 Sandro Bonazzola 2016-05-02 09:51:54 UTC
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.

Comment 3 Dan Kenigsberg 2016-05-18 10:51:19 UTC

*** This bug has been marked as a duplicate of bug 1121571 ***


Note You need to log in before you can comment on or make changes to this bug.