Bug 1121596 - Deleting attribute present in nsslapd-allowed-to-delete-attrs returns Operations error
Summary: Deleting attribute present in nsslapd-allowed-to-delete-attrs returns Operati...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: 389-ds-base
Version: 6.6
Hardware: All
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Noriko Hosoi
QA Contact: Sankar Ramalingam
URL:
Whiteboard:
Depends On: 853106
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-21 10:16 UTC by Sankar Ramalingam
Modified: 2014-10-14 07:53 UTC (History)
6 users (show)

Fixed In Version: 389-ds-base-1.2.11.15-39.el6 389-ds-base-1.2.11.15-40.el6
Doc Type: Bug Fix
Doc Text:
Clone Of: 853106
Environment:
Last Closed: 2014-10-14 07:53:45 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1385 normal SHIPPED_LIVE 389-ds-base bug fix and enhancement update 2014-10-14 01:27:42 UTC

Comment 1 Sankar Ramalingam 2014-07-21 10:19:31 UTC
Steps to verify: Run Basic acceptance test suite for RHEL66. Observe the results for bug602456_12 through bug602456_14. If it passes, then the bugzilla can be marked Verified.

Comment 4 Sankar Ramalingam 2014-08-12 15:53:45 UTC
----------------- Starting Test bug602456_12 -------------------------
Deleting a new attribute which is part of nsslapd-allowed-to-delete at runtime from cn=config
Adding the nsslapd-require-secure-binds attribute to nsslapd-allowed-to-delete-attrs
modifying entry cn=config

Successfully completed Deleting the nsslapd-listenhost attribute from nsslapd-allowed-to-delete-attrs
modifying entry cn=config

Test result for bug602456_12, Deleting a new attribute which is part of nsslapd-allowed-to-delete at runtime from cn=config, Actual_Result=0, Expected_Result=0
TestCase [bug602456_12] result-> [PASS]



----------------- Starting Test bug602456_14 -------------------------
Adding a new invalid attribute to nsslapd-allowed-to-delete-attrs at runtime to cn=config
check instance: [/usr/lib/dirsrv/slapd-ibm-x3650m4-01-vm-06]
dn:
supportedldapversion: 2
supportedldapversion: 3
instance [/usr/lib/dirsrv/slapd-ibm-x3650m4-01-vm-06] is alive on port [31597]
Adding the nsslapd-allowed-to-delete-attrs attribute to nsslapd-allowed-to-delete-attrs - Negative test
modifying entry cn=config

Successfully completed Deleting nsslapd-allowed-to-delete-attrs
modifying entry cn=config

Test result for bug602456_14, Adding a new invalid attribute to nsslapd-allowed-to-delete-attrs at runtime to cn=config, Actual_Result=0, Expected_Result=0
TestCase [bug602456_14] result-> [PASS]
------------------Test bug602456_14 Completed-------------------------


Both the test cases from basic tests are PASSing with the latest build of 389-ds-base-1.2.11.15-39 build. Hence, marking the bug as Verified.

Comment 6 Noriko Hosoi 2014-08-17 22:59:20 UTC
Thank you, Sankar.

Fixed the regression in the 1.2.11 branch.

Comment 7 Sankar Ramalingam 2014-08-19 17:48:16 UTC
check instance: [/usr/lib64/dirsrv/slapd-hp-dl320g5-01]
dn:
supportedldapversion: 2
supportedldapversion: 3
instance [/usr/lib64/dirsrv/slapd-hp-dl320g5-01] is alive on port [34107]
/tet/tet/../testcases/DS/6.0/acceptance/basic/basic.sh: line 948: [: nsslapd-listen-backlog-size:: binary operator expected
Found the attribute: [nsslapd-listen-backlog-size: 128]
TestCase [bug969210_01] result-> [PASS]
[bug969210_02] Test configurability of listen (2) backlog -- change the value.
Fetching system backlog maximum [/proc/sys/net/ipv4/tcp_max_syn_backlog]
-----------------StartSlapd: Called -----------------
Calling StartSlapd /usr/lib64/dirsrv/slapd-hp-dl320g5-01
There is an ns-slapd running: 23605
check instance: [/usr/lib64/dirsrv/slapd-hp-dl320g5-01]
dn:
supportedldapversion: 2
supportedldapversion: 3
instance [/usr/lib64/dirsrv/slapd-hp-dl320g5-01] is alive on port [34107]
StartSlapd: Server successfully started
-----------------StartSlapd: Completed-----------------
                                                      
check instance: [/usr/lib64/dirsrv/slapd-hp-dl320g5-01]
dn:
supportedldapversion: 2
supportedldapversion: 3
instance [/usr/lib64/dirsrv/slapd-hp-dl320g5-01] is alive on port [34107]
Changing the listen backlog to 2048 entries.
modifying entry cn=config

ldapmodify operation successfull.
TestCase [bug969210_02] result-> [PASS]


Test cases for bug #969210 are passing. which is a clone of the actual bugzilla. Hence, marking the bug as Verified.
Build tested - 389-ds-base-1.2.11.15-40.

Comment 8 errata-xmlrpc 2014-10-14 07:53:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1385.html


Note You need to log in before you can comment on or make changes to this bug.