Bug 853106 - Deleting attribute present in nsslapd-allowed-to-delete-attrs returns Operations error
Deleting attribute present in nsslapd-allowed-to-delete-attrs returns Operati...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: 389-ds-base (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 7.0
Assigned To: Rich Megginson
Sankar Ramalingam
: Reopened
: 566320 (view as bug list)
Depends On:
Blocks: 1121596
  Show dependency treegraph
 
Reported: 2012-08-30 10:24 EDT by Ján Rusnačko
Modified: 2014-07-21 06:16 EDT (History)
5 users (show)

See Also:
Fixed In Version: 389-ds-base-1.3.1.6-17.el7
Doc Type: Bug Fix
Doc Text:
Cause: If the value of a configuration parameter is on|off or integer, it was not allowed to delete since it loses the default value. Consequence: Even if setting a config parameter to nsslapd- allowed-to-delete-attrs, the value failed to delete if the type was on|off or integer. Fix: Store all the initial config param values in ConfigList. If the attribute value is deleted, reset the initial value. Result: Any type of the configuration parameter is now be set to allow to delete.
Story Points: ---
Clone Of:
: 1121596 (view as bug list)
Environment:
Last Closed: 2014-06-13 08:08:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ján Rusnačko 2012-08-30 10:24:52 EDT
Description of problem:

See Bug 602456. Adding attribute to nsslapd-allowed-to-delete-attrs should allow attribute to be deleted. 


Version-Release number of selected component (if applicable): 389-ds-base-1.2.10.2-15.el6.x86_64 as well as 389-ds-base-1.2.11.7-2.el6.x86_64


How reproducible:
always

Steps to Reproduce:
1. Add nsslapd-require-secure-binds attribute to nsslapd-allowed-to-delete-attrs

ldapmodify  -h localhost -p 22222 -D "cn=Directory manager" -w dirmanager << EOF
dn: cn=config
changetype: modify
replace: nsslapd-allowed-to-delete-attrs
nsslapd-allowed-to-delete-attrs: nsslapd-securelistenhost nsslapd-listenhost nsslapd-require-secure-binds
EOF

2. Restart server
3. Delete nsslapd-require-secure-binds

ldapmodify  -h localhost -p 22222 -D "cn=Directory manager" -w dirmanager << EOF
dn: cn=config
changetype: modify
delete: nsslapd-require-secure-binds
EOF
  
Actual results:

modifying entry "cn=config"
ldap_modify: Operations error (1)
	additional info: nsslapd-require-secure-binds: NULL value


Expected results: Should succeed


Additional info: See Bug 602456. Automated in acceptance/basic/config as bug602456_12
Comment 1 Rich Megginson 2012-08-30 10:33:35 EDT
Upstream ticket:
https://fedorahosted.org/389/ticket/443
Comment 2 Noriko Hosoi 2012-11-07 13:06:18 EST
*** Bug 566320 has been marked as a duplicate of this bug. ***
Comment 3 Nathan Kinder 2013-03-04 18:07:21 EST
This was fixed in 389-ds-base-1.3.0-0.1.rc1.fc18.  Closing.
Comment 6 Ján Rusnačko 2013-11-13 04:58:32 EST
Deleting a new attribute which is part of nsslapd-allowed-to-delete at runtime from cn=config
Adding the nsslapd-require-secure-binds attribute to nsslapd-allowed-to-delete-attrs
modifying entry cn=config

Successfully completed Deleting the nsslapd-listenhost attribute from nsslapd-allowed-to-delete-attrs
modifying entry cn=config

Test result for bug602456_12, Deleting a new attribute which is part of nsslapd-allowed-to-delete at runtime from cn=config, Actual_Result=0, Expected_Result=0
TestCase [bug602456_12] result-> [PASS]
------------------Test bug602456_12 Completed-------------------------

Tested on 389-ds-base-1.3.1.6-7.el7.
Comment 7 Sankar Ramalingam 2014-01-30 00:00:27 EST
############## Result  for  backend test :   Basic run
    Basic run elapse time : 00:03:44
    Basic run Tests PASS      : 100% (63/63)

Build tested - 1.3.1.6-15

All test cases for basic acceptance tests are passing. Hence, marking the bug as Verified.
Comment 8 Ludek Smid 2014-06-13 08:08:32 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.